summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2006-10-02 21:36:04 +0000
committerVlastimil Babka <caster@gentoo.org>2006-10-02 21:36:04 +0000
commitb17a71d80b87cd3f8b42975bb55536f338f99ca5 (patch)
tree879d1de10a60d67a78b03f072cc723ee1a47d3c0 /dev-java/sun-jre-bin
parentKeywording ~amd64 (diff)
downloadgentoo-2-b17a71d80b87cd3f8b42975bb55536f338f99ca5.tar.gz
gentoo-2-b17a71d80b87cd3f8b42975bb55536f338f99ca5.tar.bz2
gentoo-2-b17a71d80b87cd3f8b42975bb55536f338f99ca5.zip
Restored stable 1.5.0.06 wrt bug #148738.
(Portage version: 2.1.2_pre2)
Diffstat (limited to 'dev-java/sun-jre-bin')
-rw-r--r--dev-java/sun-jre-bin/ChangeLog6
-rw-r--r--dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.066
-rw-r--r--dev-java/sun-jre-bin/sun-jre-bin-1.5.0.06.ebuild209
3 files changed, 220 insertions, 1 deletions
diff --git a/dev-java/sun-jre-bin/ChangeLog b/dev-java/sun-jre-bin/ChangeLog
index 2144925da73a..2b5541e9edda 100644
--- a/dev-java/sun-jre-bin/ChangeLog
+++ b/dev-java/sun-jre-bin/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-java/sun-jre-bin
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.59 2006/09/23 01:28:27 nichoj Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/ChangeLog,v 1.60 2006/10/02 21:36:04 caster Exp $
+
+ 02 Oct 2006; Vlastimil Babka <caster@gentoo.org>
+ +sun-jre-bin-1.5.0.06.ebuild:
+ Restored stable 1.5.0.06 wrt bug #148738.
23 Sep 2006; Joshua Nichols <nichoj@gentoo.org> metadata.xml,
sun-jre-bin-1.4.2.10.ebuild:
diff --git a/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.06 b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.06
new file mode 100644
index 000000000000..1927b3ed0548
--- /dev/null
+++ b/dev-java/sun-jre-bin/files/digest-sun-jre-bin-1.5.0.06
@@ -0,0 +1,6 @@
+MD5 6a771c3c9e93021ab34a30bcf609c74b jre-1_5_0_06-linux-amd64.bin 16403250
+RMD160 4309c9805c9595587e385bcfe951c693609b8560 jre-1_5_0_06-linux-amd64.bin 16403250
+SHA256 3caff8426bb55fa6f3e40738a537b9351ef5f38c5a50b1f5ac6756b16f4bcfee jre-1_5_0_06-linux-amd64.bin 16403250
+MD5 e0a88dbec9bfe3195794bb652bfc6516 jre-1_5_0_06-linux-i586.bin 16769166
+RMD160 b5f306da7d2569ab7698beaaa7dc2a662c04e876 jre-1_5_0_06-linux-i586.bin 16769166
+SHA256 316a925f5a4f3edd5bf64c138c3585d979f15a1ffb517798e8ed8f3bde5024fc jre-1_5_0_06-linux-i586.bin 16769166
diff --git a/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.06.ebuild b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.06.ebuild
new file mode 100644
index 000000000000..ce2b5bdfb5b1
--- /dev/null
+++ b/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.06.ebuild
@@ -0,0 +1,209 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/sun-jre-bin/sun-jre-bin-1.5.0.06.ebuild,v 1.10 2006/10/02 21:36:04 caster Exp $
+
+inherit java eutils
+
+MY_PVL=${PV%.*}_${PV##*.}
+MY_PVA=${PV//./_}
+
+amd64file="jre-${MY_PVA}-linux-amd64.bin"
+x86file="jre-${MY_PVA}-linux-i586.bin"
+
+if use x86; then
+ At=${x86file}
+elif use amd64; then
+ At=${amd64file}
+fi
+
+S="${WORKDIR}/jre${MY_PVL}"
+DESCRIPTION="Sun's J2SE Platform"
+HOMEPAGE="http://java.sun.com/j2se/"
+SRC_URI="x86? ( $x86file ) amd64? ( $amd64file )"
+SLOT="1.5"
+LICENSE="sun-bcla-java-vm"
+KEYWORDS="-* amd64 x86"
+RESTRICT="fetch stricter"
+IUSE="X alsa browserplugin nsplugin mozilla"
+
+DEPEND="sys-apps/sed"
+
+RDEPEND="sys-libs/glibc
+ alsa? ( media-libs/alsa-lib )
+ X? ( || ( (
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXp
+ x11-libs/libXt
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
+ )"
+
+
+PACKED_JARS="lib/rt.jar lib/jsse.jar lib/charsets.jar lib/ext/localedata.jar lib/plugin.jar lib/javaws.jar lib/deploy.jar"
+
+# this is needed for proper operating under a PaX kernel without activated grsecurity acl
+CHPAX_CONSERVATIVE_FLAGS="pemsv"
+
+FETCH_SDK="http://javashoplm.sun.com:80/ECom/docs/Welcome.jsp?StoreId=22&PartDetailId=jre-${MY_PVL}-oth-JPR&SiteId=JSC&TransactionId=noreg"
+
+
+pkg_nofetch() {
+ local archtext=""
+
+ if use x86; then
+ archtext="Linux"
+ elif use amd64; then
+ archtext="Linux AMD64"
+ fi
+
+ einfo "Please download ${At} from:"
+ einfo ${FETCH_SDK}
+ einfo "Select the ${archtext} self-extracting file"
+ einfo "and move it to ${DISTDIR}"
+}
+
+src_unpack() {
+ if [ ! -r ${DISTDIR}/${At} ]; then
+ die "cannot read ${At}. Please check the permission and try again."
+ fi
+
+ #Search for the ELF Header
+ testExp=`echo -e "\105\114\106"`
+ startAt=`grep -aonm 1 ${testExp} ${DISTDIR}/${At} | cut -d: -f1`
+ tail -n +${startAt} ${DISTDIR}/${At} > install.sfx
+ chmod +x install.sfx
+ ./install.sfx || die
+ rm install.sfx
+
+ if [ -f ${S}/bin/unpack200 ]; then
+ UNPACK_CMD=${S}/bin/unpack200
+ chmod +x $UNPACK_CMD
+ sed -i 's#/tmp/unpack.log#/dev/null\x00\x00\x00\x00\x00\x00#g' $UNPACK_CMD
+ for i in $PACKED_JARS; do
+ PACK_FILE=${S}/`dirname $i`/`basename $i .jar`.pack
+ if [ -f ${PACK_FILE} ]; then
+ echo " unpacking: $i"
+ $UNPACK_CMD ${PACK_FILE} ${S}/$i
+ rm -f ${PACK_FILE}
+ fi
+ done
+ rm -f ${UNPACK_CMD}
+ else
+ die "unpack not found"
+ fi
+}
+
+src_install() {
+
+ if use amd64; then
+ local dirs="bin lib man"
+ else
+ local dirs="bin lib man plugin javaws"
+ fi
+
+
+ dodir /opt/${P}
+
+ for i in $dirs ; do
+ cp -pPR $i ${D}/opt/${P}/ || die "failed to build"
+ done
+
+ dodoc COPYRIGHT README
+ dohtml Welcome.html
+
+ if use nsplugin || # global useflag for netscape-compat plugins
+ use browserplugin || # deprecated but honor for now
+ use mozilla; then # wrong but used to honor it
+ local plugin_dir="ns7-gcc29"
+ if has_version '>=sys-devel/gcc-3' ; then
+ plugin_dir="ns7"
+ fi
+
+ if use x86 ; then
+ install_mozilla_plugin /opt/${P}/plugin/i386/$plugin_dir/libjavaplugin_oji.so
+ else
+ eerror "No plugin available for amd64 arch"
+ fi
+ fi
+
+ # create dir for system preferences
+ dodir /opt/${P}/.systemPrefs
+
+ # install control panel for Gnome/KDE
+ sed -e "s/INSTALL_DIR\/JRE_NAME_VERSION/\/opt\/${P}/" \
+ -e "s/\(Name=Java\)/\1 Control Panel/" \
+ ${D}/opt/${P}/plugin/desktop/sun_java.desktop > \
+ ${T}/sun_java-jre.desktop
+
+ domenu ${T}/sun_java-jre.desktop
+
+ set_java_env ${FILESDIR}/${VMHANDLE}
+}
+
+pkg_postinst() {
+ # Create files used as storage for system preferences.
+ PREFS_LOCATION=/opt/${P}/
+ mkdir -p ${PREFS_LOCATION}/.systemPrefs
+ if [ ! -f ${PREFS_LOCATION}/.systemPrefs/.system.lock ] ; then
+ touch $PREFS_LOCATION/.systemPrefs/.system.lock
+ chmod 644 $PREFS_LOCATION/.systemPrefs/.system.lock
+ fi
+ if [ ! -f $PREFS_LOCATION/.systemPrefs/.systemRootModFile ] ; then
+ touch $PREFS_LOCATION/.systemPrefs/.systemRootModFile
+ chmod 644 $PREFS_LOCATION/.systemPrefs/.systemRootModFile
+ fi
+
+ # Set as default VM if none exists
+ java_pkg_postinst
+
+ if ! use nsplugin && ( use browserplugin || use mozilla ); then
+ echo
+ ewarn "The 'browserplugin' and 'mozilla' useflags will not be honored in"
+ ewarn "future jdk/jre ebuilds for plugin installation. Please"
+ ewarn "update your USE to include 'nsplugin'."
+ fi
+
+ # Show info about netscape
+ if has_version '>=www-client/netscape-navigator-4.79-r1' || has_version '>=www-client/netscape-communicator-4.79-r1' ; then
+ echo
+ einfo "If you want to install the plugin for Netscape 4.x, type"
+ einfo
+ einfo " cd /usr/lib/nsbrowser/plugins/"
+ einfo " ln -sf /opt/${P}/plugin/i386/ns4/libjavaplugin.so"
+ fi
+
+ # if chpax is on the target system, set the appropriate PaX flags
+ # this will not hurt the binary, it modifies only unused ELF bits
+ # but may confuse things like AV scanners and automatic tripwire
+ if has_version sys-apps/chpax
+ then
+ echo
+ einfo "setting up conservative PaX flags for jar, javac and java"
+
+ for paxkills in "java"
+ do
+ chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/$paxkills
+ done
+
+ # /opt/$VM/bin/java_vm
+ chpax -${CHPAX_CONSERVATIVE_FLAGS} /opt/${P}/bin/java_vm
+
+ einfo "you should have seen lots of chpax output above now"
+ ewarn "make sure the grsec ACL contains those entries also"
+ ewarn "because enabling it will override the chpax setting"
+ ewarn "on the physical files - help for PaX and grsecurity"
+ ewarn "can be given by #gentoo-hardened + hardened@gentoo.org"
+ fi
+
+ if ! use X; then
+ local xwarn="virtual/x11 and/or"
+ fi
+
+ echo
+ ewarn "Some parts of Sun's JRE require ${xwarn} virtual/lpr to be installed."
+ ewarn "Be careful which Java libraries you attempt to use."
+}