summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-26 16:09:54 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-26 16:09:54 +0000
commitb8096ecdfa8d3777ceecfd177a9aadc202533121 (patch)
treeaa0dafe66b1cc855488708457ee6ce61ec129bc8 /dev-java/snip/snip-0.11.ebuild
parentRemove example use flag from ruby.eclass, #145222 (diff)
downloadgentoo-2-b8096ecdfa8d3777ceecfd177a9aadc202533121.tar.gz
gentoo-2-b8096ecdfa8d3777ceecfd177a9aadc202533121.tar.bz2
gentoo-2-b8096ecdfa8d3777ceecfd177a9aadc202533121.zip
Initial commit. Original ebuild by Iván Pérez Domínguez <iperez@babel.ls.fi.upm.es> and then improved by me. Fixes bug #145936.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'dev-java/snip/snip-0.11.ebuild')
-rw-r--r--dev-java/snip/snip-0.11.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-java/snip/snip-0.11.ebuild b/dev-java/snip/snip-0.11.ebuild
new file mode 100644
index 000000000000..04d9cf986679
--- /dev/null
+++ b/dev-java/snip/snip-0.11.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/snip/snip-0.11.ebuild,v 1.1 2007/01/26 16:09:54 betelgeuse Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="an Apache ANT optional task that extracts snippets of code from text files"
+HOMEPAGE="http://www.martiansoftware.com/lab/index.html"
+SRC_URI="http://www.martiansoftware.com/lab/${PN}/${P}-src.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc source"
+
+COMMON_DEP=">=dev-java/ant-core-1.5.4"
+RDEPEND=">=virtual/jre-1.4
+ ${COMMON_DEP}"
+DEPEND=">=virtual/jdk-1.4
+ ${COMMON_DEP}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ rm -v *.jar
+ epatch "${FILESDIR}/${PN}-0.11-build.xml.patch"
+ java-ant_rewrite-classpath
+ eant clean
+}
+
+EANT_GENTOO_CLASSPATH="ant-core"
+
+src_install() {
+ java-pkg_newjar dist/${P}.jar ${PN}.jar
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/java/com
+}
+