summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2008-06-17 14:01:51 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2008-06-17 14:01:51 +0000
commitf546dffa248d590aef2d05ba37a6f354a1717a31 (patch)
tree944d0d5ed9b703c68a15badece80d902f6e9898a /dev-java/mx4j-core
parentInclude mx4j in hessian mask. (diff)
downloadgentoo-2-f546dffa248d590aef2d05ba37a6f354a1717a31.tar.gz
gentoo-2-f546dffa248d590aef2d05ba37a6f354a1717a31.tar.bz2
gentoo-2-f546dffa248d590aef2d05ba37a6f354a1717a31.zip
Version bump.
(Portage version: 2.1.5.5)
Diffstat (limited to 'dev-java/mx4j-core')
-rw-r--r--dev-java/mx4j-core/ChangeLog10
-rw-r--r--dev-java/mx4j-core/files/mx4j-core-3.0.2-split-javadoc-build.patch45
-rw-r--r--dev-java/mx4j-core/mx4j-core-3.0.2.ebuild60
3 files changed, 113 insertions, 2 deletions
diff --git a/dev-java/mx4j-core/ChangeLog b/dev-java/mx4j-core/ChangeLog
index 8a70762d516d..62fbfaf5360c 100644
--- a/dev-java/mx4j-core/ChangeLog
+++ b/dev-java/mx4j-core/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/mx4j-core
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/mx4j-core/ChangeLog,v 1.8 2007/07/29 23:47:54 tgall Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/mx4j-core/ChangeLog,v 1.9 2008/06/17 14:01:51 nelchael Exp $
+
+*mx4j-core-3.0.2 (17 Jun 2008)
+
+ 17 Jun 2008; Krzysiek Pawlik <nelchael@gentoo.org>
+ +files/mx4j-core-3.0.2-split-javadoc-build.patch, +mx4j-core-3.0.2.ebuild:
+ Version bump.
29 Jul 2007; Tom Gall <tgall@gentoo.org> mx4j-core-3.0.1.ebuild:
stable on ppc64
diff --git a/dev-java/mx4j-core/files/mx4j-core-3.0.2-split-javadoc-build.patch b/dev-java/mx4j-core/files/mx4j-core-3.0.2-split-javadoc-build.patch
new file mode 100644
index 000000000000..9fba649e1f45
--- /dev/null
+++ b/dev-java/mx4j-core/files/mx4j-core-3.0.2-split-javadoc-build.patch
@@ -0,0 +1,45 @@
+diff -Nru mx4j-3.0.2.vanilla/build/build.xml mx4j-3.0.2/build/build.xml
+--- mx4j-3.0.2.vanilla/build/build.xml 2008-06-17 15:32:02.000000000 +0200
++++ mx4j-3.0.2/build/build.xml 2008-06-17 15:34:06.000000000 +0200
+@@ -407,7 +407,7 @@
+ </jar>
+ </target>
+
+- <target name="javadocs" description="Creates the MX4J javadoc documentation" depends="compile.tools">
++ <target name="javadocs.core" description="Creates the MX4J javadoc documentation" depends="compile.rjmx">
+ <mkdir dir="${dist.docs.api.dir}"/>
+ <javadoc destdir="${dist.docs.api.dir}"
+ author="true"
+@@ -421,6 +421,23 @@
+ <group title="MX4J classes" packages="mx4j:mx4j.*"/>
+ <sourcepath>
+ <pathelement path="${core.src.dir}"/>
++ </sourcepath>
++ </javadoc>
++ </target>
++
++ <target name="javadocs.tools" description="Creates the MX4J javadoc documentation" depends="compile.tools">
++ <mkdir dir="${dist.docs.api.dir}"/>
++ <javadoc destdir="${dist.docs.api.dir}"
++ author="true"
++ version="true"
++ use="true"
++ windowtitle="MX4J API"
++ classpathref="classpath">
++ <package name="mx4j.*"/>
++
++ <bottom><![CDATA[<center><small>Copyright &#169; 2001-2005 The MX4J Contributors. All Rights Reserved.</small></center>]]></bottom>
++ <group title="MX4J classes" packages="mx4j:mx4j.*"/>
++ <sourcepath>
+ <pathelement path="${tools.src.dir}"/>
+ </sourcepath>
+ </javadoc>
+@@ -468,7 +485,7 @@
+
+ <target name="main" depends="tests, compile.examples"/>
+
+- <target name="release" description="Builds a release of the MX4J project" depends="clean, manifest, releasing, main, docs, javadocs">
++ <target name="release" description="Builds a release of the MX4J project" depends="clean, manifest, releasing, main, docs, javadocs.core">
+ <mkdir dir="${release.dist.dir}"/>
+ <mkdir dir="${binary.release.dist.dir}"/>
+ <mkdir dir="${source.release.dist.dir}"/>
diff --git a/dev-java/mx4j-core/mx4j-core-3.0.2.ebuild b/dev-java/mx4j-core/mx4j-core-3.0.2.ebuild
new file mode 100644
index 000000000000..48bcfc32d18f
--- /dev/null
+++ b/dev-java/mx4j-core/mx4j-core-3.0.2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/mx4j-core/mx4j-core-3.0.2.ebuild,v 1.1 2008/06/17 14:01:51 nelchael Exp $
+
+inherit eutils java-pkg-2 java-ant-2
+
+MY_P="${P/-core/}"
+DESCRIPTION="Open Source implementation of the JMX and JMX Remote API (JSR 160) specifications"
+HOMEPAGE="http://mx4j.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}-src.tar.gz"
+
+# The ${S}/BUILD-HOWTO is a good source for dependencies
+# This package could also be built with jdk-1.3; see special
+# handling instructions in ${S}/BUILD-HOWTO.
+
+RDEPEND="dev-java/bcel
+ dev-java/commons-logging
+ dev-java/log4j"
+DEPEND="${RDEPEND}
+ >=virtual/jdk-1.5
+ >=dev-java/ant-core-1.6
+ source? ( app-arch/zip )"
+RDEPEND="${RDEPEND}
+ >=virtual/jre-1.5"
+
+LICENSE="mx4j"
+SLOT="3.0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE="doc source"
+
+S="${WORKDIR}/${MY_P}"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-split-javadoc-build.patch"
+
+ cd "${S}/lib"
+ java-pkg_jar-from bcel bcel.jar
+ java-pkg_jar-from commons-logging commons-logging.jar
+ java-pkg_jar-from log4j
+}
+
+src_compile() {
+ eant -f build/build.xml compile.jmx compile.rjmx $(use_doc javadocs.core)
+}
+
+src_install() {
+ java-pkg_dojar dist/lib/*.jar
+ dodoc README.txt
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc "${S}/src/core/*"
+}
+
+pkg_postinst() {
+ elog "This is a a new split ebuild for just the core jmx to reduce"
+ elog "dependencies for packages that only require the core. You can"
+ elog "find the examples in dev-java/mx4j and the tools in dev-java/mx4j-tools"
+}