summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Nichols <nichoj@gentoo.org>2006-09-14 20:02:20 +0000
committerJoshua Nichols <nichoj@gentoo.org>2006-09-14 20:02:20 +0000
commit4598d46ca655d0ea926b85a3eb35f00d8c8f2b4e (patch)
tree107968fbe6d8cf4fb99d7a4ece59a26f345f6b8d /dev-java/libgconf-java
parentAdd comment to ebuild for future reference. (diff)
downloadgentoo-2-4598d46ca655d0ea926b85a3eb35f00d8c8f2b4e.tar.gz
gentoo-2-4598d46ca655d0ea926b85a3eb35f00d8c8f2b4e.tar.bz2
gentoo-2-4598d46ca655d0ea926b85a3eb35f00d8c8f2b4e.zip
Added calls to java-pkg_pkg_setup, see bug #142708. Cleaned up whitespace. Removed compnerd as maintainer.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-java/libgconf-java')
-rw-r--r--dev-java/libgconf-java/ChangeLog8
-rw-r--r--dev-java/libgconf-java/libgconf-java-2.10.1.ebuild12
-rw-r--r--dev-java/libgconf-java/libgconf-java-2.12.1-r1.ebuild18
-rw-r--r--dev-java/libgconf-java/libgconf-java-2.12.1.ebuild25
-rw-r--r--dev-java/libgconf-java/libgconf-java-2.8.3.1.ebuild14
-rw-r--r--dev-java/libgconf-java/metadata.xml8
6 files changed, 39 insertions, 46 deletions
diff --git a/dev-java/libgconf-java/ChangeLog b/dev-java/libgconf-java/ChangeLog
index 18fa28bb4aea..58fa65f4d51b 100644
--- a/dev-java/libgconf-java/ChangeLog
+++ b/dev-java/libgconf-java/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/libgconf-java
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/ChangeLog,v 1.16 2006/07/17 19:12:30 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/ChangeLog,v 1.17 2006/09/14 20:02:20 nichoj Exp $
+
+ 14 Sep 2006; Joshua Nichols <nichoj@gentoo.org> metadata.xml,
+ libgconf-java-2.8.3.1.ebuild, libgconf-java-2.10.1.ebuild,
+ libgconf-java-2.12.1.ebuild, libgconf-java-2.12.1-r1.ebuild:
+ Added calls to java-pkg_pkg_setup, see bug #142708. Cleaned up whitespace.
+ Removed compnerd as maintainer.
17 Jul 2006; Daniel Gryniewicz <dang@gentoo.org>
libgconf-java-2.12.1-r1.ebuild:
diff --git a/dev-java/libgconf-java/libgconf-java-2.10.1.ebuild b/dev-java/libgconf-java/libgconf-java-2.10.1.ebuild
index 9991146c626a..7f981a052c6d 100644
--- a/dev-java/libgconf-java/libgconf-java-2.10.1.ebuild
+++ b/dev-java/libgconf-java/libgconf-java-2.10.1.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.10.1.ebuild,v 1.3 2005/07/19 11:58:20 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.10.1.ebuild,v 1.4 2006/09/14 20:02:20 nichoj Exp $
#
-# WARNING: Because java-gnome is a set of bindings to native GNOME libraries,
-# it has, like any GNOME project, a massive autoconf setup, and unlike many
+# WARNING: Because java-gnome is a set of bindings to native GNOME libraries,
+# it has, like any GNOME project, a massive autoconf setup, and unlike many
# other java libraries, it has its own [necessary] `make install` step.
# As a result, this ebuild is VERY sensitive to the internal layout of the
# upstream project. Because these issues are currently evolving upstream,
# simply version bumping this ebuild is not likely to work but FAILURES WILL
# BE VERY SUBTLE IF IT DOES NOT WORK.
-#
+#
inherit eutils gnome.org
@@ -67,7 +67,7 @@ src_install() {
cd ${S}/src/java
find . -name '*.java' | xargs zip ${D}/usr/share/${PN}-${SLOT}/src/libgconf-java-${PV}.src.zip
- # with dojar misbehaving, better do to this manually for the
+ # with dojar misbehaving, better do to this manually for the
# time being. Yes, this is bad hard coding, but what in this ebuild isn't?
echo "DESCRIPTION=${DESCRIPTION}" \
diff --git a/dev-java/libgconf-java/libgconf-java-2.12.1-r1.ebuild b/dev-java/libgconf-java/libgconf-java-2.12.1-r1.ebuild
index 3df930afcc5f..44d3628bc10d 100644
--- a/dev-java/libgconf-java/libgconf-java-2.12.1-r1.ebuild
+++ b/dev-java/libgconf-java/libgconf-java-2.12.1-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.12.1-r1.ebuild,v 1.4 2006/07/17 19:12:30 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.12.1-r1.ebuild,v 1.5 2006/09/14 20:02:20 nichoj Exp $
# Must be before the gnome.org inherit
GNOME_TARBALL_SUFFIX="gz"
-
inherit java-pkg eutils gnome.org
DESCRIPTION="Java bindings for Glade"
@@ -19,18 +18,17 @@ KEYWORDS="amd64 ppc x86"
IUSE="doc gcj source"
DEPS=">=gnome-base/gconf-2.12.0
- >=dev-java/glib-java-0.2.1
- >=dev-java/libgtk-java-2.8.1
- >=dev-java/libgnome-java-2.8.0
- dev-util/pkgconfig"
-
+ >=dev-java/glib-java-0.2.1
+ >=dev-java/libgtk-java-2.8.1
+ >=dev-java/libgnome-java-2.8.0"
DEPEND=">=virtual/jdk-1.4
- >=sys-apps/sed-4
- ${DEPS}"
+ ${DEPS}"
RDEPEND=">=virtual/jre-1.4
- ${DEPS}"
+ ${DEPS}"
JARNAME="gconf${SLOT}.jar"
+
pkg_setup() {
+ java-pkg_pkg_setup
if use gcj ; then
if ! built_with_use sys-devel/gcc gcj ; then
ewarn
diff --git a/dev-java/libgconf-java/libgconf-java-2.12.1.ebuild b/dev-java/libgconf-java/libgconf-java-2.12.1.ebuild
index 1636d59de85b..6d73296214b1 100644
--- a/dev-java/libgconf-java/libgconf-java-2.12.1.ebuild
+++ b/dev-java/libgconf-java/libgconf-java-2.12.1.ebuild
@@ -1,10 +1,9 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.12.1.ebuild,v 1.5 2005/12/30 02:52:06 compnerd Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.12.1.ebuild,v 1.6 2006/09/14 20:02:20 nichoj Exp $
# Must be before the gnome.org inherit
GNOME_TARBALL_SUFFIX="gz"
-
inherit java-pkg eutils gnome.org
DESCRIPTION="Java bindings for Glade"
@@ -19,18 +18,16 @@ KEYWORDS="~amd64 ~ppc ~x86"
IUSE="doc gcj"
DEPS=">=gnome-base/gconf-2.12.0
- >=dev-java/glib-java-0.2.1
- >=dev-java/libgtk-java-2.8.1
- >=dev-java/libgnome-java-2.8.0
- dev-util/pkgconfig"
-
+ >=dev-java/glib-java-0.2.1
+ >=dev-java/libgtk-java-2.8.1
+ >=dev-java/libgnome-java-2.8.0"
DEPEND=">=virtual/jdk-1.4
- >=sys-apps/sed-4
- ${DEPS}"
+ ${DEPS}"
RDEPEND=">=virtual/jre-1.4
- ${DEPS}"
+ ${DEPS}"
pkg_setup() {
+ java-pkg_pkg_setup
if use gcj ; then
if ! built_with_use sys-devel/gcc gcj ; then
ewarn
@@ -45,9 +42,9 @@ pkg_setup() {
src_compile() {
# JARDIR is a hack for java-config
econf $(use_with gcj gcj-compile) \
- $(use_with doc javadocs) \
- --with-jardir=/usr/share/${PN}-${SLOT}/lib \
- || die "configure failed"
+ $(use_with doc javadocs) \
+ --with-jardir=/usr/share/${PN}-${SLOT}/lib \
+ || die "configure failed"
emake || die "compile failed"
diff --git a/dev-java/libgconf-java/libgconf-java-2.8.3.1.ebuild b/dev-java/libgconf-java/libgconf-java-2.8.3.1.ebuild
index 8cf4440be480..490f2535be63 100644
--- a/dev-java/libgconf-java/libgconf-java-2.8.3.1.ebuild
+++ b/dev-java/libgconf-java/libgconf-java-2.8.3.1.ebuild
@@ -1,16 +1,16 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.8.3.1.ebuild,v 1.5 2005/07/19 11:58:20 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/libgconf-java/libgconf-java-2.8.3.1.ebuild,v 1.6 2006/09/14 20:02:20 nichoj Exp $
#
-# WARNING: Because java-gnome is a set of bindings to native GNOME libraries,
-# it has, like any GNOME project, a massive autoconf setup, and unlike many
+# WARNING: Because java-gnome is a set of bindings to native GNOME libraries,
+# it has, like any GNOME project, a massive autoconf setup, and unlike many
# other java libraries, it has its own [necessary] `make install` step.
# As a result, this ebuild is VERY sensitive to the internal layout of the
# upstream project. Because these issues are currently evolving upstream,
# simply version bumping this ebuild is not likely to work but FAILURES WILL
# BE VERY SUBTLE IF IT DOES NOT WORK.
-#
+#
inherit eutils gnome.org
@@ -71,7 +71,7 @@ src_install() {
# the upstream install scatters things around a bit. The following cleans
# that up to make it policy compliant.
- # I originally tried java-pkg_dojar here, but it has a few glitches
+ # I originally tried java-pkg_dojar here, but it has a few glitches
# like not copying symlinks as symlinks which makes a mess.
dodir /usr/share/${PN}-${SLOT}/lib
@@ -82,7 +82,7 @@ src_install() {
cd ${S}/src/java
zip -r ${D}/usr/share/${PN}-${SLOT}/src/libgconf-java-${PV}.src.zip *
- # again, with dojar misbehaving, better do to this manually for the
+ # again, with dojar misbehaving, better do to this manually for the
# time being. Yes, this is bad hard coding, but what in this ebuild isn't?
echo "DESCRIPTION=${DESCRIPTION}" \
diff --git a/dev-java/libgconf-java/metadata.xml b/dev-java/libgconf-java/metadata.xml
index 950fc8fdf788..56ce88eafafb 100644
--- a/dev-java/libgconf-java/metadata.xml
+++ b/dev-java/libgconf-java/metadata.xml
@@ -2,14 +2,6 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>java</herd>
- <maintainer>
- <email>andrew@operationaldynamics.com</email>
- <name>Andrew Cowie</name>
- </maintainer>
- <maintainer>
- <email>compnerd@gentoo.org</email>
- <name>Saleem Abdulrasool</name>
- </maintainer>
<longdescription>
An elegant set of language bindings to allow you to write
native GNOME applications in Java. Works with both traditional