summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2011-01-28 01:29:27 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2011-01-28 01:29:27 +0000
commit8b59862d591fc738b50edfc2aaeeeb4ca42058c7 (patch)
tree6917613825220de7bc06cc486a8e33dce23c0ffb /dev-java/jsch
parentVersion bump 0.16.1, remove old (diff)
downloadgentoo-2-8b59862d591fc738b50edfc2aaeeeb4ca42058c7.tar.gz
gentoo-2-8b59862d591fc738b50edfc2aaeeeb4ca42058c7.tar.bz2
gentoo-2-8b59862d591fc738b50edfc2aaeeeb4ca42058c7.zip
dev-java/jsch: version bump
(Portage version: 2.1.9.35/cvs/Linux x86_64)
Diffstat (limited to 'dev-java/jsch')
-rw-r--r--dev-java/jsch/ChangeLog9
-rw-r--r--dev-java/jsch/jsch-0.1.44.ebuild45
2 files changed, 52 insertions, 2 deletions
diff --git a/dev-java/jsch/ChangeLog b/dev-java/jsch/ChangeLog
index 75e97874bf81..dfbf4a49caef 100644
--- a/dev-java/jsch/ChangeLog
+++ b/dev-java/jsch/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jsch
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jsch/ChangeLog,v 1.77 2010/07/16 20:34:50 grobian Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jsch/ChangeLog,v 1.78 2011/01/28 01:29:27 fordfrog Exp $
+
+*jsch-0.1.44 (28 Jan 2011)
+
+ 28 Jan 2011; Miroslav Šulc <fordfrog@gentoo.org> +jsch-0.1.44.ebuild:
+ Version bump
16 Jul 2010; Fabian Groffen <grobian@gentoo.org> jsch-0.1.41.ebuild:
Marked ~x64-macos
diff --git a/dev-java/jsch/jsch-0.1.44.ebuild b/dev-java/jsch/jsch-0.1.44.ebuild
new file mode 100644
index 000000000000..193b51db7dd6
--- /dev/null
+++ b/dev-java/jsch/jsch-0.1.44.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jsch/jsch-0.1.44.ebuild,v 1.1 2011/01/28 01:29:27 fordfrog Exp $
+
+EAPI="2"
+JAVA_PKG_IUSE="doc source examples"
+
+inherit java-pkg-2 java-ant-2 java-osgi
+
+DESCRIPTION="JSch is a pure Java implementation of SSH2."
+HOMEPAGE="http://www.jcraft.com/jsch/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.zip"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="zlib"
+
+RDEPEND=">=virtual/jdk-1.5
+ zlib? ( dev-java/jzlib:0 )"
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip
+ ${RDEPEND}"
+
+EANT_BUILD_TARGET="dist"
+JAVA_ANT_REWRITE_CLASSPATH="true"
+
+src_compile() {
+ if use zlib; then
+ EANT_EXTRA_ARGS="-Djzlib.available=true"
+ EANT_GENTOO_CLASSPATH="jzlib"
+ fi
+
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ java-osgi_newjar dist/lib/jsch*.jar "com.jcraft.jsch" "JSch" \
+ "com.jcraft.jsch, com.jcraft.jsch.jce;x-internal:=true, \
+com.jcraft.jsch.jcraft;x-internal:=true"
+
+ dodoc README ChangeLog || die
+ use doc && java-pkg_dojavadoc javadoc
+ use source && java-pkg_dosrc src/*
+ use examples && java-pkg_doexamples examples
+}