summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 21:10:40 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-07-22 21:10:40 +0000
commit8ae4a0b2e75f788cad3952cf1ecd4459263e8e7b (patch)
tree39981bb994ef8259e8bcd84471b92c2478f27735 /dev-java/jisp/jisp-2.5.1-r2.ebuild
parentant_src_unpack -> src_unpack (diff)
downloadgentoo-2-8ae4a0b2e75f788cad3952cf1ecd4459263e8e7b.tar.gz
gentoo-2-8ae4a0b2e75f788cad3952cf1ecd4459263e8e7b.tar.bz2
gentoo-2-8ae4a0b2e75f788cad3952cf1ecd4459263e8e7b.zip
ant_src_unpack -> src_unpack
(Portage version: 2.1.1_pre3-r3)
Diffstat (limited to 'dev-java/jisp/jisp-2.5.1-r2.ebuild')
-rw-r--r--dev-java/jisp/jisp-2.5.1-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-java/jisp/jisp-2.5.1-r2.ebuild b/dev-java/jisp/jisp-2.5.1-r2.ebuild
new file mode 100644
index 000000000000..5ac4602304c1
--- /dev/null
+++ b/dev-java/jisp/jisp-2.5.1-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jisp/jisp-2.5.1-r2.ebuild,v 1.1 2006/07/22 21:10:40 nelchael Exp $
+
+inherit java-pkg-2 java-ant-2 eutils
+
+DESCRIPTION="Java Indexed Serialization Package: A small, embedded database engine written in Pure Java"
+HOMEPAGE="http://www.coyotegulch.com/products/jisp/"
+
+# TODO contact upstream about hosting jisp-2.5 on their site.
+# They only maintain 3.0 at the moment
+# This tarball is from jpackage's jisp2 source rpm
+SRC_URI="http://gentooexperimental.org/distfiles/${P}-source.tar.gz"
+
+LICENSE="SVFL"
+SLOT="2.5"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND=">=virtual/jdk-1.4
+ dev-java/ant-core"
+RDEPEND=">=virtual/jre-1.4"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${P}-java15.patch
+
+ mkdir src
+ mv com src
+ cp ${FILESDIR}/build-${PV}.xml build.xml
+}
+
+src_compile() {
+ eant jar -Dproject.name=${PN} $(use_doc)
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+
+ use doc && java-pkg_dohtml -r dist/doc/api
+}