summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohann Schmitz <ercpe@gentoo.org>2014-07-11 17:45:44 +0000
committerJohann Schmitz <ercpe@gentoo.org>2014-07-11 17:45:44 +0000
commit4592f4dd0d3d9fd3d56949828c28c6c5ca66cc80 (patch)
tree6773e5b20212125dea48c6dc43c391515ad6f99b /dev-java/jgoodies-looks
parentppc64 stable wrt bug #498660 (diff)
downloadgentoo-2-4592f4dd0d3d9fd3d56949828c28c6c5ca66cc80.tar.gz
gentoo-2-4592f4dd0d3d9fd3d56949828c28c6c5ca66cc80.tar.bz2
gentoo-2-4592f4dd0d3d9fd3d56949828c28c6c5ca66cc80.zip
Version bump of jgoodies-looks
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 77C501ED)
Diffstat (limited to 'dev-java/jgoodies-looks')
-rw-r--r--dev-java/jgoodies-looks/ChangeLog10
-rw-r--r--dev-java/jgoodies-looks/jgoodies-looks-2.6.0.ebuild40
2 files changed, 47 insertions, 3 deletions
diff --git a/dev-java/jgoodies-looks/ChangeLog b/dev-java/jgoodies-looks/ChangeLog
index 19a3baa26648..7a24933e6866 100644
--- a/dev-java/jgoodies-looks/ChangeLog
+++ b/dev-java/jgoodies-looks/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/jgoodies-looks
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-looks/ChangeLog,v 1.42 2010/10/17 12:30:01 caster Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-looks/ChangeLog,v 1.43 2014/07/11 17:45:44 ercpe Exp $
+
+*jgoodies-looks-2.6.0 (11 Jul 2014)
+
+ 11 Jul 2014; Johann Schmitz <ercpe@gentoo.org> +jgoodies-looks-2.6.0.ebuild:
+ Version bump of jgoodies-looks
17 Oct 2010; Vlastimil Babka <caster@gentoo.org> -files/plastic-1.3.2.txt,
-files/build-1.3.2.xml, -files/build-2.0.4.xml,
@@ -216,4 +221,3 @@
+files/build.xml, +files/plastic.txt, +jgoodies-looks-1.2.2.ebuild:
Initial import. Ebuild contributed by Saleem A. <compnerd@gentoo.org>. Fixes
#74996.
-
diff --git a/dev-java/jgoodies-looks/jgoodies-looks-2.6.0.ebuild b/dev-java/jgoodies-looks/jgoodies-looks-2.6.0.ebuild
new file mode 100644
index 000000000000..8a33fbf2fd73
--- /dev/null
+++ b/dev-java/jgoodies-looks/jgoodies-looks-2.6.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jgoodies-looks/jgoodies-looks-2.6.0.ebuild,v 1.1 2014/07/11 17:45:44 ercpe Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="doc source"
+
+inherit java-pkg-2 java-pkg-simple
+
+MY_PN="looks"
+MY_PV=${PV//./_}
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="JGoodies Looks Library"
+HOMEPAGE="http://www.jgoodies.com/"
+SRC_URI="http://www.jgoodies.com/download/libraries/${MY_PN}/${MY_P}.zip"
+
+LICENSE="BSD"
+SLOT="2.6"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-java/jgoodies-common:1.8"
+DEPEND=">=virtual/jdk-1.6
+ app-arch/unzip
+ ${COMMON_DEPEND}"
+RDEPEND=">=virtual/jre-1.6
+ ${COMMON_DEPEND}"
+
+S="${WORKDIR}"/${P}
+
+JAVA_SRC_DIR="src"
+JAVA_GENTOO_CLASSPATH="jgoodies-common-1.8"
+
+java_prepare() {
+ mkdir src || die
+ unzip ${P}-sources.jar -d src || die
+ rm "${S}"/pom.xml "${S}"/*.jar || die
+}