summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2014-04-22 00:00:28 +0000
committerTom Wijsman <tomwij@gentoo.org>2014-04-22 00:00:28 +0000
commitf66e7bd8fc419c506ec3804ef7d53111986cab3c (patch)
tree6c4b36478d39c5e7e5e50679e3c0cc0d69d1f5b0 /dev-java/icu4j
parentversion bump wrt #508316 (diff)
downloadgentoo-2-f66e7bd8fc419c506ec3804ef7d53111986cab3c.tar.gz
gentoo-2-f66e7bd8fc419c506ec3804ef7d53111986cab3c.tar.bz2
gentoo-2-f66e7bd8fc419c506ec3804ef7d53111986cab3c.zip
Version bump to 53.1; fixes bug #507660, reported by Arfrever Frehtes Taifersar Arahesis (arfrever.fta).
(Portage version: HEAD/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/icu4j')
-rw-r--r--dev-java/icu4j/ChangeLog8
-rw-r--r--dev-java/icu4j/icu4j-53.1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-java/icu4j/ChangeLog b/dev-java/icu4j/ChangeLog
index 1de2d19f1495..8d3c6d9a59f2 100644
--- a/dev-java/icu4j/ChangeLog
+++ b/dev-java/icu4j/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/icu4j
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.62 2014/01/12 20:31:01 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/ChangeLog,v 1.63 2014/04/22 00:00:28 tomwij Exp $
+
+*icu4j-53.1 (21 Apr 2014)
+
+ 21 Apr 2014; Tom Wijsman <TomWij@gentoo.org> +icu4j-53.1.ebuild:
+ Version bump to 53.1; fixes bug #507660, reported by Arfrever Frehtes
+ Taifersar Arahesis (arfrever.fta).
*icu4j-52.1 (12 Jan 2014)
diff --git a/dev-java/icu4j/icu4j-53.1.ebuild b/dev-java/icu4j/icu4j-53.1.ebuild
new file mode 100644
index 000000000000..6f80d5ceb94c
--- /dev/null
+++ b/dev-java/icu4j/icu4j-53.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/icu4j/icu4j-53.1.ebuild,v 1.1 2014/04/22 00:00:28 tomwij Exp $
+
+EAPI="5"
+
+# testdata.jar, icudata.jar and icutzdata.jar do not contain *.class files
+# but *.res files. These *.res data files are needed to build the final jar.
+
+JAVA_PKG_IUSE="doc examples source test"
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="A set of Java libraries providing Unicode and Globalization support."
+HOMEPAGE="http://www.icu-project.org/"
+SRC_URI="http://download.icu-project.org/files/${PN}/${PV}/${PN}-${PV//./_}.tgz"
+
+LICENSE="icu"
+SLOT="52"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+# Beware of jdk version dependant code #361593
+DEPEND=">=virtual/jdk-1.6"
+RDEPEND=">=virtual/jre-1.6"
+
+S="${WORKDIR}"
+
+JAVA_PKG_BSFIX_NAME+=" common-targets.xml"
+
+EANT_DOC_TARGET="docs"
+EANT_TEST_TARGET="check"
+
+src_test() {
+ java-pkg-2_src_test
+}
+
+src_install() {
+ java-pkg_dojar ${PN}.jar
+ java-pkg_dojar ${PN}-charset.jar
+ java-pkg_dojar ${PN}-localespi.jar
+
+ dohtml readme.html
+
+ use doc && java-pkg_dojavadoc doc
+ use examples && java-pkg_doexamples demos samples
+ use source && java-pkg_dosrc main/classes/*/src/com
+}