summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-07-13 13:38:27 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-07-13 13:38:27 +0000
commit662ab7d0d10c131997b1ae24cd55bd32097348e0 (patch)
treee60eeeaf807749a4c19d520ac8986f0aaa986fea /dev-java/httpcomponents-core
parentCorrect dependency on dev-python/PyQt4, wrt bug #476700 (diff)
downloadgentoo-2-662ab7d0d10c131997b1ae24cd55bd32097348e0.tar.gz
gentoo-2-662ab7d0d10c131997b1ae24cd55bd32097348e0.tar.bz2
gentoo-2-662ab7d0d10c131997b1ae24cd55bd32097348e0.zip
New ebuild for dev-java/httpcomponents-core, a low level toolset of Java components focused on HTTP and associated protocols. Needed dependency of app-office/ganttproject, see bug #119276. Imported from lh-overlay, contributed by Johann Schmitz (ercpe); small adjustements made.
(Portage version: 2.1.12.13/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/httpcomponents-core')
-rw-r--r--dev-java/httpcomponents-core/ChangeLog15
-rw-r--r--dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-build.xml74
-rw-r--r--dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-httpcore-build.xml281
-rw-r--r--dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-httpcore-nio-build.xml307
-rw-r--r--dev-java/httpcomponents-core/httpcomponents-core-4.2.4.ebuild43
-rw-r--r--dev-java/httpcomponents-core/metadata.xml5
6 files changed, 725 insertions, 0 deletions
diff --git a/dev-java/httpcomponents-core/ChangeLog b/dev-java/httpcomponents-core/ChangeLog
new file mode 100644
index 000000000000..457c48043505
--- /dev/null
+++ b/dev-java/httpcomponents-core/ChangeLog
@@ -0,0 +1,15 @@
+# ChangeLog for dev-java/httpcomponents-core
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/httpcomponents-core/ChangeLog,v 1.1 2013/07/13 13:38:27 tomwij Exp $
+
+*httpcomponents-core-4.2.4 (13 Jul 2013)
+
+ 13 Jul 2013; Tom Wijsman <TomWij@gentoo.org>
+ +files/httpcomponents-core-4.2.4-build.xml,
+ +files/httpcomponents-core-4.2.4-httpcore-build.xml,
+ +files/httpcomponents-core-4.2.4-httpcore-nio-build.xml,
+ +httpcomponents-core-4.2.4.ebuild, +metadata.xml:
+ New ebuild for dev-java/httpcomponents-core, a low level toolset of Java
+ components focused on HTTP and associated protocols. Needed dependency of app-
+ office/ganttproject, see bug #119276. Imported from lh-overlay, contributed by
+ Johann Schmitz (ercpe); small adjustements made.
diff --git a/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-build.xml b/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-build.xml
new file mode 100644
index 000000000000..1ebbeed19ac1
--- /dev/null
+++ b/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-build.xml
@@ -0,0 +1,74 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/14/13 8:39 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="httpcomponents-core-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <ant antfile="build.xml" dir="httpcore" target="clean"/>
+ <ant antfile="build.xml" dir="httpcore-nio" target="clean"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" description="Compile the code">
+ <ant antfile="build.xml" dir="httpcore" target="compile"/>
+ <ant antfile="build.xml" dir="httpcore-nio" target="compile"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests" description="Compile the test code">
+ <ant antfile="build.xml" dir="httpcore" target="compile-tests"/>
+ <ant antfile="build.xml" dir="httpcore-nio" target="compile-tests"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test" description="Run the test cases">
+ <ant antfile="build.xml" dir="httpcore" target="test"/>
+ <ant antfile="build.xml" dir="httpcore-nio" target="test"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <ant antfile="build.xml" dir="httpcore" target="javadoc"/>
+ <ant antfile="build.xml" dir="httpcore-nio" target="javadoc"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" description="Package the application">
+ <ant antfile="build.xml" dir="httpcore" target="package"/>
+ <ant antfile="build.xml" dir="httpcore-nio" target="package"/>
+ </target>
+
+</project>
diff --git a/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-httpcore-build.xml b/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-httpcore-build.xml
new file mode 100644
index 000000000000..7f97b4d910a5
--- /dev/null
+++ b/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-httpcore-build.xml
@@ -0,0 +1,281 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/14/13 8:39 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="httpcore-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="httpcore-4.2.4"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath"/>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="**/*.properties"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.5"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.9"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.9/junit-4.9.jar"
+ dest="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.9/junit-4.9.jar"
+ dest="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1"/>
+ <get src="http://repository.apache.org/snapshots/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/mockito/mockito-core/1.8.5"/>
+ <get src="http://repository.apache.org/snapshots/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"
+ dest="${maven.repo.local}/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"
+ dest="${maven.repo.local}/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/objenesis/objenesis/1.0"/>
+ <get src="http://repository.apache.org/snapshots/org/objenesis/objenesis/1.0/objenesis-1.0.jar"
+ dest="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/objenesis/objenesis/1.0/objenesis-1.0.jar"
+ dest="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-httpcore-nio-build.xml b/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-httpcore-nio-build.xml
new file mode 100644
index 000000000000..df983ac09450
--- /dev/null
+++ b/dev-java/httpcomponents-core/files/httpcomponents-core-4.2.4-httpcore-nio-build.xml
@@ -0,0 +1,307 @@
+<?xml version="1.0" encoding="UTF-8"?>
+
+<!-- ====================================================================== -->
+<!-- Ant build file (http://ant.apache.org/) for Ant 1.6.2 or above. -->
+<!-- ====================================================================== -->
+
+<!-- ====================================================================== -->
+<!-- ===================== - DO NOT EDIT THIS FILE! - ===================== -->
+<!-- ====================================================================== -->
+<!-- -->
+<!-- Any modifications will be overwritten. -->
+<!-- -->
+<!-- Generated by Maven Ant Plugin on 6/14/13 8:39 AM -->
+<!-- See: http://maven.apache.org/plugins/maven-ant-plugin/ -->
+<!-- -->
+<!-- ====================================================================== -->
+
+<project name="httpcore-nio-from-maven" default="package" basedir=".">
+
+ <!-- ====================================================================== -->
+ <!-- Build environment properties -->
+ <!-- ====================================================================== -->
+
+ <property file="${user.home}/.m2/maven.properties"/>
+ <property file="maven-build.properties"/>
+
+ <property name="maven.build.finalName" value="httpcore-nio-4.2.4"/>
+ <property name="maven.build.dir" value="target"/>
+ <property name="maven.build.outputDir" value="${maven.build.dir}/classes"/>
+ <property name="maven.build.srcDir.0" value="src/main/java"/>
+ <property name="maven.build.resourceDir.0" value="src/main/resources"/>
+ <property name="maven.build.testOutputDir" value="${maven.build.dir}/test-classes"/>
+ <property name="maven.build.testDir.0" value="src/test/java"/>
+ <property name="maven.build.testResourceDir.0" value="src/test/resources"/>
+ <property name="maven.test.reports" value="${maven.build.dir}/test-reports"/>
+ <property name="maven.reporting.outputDirectory" value="${maven.build.dir}/site"/>
+
+ <property name="maven.repo.local" value="${user.home}/.m2/repository"/>
+ <property name="maven.settings.offline" value="false"/>
+ <property name="maven.settings.interactiveMode" value="true"/>
+
+ <!-- ====================================================================== -->
+ <!-- Defining classpaths -->
+ <!-- ====================================================================== -->
+
+ <path id="build.classpath">
+ <pathelement location="${basedir}/../httpcore/target/httpcore-4.2.4.jar"/>
+ </path>
+ <path id="build.test.classpath">
+ <pathelement location="${maven.repo.local}/org/apache/httpcomponents/httpcore/4.2.4/httpcore-4.2.4.jar"/>
+ <pathelement location="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"/>
+ <pathelement location="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"/>
+ <pathelement location="${maven.repo.local}/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"/>
+ <pathelement location="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"/>
+ <pathelement location="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"/>
+ </path>
+
+ <!-- ====================================================================== -->
+ <!-- Cleaning up target -->
+ <!-- ====================================================================== -->
+
+ <target name="clean" description="Clean the output directory">
+ <delete dir="${maven.build.dir}"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile" depends="get-deps" description="Compile the code">
+ <mkdir dir="${maven.build.outputDir}"/>
+ <javac destdir="${maven.build.outputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.srcDir.0}"/>
+ </src>
+ <classpath refid="build.classpath"/>
+ </javac>
+ <copy todir="${maven.build.outputDir}">
+ <fileset dir="${maven.build.resourceDir.0}">
+ <include name="**/*.properties"/>
+ </fileset>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Test-compilation target -->
+ <!-- ====================================================================== -->
+
+ <target name="compile-tests"
+ depends="compile"
+ description="Compile the test code"
+ unless="maven.test.skip">
+ <mkdir dir="${maven.build.testOutputDir}"/>
+ <javac destdir="${maven.build.testOutputDir}"
+ nowarn="false"
+ debug="true"
+ optimize="true"
+ deprecation="true"
+ target="1.5"
+ verbose="false"
+ fork="false"
+ source="1.5">
+ <src>
+ <pathelement location="${maven.build.testDir.0}"/>
+ </src>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ </classpath>
+ </javac>
+ <copy todir="${maven.build.testOutputDir}">
+ <fileset dir="${maven.build.testResourceDir.0}"/>
+ </copy>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Run all tests -->
+ <!-- ====================================================================== -->
+
+ <target name="test"
+ depends="compile-tests, junit-missing"
+ unless="junit.skipped"
+ description="Run the test cases">
+ <mkdir dir="${maven.test.reports}"/>
+ <junit printSummary="yes" haltonerror="true" haltonfailure="true" fork="true" dir=".">
+ <sysproperty key="basedir" value="."/>
+ <formatter type="xml"/>
+ <formatter type="plain" usefile="false"/>
+ <classpath>
+ <path refid="build.test.classpath"/>
+ <pathelement location="${maven.build.outputDir}"/>
+ <pathelement location="${maven.build.testOutputDir}"/>
+ </classpath>
+ <batchtest todir="${maven.test.reports}" unless="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/Test*.java"/>
+ <include name="**/*Test.java"/>
+ <include name="**/*TestCase.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ <batchtest todir="${maven.test.reports}" if="test">
+ <fileset dir="${maven.build.testDir.0}">
+ <include name="**/${test}.java"/>
+ <exclude name="**/*Abstract*Test.java"/>
+ </fileset>
+ </batchtest>
+ </junit>
+ </target>
+
+ <target name="test-junit-present">
+ <available classname="junit.framework.Test" property="junit.present"/>
+ </target>
+
+ <target name="test-junit-status"
+ depends="test-junit-present">
+ <condition property="junit.missing">
+ <and>
+ <isfalse value="${junit.present}"/>
+ <isfalse value="${maven.test.skip}"/>
+ </and>
+ </condition>
+ <condition property="junit.skipped">
+ <or>
+ <isfalse value="${junit.present}"/>
+ <istrue value="${maven.test.skip}"/>
+ </or>
+ </condition>
+ </target>
+
+ <target name="junit-missing"
+ depends="test-junit-status"
+ if="junit.missing">
+ <echo>=================================== WARNING ===================================</echo>
+ <echo> JUnit is not present in your $ANT_HOME/lib directory. Tests not executed.</echo>
+ <echo>===============================================================================</echo>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Javadoc target -->
+ <!-- ====================================================================== -->
+
+ <target name="javadoc" description="Generates the Javadoc of the application">
+ <javadoc sourcepath="${maven.build.srcDir.0}"
+ packagenames="*"
+ destdir="${maven.reporting.outputDirectory}/apidocs"
+ access="protected"
+ old="false"
+ verbose="false"
+ version="true"
+ use="true"
+ author="true"
+ splitindex="false"
+ nodeprecated="false"
+ nodeprecatedlist="false"
+ notree="false"
+ noindex="false"
+ nohelp="false"
+ nonavbar="false"
+ serialwarn="false"
+ charset="ISO-8859-1"
+ source="1.5"
+ linksource="false"
+ breakiterator="false">
+ <link href="http://download.oracle.com/javase/1.5.0/docs/api/"/>
+ <link href="http://hc.apache.org/httpcomponents-core-ga/httpcore/apidocs/"/>
+ </javadoc>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- Package target -->
+ <!-- ====================================================================== -->
+
+ <target name="package" depends="compile,test" description="Package the application">
+ <jar jarfile="${maven.build.dir}/${maven.build.finalName}.jar"
+ compress="true"
+ index="false"
+ basedir="${maven.build.outputDir}"
+ excludes="**/package.html"/>
+ </target>
+
+ <!-- ====================================================================== -->
+ <!-- A dummy target for the package named after the type it creates -->
+ <!-- ====================================================================== -->
+
+ <target name="jar" depends="package" description="Builds the jar for the application"/>
+
+ <!-- ====================================================================== -->
+ <!-- Download dependencies target -->
+ <!-- ====================================================================== -->
+
+ <target name="test-offline">
+ <condition property="maven.mode.offline">
+ <equals arg1="${maven.settings.offline}" arg2="true"/>
+ </condition>
+ </target>
+
+ <target name="get-deps"
+ depends="test-offline"
+ description="Download all dependencies"
+ unless="maven.mode.offline">
+ <mkdir dir="${maven.repo.local}"/>
+ <mkdir dir="${maven.repo.local}/org/apache/httpcomponents/httpcore/4.2.4"/>
+ <get src="http://repository.apache.org/snapshots/org/apache/httpcomponents/httpcore/4.2.4/httpcore-4.2.4.jar"
+ dest="${maven.repo.local}/org/apache/httpcomponents/httpcore/4.2.4/httpcore-4.2.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/apache/httpcomponents/httpcore/4.2.4/httpcore-4.2.4.jar"
+ dest="${maven.repo.local}/org/apache/httpcomponents/httpcore/4.2.4/httpcore-4.2.4.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/junit/junit/4.9"/>
+ <get src="http://repository.apache.org/snapshots/junit/junit/4.9/junit-4.9.jar"
+ dest="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/junit/junit/4.9/junit-4.9.jar"
+ dest="${maven.repo.local}/junit/junit/4.9/junit-4.9.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1"/>
+ <get src="http://repository.apache.org/snapshots/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ dest="${maven.repo.local}/org/hamcrest/hamcrest-core/1.1/hamcrest-core-1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/mockito/mockito-core/1.8.5"/>
+ <get src="http://repository.apache.org/snapshots/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"
+ dest="${maven.repo.local}/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"
+ dest="${maven.repo.local}/org/mockito/mockito-core/1.8.5/mockito-core-1.8.5.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/org/objenesis/objenesis/1.0"/>
+ <get src="http://repository.apache.org/snapshots/org/objenesis/objenesis/1.0/objenesis-1.0.jar"
+ dest="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/org/objenesis/objenesis/1.0/objenesis-1.0.jar"
+ dest="${maven.repo.local}/org/objenesis/objenesis/1.0/objenesis-1.0.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <mkdir dir="${maven.repo.local}/commons-logging/commons-logging/1.1.1"/>
+ <get src="http://repository.apache.org/snapshots/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"
+ dest="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ <get src="http://repo.maven.apache.org/maven2/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"
+ dest="${maven.repo.local}/commons-logging/commons-logging/1.1.1/commons-logging-1.1.1.jar"
+ usetimestamp="false"
+ ignoreerrors="true"/>
+ </target>
+
+</project>
diff --git a/dev-java/httpcomponents-core/httpcomponents-core-4.2.4.ebuild b/dev-java/httpcomponents-core/httpcomponents-core-4.2.4.ebuild
new file mode 100644
index 000000000000..ee2c671f93d6
--- /dev/null
+++ b/dev-java/httpcomponents-core/httpcomponents-core-4.2.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/httpcomponents-core/httpcomponents-core-4.2.4.ebuild,v 1.1 2013/07/13 13:38:27 tomwij Exp $
+
+EAPI="5"
+
+JAVA_PKG_IUSE="source examples"
+
+inherit eutils java-pkg-2 java-ant-2
+
+DESCRIPTION="A low level toolset of Java components focused on HTTP and associated protocols."
+HOMEPAGE="http://hc.apache.org/index.html"
+SRC_URI="mirror://apache/${PN/-//http}/source/${P}-src.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND=">=virtual/jdk-1.5"
+RDEPEND=">=virtual/jre-1.5"
+
+EANT_BUILD_TARGET="package"
+
+java_prepare() {
+ cp "${FILESDIR}"/${P}-build.xml build.xml || die
+
+ for x in "${FILESDIR}"/${P}-httpcore*; do
+ d=$(basename ${x})
+ d=${d/${P}-}
+ cp "${x}" ${d/-build.xml}/build.xml || die
+ done
+}
+
+src_install() {
+ for mod in httpcore httpcore-nio ; do
+ java-pkg_newjar ${mod}/target/${mod}-${PV}.jar ${mod}.jar
+ done
+
+ use source && java-pkg_dosrc httpcore{,-nio}/src/main/java
+ use examples && java-pkg_doexamples httpcore{,-nio}/src/examples
+
+ dodoc {README,RELEASE_NOTES,NOTICE}.txt
+}
diff --git a/dev-java/httpcomponents-core/metadata.xml b/dev-java/httpcomponents-core/metadata.xml
new file mode 100644
index 000000000000..838c00a4a448
--- /dev/null
+++ b/dev-java/httpcomponents-core/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>java</herd>
+</pkgmetadata>