summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMiroslav Šulc <fordfrog@gentoo.org>2007-01-21 02:01:40 +0000
committerMiroslav Šulc <fordfrog@gentoo.org>2007-01-21 02:01:40 +0000
commit4702021c73b12bd2db0d326b894d1ed5e97237f1 (patch)
tree2e0702d5b92135f24e4922d6e90f1d051b9dd2b9 /dev-java/glassfish-persistence/glassfish-persistence-1.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-4702021c73b12bd2db0d326b894d1ed5e97237f1.tar.gz
gentoo-2-4702021c73b12bd2db0d326b894d1ed5e97237f1.tar.bz2
gentoo-2-4702021c73b12bd2db0d326b894d1ed5e97237f1.zip
Initial ebuild, thanks to Alistair Bush <alistair.bush@gmail.com>.
(Portage version: 2.1.2-r1)
Diffstat (limited to 'dev-java/glassfish-persistence/glassfish-persistence-1.0.ebuild')
-rw-r--r--dev-java/glassfish-persistence/glassfish-persistence-1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-java/glassfish-persistence/glassfish-persistence-1.0.ebuild b/dev-java/glassfish-persistence/glassfish-persistence-1.0.ebuild
new file mode 100644
index 000000000000..cc51580fe6e2
--- /dev/null
+++ b/dev-java/glassfish-persistence/glassfish-persistence-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/glassfish-persistence/glassfish-persistence-1.0.ebuild,v 1.1 2007/01/21 02:01:40 fordfrog Exp $
+
+inherit java-pkg-2 java-ant-2
+
+DESCRIPTION="Glassfish implementation of persistence API"
+HOMEPAGE="https://glassfish.dev.java.net/"
+SRC_URI="http://download.java.net/javaee5/fcs_branch/promoted/source/glassfish-9_0-b48-src.zip"
+
+LICENSE="CDDL"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=virtual/jdk-1.5
+ app-arch/unzip"
+RDEPEND=">=virtual/jre-1.5"
+
+MODULE="persistence-api"
+S="${WORKDIR}/glassfish"
+
+src_compile() {
+ cd ${S}/${MODULE}
+ eant all
+}
+
+src_install() {
+ cd ${WORKDIR}/publish/glassfish
+ java-pkg_newjar lib/javaee.jar
+
+ dodir /usr/share/${PN}/lib/schemas
+ cp schemas/*.xsd ${D}/usr/share/${PN}/lib/schemas
+}