summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-29 19:14:19 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-29 19:14:19 +0000
commit3fe539a2769ba020a9b63bea4bed47237b98297f (patch)
tree83ae197b75441c25457c67db20a8c8a0ba581ef1 /dev-java/datavision
parentA number of fixes (diff)
downloadgentoo-2-3fe539a2769ba020a9b63bea4bed47237b98297f.tar.gz
gentoo-2-3fe539a2769ba020a9b63bea4bed47237b98297f.tar.bz2
gentoo-2-3fe539a2769ba020a9b63bea4bed47237b98297f.zip
The build system needs ruby so we need to always DEPEND on it. I chose jruby over dev-lang/ruby because we might be needing jruby for the scripting support with the ruby use flag during runtime too. Fixes bug #164402.
(Portage version: 2.1.2-r4)
Diffstat (limited to 'dev-java/datavision')
-rw-r--r--dev-java/datavision/ChangeLog8
-rw-r--r--dev-java/datavision/datavision-1.0.0-r2.ebuild12
2 files changed, 18 insertions, 2 deletions
diff --git a/dev-java/datavision/ChangeLog b/dev-java/datavision/ChangeLog
index aeee39b17c3d..f150a14e47dd 100644
--- a/dev-java/datavision/ChangeLog
+++ b/dev-java/datavision/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/datavision
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/datavision/ChangeLog,v 1.16 2007/01/28 16:57:22 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/datavision/ChangeLog,v 1.17 2007/01/29 19:14:19 betelgeuse Exp $
+
+ 29 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+ datavision-1.0.0-r2.ebuild:
+ The build system needs ruby so we need to always DEPEND on it. I chose jruby
+ over dev-lang/ruby because we might be needing jruby for the scripting
+ support with the ruby use flag during runtime too. Fixes bug #164402.
28 Jan 2007; William L. Thomson Jr. <wltjr@gentoo.org>
-datavision-0.8.2.ebuild, -datavision-1.0.0.ebuild,
diff --git a/dev-java/datavision/datavision-1.0.0-r2.ebuild b/dev-java/datavision/datavision-1.0.0-r2.ebuild
index 2a9a9cd61ca6..f726aa44222d 100644
--- a/dev-java/datavision/datavision-1.0.0-r2.ebuild
+++ b/dev-java/datavision/datavision-1.0.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/datavision/datavision-1.0.0-r2.ebuild,v 1.2 2007/01/28 16:57:22 wltjr Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/datavision/datavision-1.0.0-r2.ebuild,v 1.3 2007/01/29 19:14:19 betelgeuse Exp $
inherit java-pkg-2 java-ant-2
@@ -19,6 +19,8 @@ RDEPEND=">=virtual/jre-1.4
mysql? ( >=dev-java/jdbc-mysql-3.0 )
postgres? ( >=dev-java/jdbc2-postgresql-7.3 )"
DEPEND=">=virtual/jdk-1.4
+ dev-java/jruby
+ dev-java/ant-core
${RDEPEND}"
# test? ( >=dev-java/junit-3.7 )"
@@ -35,6 +37,11 @@ src_unpack() {
use ruby && java-pkg_jar-from jruby
cd "${S}"
+ # Let's use jruby instead as this is java and we can RDEPEND on it
+ # during run time any way
+ # https://bugs.gentoo.org/show_bug.cgi?id=164402
+ sed -e 's/executable=\"ruby\"/executable=\"jruby\"/' -i build.xml \
+ || die "Failed to replace ruby with jruby"
use mysql && java-pkg_jar-from jdbc-mysql
use postgres && java-pkg_jar-from jdbc2-postgresql-6
}
@@ -83,4 +90,7 @@ pkg_postinst() {
elog "Because we need to change the current working directory"
elog "in the launcher for the help to work, the launcher can't be"
elog "used with relative paths. Patches are welcome."
+ elog ""
+ elog "The build system needs ruby so the ruby use flag only affects"
+ elog "RDEPEND."
}