summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Matthijs <axxo@gentoo.org>2004-07-16 19:49:22 +0000
committerThomas Matthijs <axxo@gentoo.org>2004-07-16 19:49:22 +0000
commitfef1de1d41f6f57ee216d0f46e764025d4c6379b (patch)
treef066ef74cf9cd564be6c2bb252c17b1d9bc69a5c /dev-java/commons-logging
parentstable on ppc64 (Manifest recommit) (diff)
downloadgentoo-2-fef1de1d41f6f57ee216d0f46e764025d4c6379b.tar.gz
gentoo-2-fef1de1d41f6f57ee216d0f46e764025d4c6379b.tar.bz2
gentoo-2-fef1de1d41f6f57ee216d0f46e764025d4c6379b.zip
Version Bump
Diffstat (limited to 'dev-java/commons-logging')
-rw-r--r--dev-java/commons-logging/ChangeLog8
-rw-r--r--dev-java/commons-logging/Manifest2
-rw-r--r--dev-java/commons-logging/commons-logging-1.0.4.ebuild45
-rw-r--r--dev-java/commons-logging/files/digest-commons-logging-1.0.41
4 files changed, 55 insertions, 1 deletions
diff --git a/dev-java/commons-logging/ChangeLog b/dev-java/commons-logging/ChangeLog
index f668fb8486e9..5e7fd0539478 100644
--- a/dev-java/commons-logging/ChangeLog
+++ b/dev-java/commons-logging/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-logging
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/ChangeLog,v 1.16 2004/07/15 14:49:12 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/ChangeLog,v 1.17 2004/07/16 19:49:22 axxo Exp $
+
+*commons-logging-1.0.4 (16 Jul 2004)
+
+ 16 Jul 2004; Thomas Matthijs <axxo@gentoo.org>
+ +commons-logging-1.0.4.ebuild:
+ Version Bump
15 Jul 2004; Thomas Matthijs <axxo@gentoo.org>
commons-logging-1.0.3-r1.ebuild:
diff --git a/dev-java/commons-logging/Manifest b/dev-java/commons-logging/Manifest
index fd07f3d53861..fd7b4bd30305 100644
--- a/dev-java/commons-logging/Manifest
+++ b/dev-java/commons-logging/Manifest
@@ -1,4 +1,6 @@
+MD5 59c960f2dec663b1b2e8d18ba91e5234 commons-logging-1.0.4.ebuild 1461
MD5 59c960f2dec663b1b2e8d18ba91e5234 commons-logging-1.0.3-r1.ebuild 1461
MD5 630b619e0d396bb2e7bafb657c9bbfad ChangeLog 2296
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
+MD5 1e62b8a1770a8f7d817420e0c0d5f651 files/digest-commons-logging-1.0.4 77
MD5 3d6fb50b9453c1e9c219a22a23345e23 files/digest-commons-logging-1.0.3-r1 76
diff --git a/dev-java/commons-logging/commons-logging-1.0.4.ebuild b/dev-java/commons-logging/commons-logging-1.0.4.ebuild
new file mode 100644
index 000000000000..7928ca1c5fef
--- /dev/null
+++ b/dev-java/commons-logging/commons-logging-1.0.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.4.ebuild,v 1.1 2004/07/16 19:49:22 axxo Exp $
+
+inherit java-pkg
+
+DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries."
+HOMEPAGE="http://jakarta.apache.org/commons/logging/"
+SRC_URI="mirror://apache/jakarta/commons/logging/source/${PN}-${PV}-src.tar.gz"
+DEPEND=">=dev-java/log4j-1.2.5
+ dev-java/avalon-logkit
+ >=dev-java/ant-1.4
+ jikes? ( dev-java/jikes )
+ junit? ( >=dev-java/junit-3.7 >=virtual/jdk-1.4 ) : ( >=virtual/jdk-1.3 )"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ppc sparc amd64"
+IUSE="doc jikes junit"
+
+S="${WORKDIR}/${P}-src/"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ echo "log4j.jar=`java-config -p log4j`" > build.properties
+ echo "logkit.jar=`java-config -p avalon-logkit`" >> build.properties
+ echo "junit.jar=`java-config -p junit`" >> build.properties
+}
+
+src_compile() {
+ local antflags="compile"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ use junit && antflags="${antflags} test"
+ ant ${antflags} || die "compile problem"
+}
+
+src_install() {
+ java-pkg_dojar target/${PN}-api.jar target/${PN}.jar
+
+ dodoc RELEASE-NOTES.txt
+ dohtml PROPOSAL.html STATUS.html usersguide.html
+ use doc && dohtml -r dist/docs/
+}
diff --git a/dev-java/commons-logging/files/digest-commons-logging-1.0.4 b/dev-java/commons-logging/files/digest-commons-logging-1.0.4
new file mode 100644
index 000000000000..f624da15c5f7
--- /dev/null
+++ b/dev-java/commons-logging/files/digest-commons-logging-1.0.4
@@ -0,0 +1 @@
+MD5 db5dc75c89e794f794be92d10df6be1b commons-logging-1.0.4-src.tar.gz 101017