summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Aniszczyk <zx@gentoo.org>2004-03-09 05:51:53 +0000
committerChris Aniszczyk <zx@gentoo.org>2004-03-09 05:51:53 +0000
commit6065cb94c1b59716860303ea55ff5020517c9cb3 (patch)
tree11faa6ff46a4f77f7600b772ea4b3ce154590c73 /dev-java/commons-httpclient
parentChanged herd from hardened to netmon (diff)
downloadgentoo-2-6065cb94c1b59716860303ea55ff5020517c9cb3.tar.gz
gentoo-2-6065cb94c1b59716860303ea55ff5020517c9cb3.tar.bz2
gentoo-2-6065cb94c1b59716860303ea55ff5020517c9cb3.zip
Closes #43709
Diffstat (limited to 'dev-java/commons-httpclient')
-rw-r--r--dev-java/commons-httpclient/ChangeLog10
-rw-r--r--dev-java/commons-httpclient/Manifest6
-rw-r--r--dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild39
-rw-r--r--dev-java/commons-httpclient/files/digest-commons-httpclient-2.0-r11
-rw-r--r--dev-java/commons-httpclient/files/gentoo.diff13
5 files changed, 65 insertions, 4 deletions
diff --git a/dev-java/commons-httpclient/ChangeLog b/dev-java/commons-httpclient/ChangeLog
index f00ea0be2ec7..cd596de6ca4c 100644
--- a/dev-java/commons-httpclient/ChangeLog
+++ b/dev-java/commons-httpclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-java/commons-httpclient
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.4 2004/03/02 08:54:26 aliz Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/ChangeLog,v 1.5 2004/03/09 05:51:53 zx Exp $
+
+*commons-httpclient-2.0-r1 (09 Mar 2004)
+
+ 09 Mar 2004; Chris Aniszczyk <zx@gentoo.org>
+ commons-httpclient-2.0-r1.ebuild, files/gentoo.diff:
+ Weaning off the broken jakarta-commons eclass. Closes #43709
*commons-httpclient-2.0 (24 Feb 2004)
diff --git a/dev-java/commons-httpclient/Manifest b/dev-java/commons-httpclient/Manifest
index 98cd9409bc3a..42f44d0b443c 100644
--- a/dev-java/commons-httpclient/Manifest
+++ b/dev-java/commons-httpclient/Manifest
@@ -1,4 +1,6 @@
-MD5 c8bef0d521e2f3eb41fe773770733b62 commons-httpclient-2.0.ebuild 982
-MD5 b628d68ff9069003a1a29994c5c68e2c ChangeLog 695
+MD5 81679baea28d92fd5fbca71c2dfb6986 commons-httpclient-2.0-r1.ebuild 981
+MD5 81679baea28d92fd5fbca71c2dfb6986 commons-httpclient-2.0.ebuild 981
+MD5 437722849cc915516bfd1b988db1ed13 ChangeLog 694
MD5 a6ec7d7724fbd068ffb39b5be56134ed metadata.xml 157
MD5 70dbd7a345c0a9f6a17998de0191f13e files/digest-commons-httpclient-2.0 79
+MD5 70dbd7a345c0a9f6a17998de0191f13e files/digest-commons-httpclient-2.0-r1 79
diff --git a/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild b/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild
new file mode 100644
index 000000000000..8907da40eacf
--- /dev/null
+++ b/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-httpclient/commons-httpclient-2.0-r1.ebuild,v 1.1 2004/03/09 05:51:53 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="The Jakarta Commons HttpClient provides an efficient, up-to-date, and feature-rich package implementing the client side of the most recent HTTP standards and recommendations."
+HOMEPAGE="http://jakarta.apache.org/commons/httpclient/index.html"
+SRC_URI="mirror://apache/jakarta/commons/httpclient/source/${P/_/-}-src.tar.gz"
+DEPEND=">=virtual/jdk-1.3
+ >=dev-java/log4j-1.2.5
+ >=dev-java/ant-1.4
+ dev-java/commons-logging"
+RDEPEND=">=virtual/jdk-1.3"
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="x86 ~ppc ~sparc"
+IUSE="doc jikes"
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/gentoo.diff || die "patching failed"
+ echo "commons-logging.jar=/usr/share/commons-logging/lib/commons-logging.jar" >> build.properties
+}
+
+src_compile() {
+ local antflags="dist"
+ use jikes && antflags="${antflags} -Dbuild.compiler=jikes"
+ use doc && antflags="${antflags} javadoc"
+ ant ${antflags}
+}
+
+src_install() {
+ java-pkg_dojar dist/${PN}.jar
+ use doc && dohtml -r dist/docs/*
+}
diff --git a/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0-r1 b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0-r1
new file mode 100644
index 000000000000..6ad9c15703a0
--- /dev/null
+++ b/dev-java/commons-httpclient/files/digest-commons-httpclient-2.0-r1
@@ -0,0 +1 @@
+MD5 6bc428538d8299cc76b54186eed6adcd commons-httpclient-2.0-src.tar.gz 1427148
diff --git a/dev-java/commons-httpclient/files/gentoo.diff b/dev-java/commons-httpclient/files/gentoo.diff
new file mode 100644
index 000000000000..4b22b61f3176
--- /dev/null
+++ b/dev-java/commons-httpclient/files/gentoo.diff
@@ -0,0 +1,13 @@
+--- build.xml 2004-02-17 22:40:24.000000000 -0500
++++ build.xml.patched 2004-03-09 00:39:30.079755224 -0500
+@@ -200,10 +200,6 @@
+ <copy todir="${dist.home}/src" filtering="on">
+ <fileset dir="${source.home}"/>
+ </copy>
+- <mkdir dir="${dist.home}/lib"/>
+- <copy todir="${dist.home}/lib">
+- <fileset dir="lib"/>
+- </copy>
+ </target>
+
+ <!-- ========== Targets: "External" Targets: Clean-up ===================== -->