summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetteri Räty <betelgeuse@gentoo.org>2007-01-14 17:24:59 +0000
committerPetteri Räty <betelgeuse@gentoo.org>2007-01-14 17:24:59 +0000
commit84587408217d7c71cc541a6d4bf23bfd47dfde08 (patch)
tree492d50c10037b052de5381c3b5ad718da53093f9 /dev-java/blowfishj
parentVersion bump, also fix bug 158179 (diff)
downloadgentoo-2-84587408217d7c71cc541a6d4bf23bfd47dfde08.tar.gz
gentoo-2-84587408217d7c71cc541a6d4bf23bfd47dfde08.tar.bz2
gentoo-2-84587408217d7c71cc541a6d4bf23bfd47dfde08.zip
Fixed to work with JAVA_PKG_STRICT, added source use flag and cleaned javadoc installation.
(Portage version: 2.1.2_rc4-r7)
Diffstat (limited to 'dev-java/blowfishj')
-rw-r--r--dev-java/blowfishj/ChangeLog9
-rw-r--r--dev-java/blowfishj/blowfishj-2.14-r1.ebuild24
-rw-r--r--dev-java/blowfishj/metadata.xml8
3 files changed, 26 insertions, 15 deletions
diff --git a/dev-java/blowfishj/ChangeLog b/dev-java/blowfishj/ChangeLog
index 9fd7a5a1dbbd..dd9b0b0142ad 100644
--- a/dev-java/blowfishj/ChangeLog
+++ b/dev-java/blowfishj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/blowfishj
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/ChangeLog,v 1.7 2006/10/05 15:11:33 gustavoz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/ChangeLog,v 1.8 2007/01/14 17:24:59 betelgeuse Exp $
+
+ 14 Jan 2007; Petteri Räty <betelgeuse@gentoo.org>
+ blowfishj-2.14-r1.ebuild:
+ Fixed to work with JAVA_PKG_STRICT, added source use flag and cleaned
+ javadoc installation.
05 Oct 2006; Gustavo Zacarias <gustavoz@gentoo.org> blowfishj-2.14.ebuild,
blowfishj-2.14-r1.ebuild:
diff --git a/dev-java/blowfishj/blowfishj-2.14-r1.ebuild b/dev-java/blowfishj/blowfishj-2.14-r1.ebuild
index 3090d416763f..807f530a56af 100644
--- a/dev-java/blowfishj/blowfishj-2.14-r1.ebuild
+++ b/dev-java/blowfishj/blowfishj-2.14-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/blowfishj-2.14-r1.ebuild,v 1.2 2006/10/05 15:11:33 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/blowfishj/blowfishj-2.14-r1.ebuild,v 1.3 2007/01/14 17:24:59 betelgeuse Exp $
inherit java-pkg-2 java-ant-2
@@ -11,24 +11,30 @@ HOMEPAGE="http://blowfishj.sourceforge.net/index.html"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~x86 ~amd64 ~ppc"
-IUSE="doc test"
+IUSE="doc test source"
DEPEND=">=virtual/jdk-1.4
- dev-java/ant
+ dev-java/ant-core
app-arch/unzip
- test? ( dev-java/junit ) "
+ test? ( dev-java/junit dev-java/ant-tasks ) "
RDEPEND=">=virtual/jre-1.4"
-src_compile() {
- eant jar $(use_doc) || die "failed to compile"
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+ java-ant_ignore-system-classes
+ mkdir -p target/lib
+ cd target/lib
+ use test && java-pkg_jar-from --build-only junit
}
src_test() {
- eant test || die "test failed"
+ eant test -DJunit.present=true || die "test failed"
}
src_install() {
java-pkg_newjar target/${P}.jar ${PN}.jar
- use doc && java-pkg_dohtml -r dist/docs/api/*
+ use doc && java-pkg_dojavadoc dist/docs/api
+ use source && java-pkg_dosrc src/java/net
}
diff --git a/dev-java/blowfishj/metadata.xml b/dev-java/blowfishj/metadata.xml
index 840efe3842ab..23a1a427d99a 100644
--- a/dev-java/blowfishj/metadata.xml
+++ b/dev-java/blowfishj/metadata.xml
@@ -5,10 +5,10 @@
<herd>java</herd>
<longdescription>
-The Blowfish implementation in Java, provides very fast ECB and CBC encryption.
-Comes with the BlowfishEasy class for simple string encryption, plus a solution
-for streaming, both are binary compatible to Blowfish.NET. Additionally this
-package includes its own SHA-1 class, all sources, JUnit test cases, demos and
+The Blowfish implementation in Java, provides very fast ECB and CBC encryption.
+Comes with the BlowfishEasy class for simple string encryption, plus a solution
+for streaming, both are binary compatible to Blowfish.NET. Additionally this
+package includes its own SHA-1 class, all sources, JUnit test cases, demos and
JavaDocs.
</longdescription>
</pkgmetadata>