summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom Wijsman <tomwij@gentoo.org>2013-08-28 22:21:40 +0000
committerTom Wijsman <tomwij@gentoo.org>2013-08-28 22:21:40 +0000
commit5e218b839684acbc1dfdff2f8e756984713e71fc (patch)
treec2b2fbf1ca07bec7ce6a5624632b9df4ed9f8232 /dev-java/ant-nodeps
parentVersion bump to 1.9.2. Fixes security bug #476958. (diff)
downloadgentoo-2-5e218b839684acbc1dfdff2f8e756984713e71fc.tar.gz
gentoo-2-5e218b839684acbc1dfdff2f8e756984713e71fc.tar.bz2
gentoo-2-5e218b839684acbc1dfdff2f8e756984713e71fc.zip
Version bump to 1.9.2. Fixes security bug #476958.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 6D34E57D)
Diffstat (limited to 'dev-java/ant-nodeps')
-rw-r--r--dev-java/ant-nodeps/ChangeLog7
-rw-r--r--dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild28
2 files changed, 34 insertions, 1 deletions
diff --git a/dev-java/ant-nodeps/ChangeLog b/dev-java/ant-nodeps/ChangeLog
index d055e8535236..159e322e52dd 100644
--- a/dev-java/ant-nodeps/ChangeLog
+++ b/dev-java/ant-nodeps/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-java/ant-nodeps
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-nodeps/ChangeLog,v 1.41 2013/07/05 14:22:09 tomwij Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-nodeps/ChangeLog,v 1.42 2013/08/28 22:21:40 tomwij Exp $
+
+*ant-nodeps-1.9.2 (28 Aug 2013)
+
+ 28 Aug 2013; Tom Wijsman <TomWij@gentoo.org> +ant-nodeps-1.9.2.ebuild:
+ Version bump to 1.9.2. Fixes security bug #476958.
*ant-nodeps-1.9.1 (05 Jul 2013)
diff --git a/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild b/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild
new file mode 100644
index 000000000000..f79dbdcfa23e
--- /dev/null
+++ b/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/ant-nodeps/ant-nodeps-1.9.2.ebuild,v 1.1 2013/08/28 22:21:40 tomwij Exp $
+
+EAPI="5"
+
+ANT_TASK_DEPNAME=""
+ANT_TASK_DISABLE_VM_DEPS="true"
+
+inherit ant-tasks
+
+DESCRIPTION="Formerly Ant's optional tasks w/o external deps, now compat empty jar"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Dependency needed for jar.
+DEPEND=">=virtual/jdk-1.4"
+
+src_compile() {
+ # The classes were moved to ant-core in 1.8.2, this is just for compatibility.
+ mkdir -p build/lib/empty && cd build/lib/empty || die
+ jar -cf ../${PN}.jar . || die
+}
+
+pkg_postinst() {
+ elog "Upstream has removed ant-nodeps.jar as of 1.8.2 and moved the classes to ant.jar"
+ elog "This package thus installs an empty jar for compatibility"
+ elog "and will be removed once reverse dependencies are transitioned."
+}