summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-12-11 06:51:16 +0000
committerMark Wright <gienah@gentoo.org>2013-12-11 06:51:16 +0000
commitb34f4f15532416bda6052413586038089b6fd198 (patch)
tree304a90e2715ce49c808a5aadbf191d901778916e /dev-haskell
parentBump wai-test to 2.0.0.1 (diff)
downloadgentoo-2-b34f4f15532416bda6052413586038089b6fd198.tar.gz
gentoo-2-b34f4f15532416bda6052413586038089b6fd198.tar.bz2
gentoo-2-b34f4f15532416bda6052413586038089b6fd198.zip
Bump warp to 2.0.1
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/warp/ChangeLog7
-rw-r--r--dev-haskell/warp/warp-2.0.1.ebuild52
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-haskell/warp/ChangeLog b/dev-haskell/warp/ChangeLog
index 2ddbf8c32cf2..107d8e72126d 100644
--- a/dev-haskell/warp/ChangeLog
+++ b/dev-haskell/warp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/warp
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp/ChangeLog,v 1.5 2013/11/24 19:40:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp/ChangeLog,v 1.6 2013/12/11 06:51:16 gienah Exp $
+
+*warp-2.0.1 (11 Dec 2013)
+
+ 11 Dec 2013; Mark Wright <gienah@gentoo.org> +warp-2.0.1.ebuild:
+ Bump warp to 2.0.1
24 Nov 2013; Agostino Sarubbo <ago@gentoo.org> warp-1.3.9.2.ebuild:
Stable for x86, wrt bug #488750
diff --git a/dev-haskell/warp/warp-2.0.1.ebuild b/dev-haskell/warp/warp-2.0.1.ebuild
new file mode 100644
index 000000000000..0828b2d4d4e2
--- /dev/null
+++ b/dev-haskell/warp/warp-2.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/warp/warp-2.0.1.ebuild,v 1.1 2013/12/11 06:51:16 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.5.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A fast, light-weight web server for WAI applications."
+HOMEPAGE="http://github.com/yesodweb/wai"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+allow-sendfilefd"
+
+RDEPEND=">=dev-haskell/blaze-builder-0.3.3:=[profile?] <dev-haskell/blaze-builder-0.4:=[profile?]
+ >=dev-haskell/blaze-builder-conduit-0.5:=[profile?] <dev-haskell/blaze-builder-conduit-1.1:=[profile?]
+ >=dev-haskell/case-insensitive-0.2:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ dev-haskell/http-attoparsec:=[profile?]
+ dev-haskell/http-date:=[profile?]
+ >=dev-haskell/http-types-0.7:=[profile?]
+ >=dev-haskell/lifted-base-0.1:=[profile?]
+ >=dev-haskell/network-conduit-0.5:=[profile?] <dev-haskell/network-conduit-1.1:=[profile?]
+ >=dev-haskell/simple-sendfile-0.2.7:=[profile?] <dev-haskell/simple-sendfile-0.3:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ >=dev-haskell/unix-compat-0.2:=[profile?]
+ dev-haskell/void:=[profile?]
+ >=dev-haskell/wai-2.0:=[profile?] <dev-haskell/wai-2.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ allow-sendfilefd? ( dev-haskell/hashable:=[profile?] )
+ >=dev-haskell/network-2.3:=[profile?]
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/doctest-0.9.3
+ >=dev-haskell/hspec-1.3
+ dev-haskell/http
+ dev-haskell/hunit
+ dev-haskell/quickcheck
+ !allow-sendfilefd? ( dev-haskell/hashable ) )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag allow-sendfilefd allow-sendfilefd)
+}