summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2007-11-10 03:10:43 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2007-11-10 03:10:43 +0000
commit689de618536c1961f8c4c6c0a4693f31c7544890 (patch)
tree54f941522fff0069c06c7a00cd018df3fe87ac4b /dev-haskell
parentversion bump (diff)
downloadgentoo-2-689de618536c1961f8c4c6c0a4693f31c7544890.tar.gz
gentoo-2-689de618536c1961f8c4c6c0a4693f31c7544890.tar.bz2
gentoo-2-689de618536c1961f8c4c6c0a4693f31c7544890.zip
Adding new gtk2hs version
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/gtk2hs/ChangeLog7
-rw-r--r--dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.12.13
-rw-r--r--dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild91
3 files changed, 100 insertions, 1 deletions
diff --git a/dev-haskell/gtk2hs/ChangeLog b/dev-haskell/gtk2hs/ChangeLog
index ac13d9df4106..824556e44c9c 100644
--- a/dev-haskell/gtk2hs/ChangeLog
+++ b/dev-haskell/gtk2hs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/gtk2hs
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.37 2007/11/09 20:38:16 araujo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/ChangeLog,v 1.38 2007/11/10 03:10:42 araujo Exp $
+
+*gtk2hs-0.9.12.1 (10 Nov 2007)
+
+ 10 Nov 2007; Luis F. Araujo <araujo@gentoo.org> +gtk2hs-0.9.12.1.ebuild:
+ Adding new version
09 Nov 2007; Luis F. Araujo <araujo@gentoo.org> gtk2hs-0.9.12.ebuild:
Adding missing backslash to fix package registration
diff --git a/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.12.1 b/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.12.1
new file mode 100644
index 000000000000..b05210834c9d
--- /dev/null
+++ b/dev-haskell/gtk2hs/files/digest-gtk2hs-0.9.12.1
@@ -0,0 +1,3 @@
+MD5 4b6bd54f29963b3f9fcfbea219f19abb gtk2hs-0.9.12.1.tar.gz 1004661
+RMD160 cd658027ed91b9550915e686d546e36b1b371c10 gtk2hs-0.9.12.1.tar.gz 1004661
+SHA256 4278078b786202fc64f86881c2b2517bdd589d5248bff2e9b7e6c1ffd2361f84 gtk2hs-0.9.12.1.tar.gz 1004661
diff --git a/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild b/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild
new file mode 100644
index 000000000000..50a0c5790960
--- /dev/null
+++ b/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/gtk2hs/gtk2hs-0.9.12.1.ebuild,v 1.1 2007/11/10 03:10:42 araujo Exp $
+
+inherit base eutils ghc-package multilib toolchain-funcs versionator
+
+DESCRIPTION="A GUI Library for Haskell based on Gtk+"
+HOMEPAGE="http://haskell.org/gtk2hs/"
+SRC_URI="mirror://sourceforge/gtk2hs/${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+IUSE="doc glade gnome opengl svg firefox seamonkey profile xulrunner"
+
+RDEPEND=">=dev-lang/ghc-6.4
+ dev-haskell/mtl
+ >=x11-libs/gtk+-2
+ glade? ( >=gnome-base/libglade-2 )
+ gnome? ( >=gnome-base/libglade-2
+ >=x11-libs/gtksourceview-0.6
+ >=gnome-base/gconf-2 )
+ svg? ( >=gnome-base/librsvg-2.16 )
+ opengl? ( x11-libs/gtkglext )
+ seamonkey? ( >=www-client/seamonkey-1.0.2 )
+ firefox? ( >=www-client/mozilla-firefox-1.0.4 )
+ xulrunner? ( net-libs/xulrunner )"
+DEPEND="${RDEPEND}
+ doc? ( >=dev-haskell/haddock-0.8 )"
+
+src_compile() {
+ econf \
+ --enable-packager-mode \
+ $(version_is_at_least "4.2" "$(gcc-version)" && \
+ echo --disable-split-objs) \
+ $(has_version '>=x11-libs/gtk+-2.8' && echo --enable-cairo) \
+ $(use glade || use gnome && echo --enable-libglade) \
+ $(use_enable gnome gconf) \
+ $(use_enable gnome sourceview) \
+ $(use_enable svg svg) \
+ $(use_enable opengl opengl) \
+ $(use_enable seamonkey seamonkey) \
+ $(use_enable firefox firefox) \
+ $(use_enable xulrunner xulrunner) \
+ $(use_enable doc docs) \
+ $(use_enable profile profiling) \
+ || die "Configure failed"
+
+ # parallel build doesn't work, so specify -j1
+ emake -j1 || die "Make failed"
+}
+
+src_install() {
+
+ make install \
+ DESTDIR="${D}" \
+ htmldir="/usr/share/doc/${PF}/html" \
+ haddockifacedir="/usr/share/doc/${PF}" \
+ || die "Make install failed"
+
+ # for some reason it creates the doc dir even if it is configured
+ # to not generate docs, so lets remove the empty dirs in that case
+ # (and lets be cautious and only remove them if they're empty)
+ if ! use doc; then
+ rmdir "${D}/usr/share/doc/${PF}/html"
+ rmdir "${D}/usr/share/doc/${PF}"
+ rmdir "${D}/usr/share/doc"
+ rmdir "${D}/usr/share"
+ fi
+
+ # arrange for the packages to be registered
+ ghc-setup-pkg \
+ "${D}/usr/$(get_libdir)/gtk2hs/glib.package.conf" \
+ $(has_version '>=x11-libs/gtk+-2.8' && echo \
+ "${D}/usr/$(get_libdir)/gtk2hs/cairo.package.conf") \
+ "${D}/usr/$(get_libdir)/gtk2hs/gtk.package.conf" \
+ "${D}/usr/$(get_libdir)/gtk2hs/soegtk.package.conf" \
+ $(use glade || use gnome && echo \
+ "${D}/usr/$(get_libdir)/gtk2hs/glade.package.conf") \
+ $(use gnome && echo \
+ "${D}/usr/$(get_libdir)/gtk2hs/gconf.package.conf" \
+ "${D}/usr/$(get_libdir)/gtk2hs/sourceview.package.conf" ) \
+ $(use svg && echo \
+ "${D}/usr/$(get_libdir)/gtk2hs/svgcairo.package.conf") \
+ $(use opengl && echo \
+ "${D}/usr/$(get_libdir)/gtk2hs/gtkglext.package.conf") \
+ $(use seamonkey || use firefox || use xulrunner && echo \
+ "${D}/usr/$(get_libdir)/gtk2hs/mozembed.package.conf")
+ ghc-install-pkg
+}