summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2013-02-09 19:07:22 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2013-02-09 19:07:22 +0000
commit2188abe74762baffae6883e335a3940652e071ab (patch)
tree45b3601253ae5357cd41c182b2f58dc2561b7dbe /dev-haskell
parentVersion bump. (diff)
downloadgentoo-2-2188abe74762baffae6883e335a3940652e071ab.tar.gz
gentoo-2-2188abe74762baffae6883e335a3940652e071ab.tar.bz2
gentoo-2-2188abe74762baffae6883e335a3940652e071ab.zip
Switch to EAPI=5.
(Portage version: 2.2.0_alpha153_p6/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell')
-rw-r--r--dev-haskell/x11/ChangeLog7
-rw-r--r--dev-haskell/x11/x11-1.6.0.2-r1.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-haskell/x11/ChangeLog b/dev-haskell/x11/ChangeLog
index 56011280801d..9160a1807a5e 100644
--- a/dev-haskell/x11/ChangeLog
+++ b/dev-haskell/x11/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/x11
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.28 2013/01/01 08:15:43 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/ChangeLog,v 1.29 2013/02/09 19:07:22 slyfox Exp $
+
+*x11-1.6.0.2-r1 (09 Feb 2013)
+
+ 09 Feb 2013; Sergei Trofimovich <slyfox@gentoo.org> +x11-1.6.0.2-r1.ebuild:
+ Switch to EAPI=5.
*x11-1.6.0.2 (01 Jan 2013)
diff --git a/dev-haskell/x11/x11-1.6.0.2-r1.ebuild b/dev-haskell/x11/x11-1.6.0.2-r1.ebuild
new file mode 100644
index 000000000000..972bd7a654ce
--- /dev/null
+++ b/dev-haskell/x11/x11-1.6.0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/x11/x11-1.6.0.2-r1.ebuild,v 1.1 2013/02/09 19:07:22 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.1
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+MY_PN="X11"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A binding to the X11 graphics library"
+HOMEPAGE="https://github.com/haskell-pkg-janitors/X11"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~ppc64 ~ppc-macos ~x86-linux"
+IUSE="xinerama"
+
+RDEPEND="dev-haskell/syb[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXrandr
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ cabal_src_configure --configure-option=$(use_with xinerama)
+}