summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:32:35 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2013-08-26 12:32:35 +0000
commitfa0bda20b3a4078b952b9ddf648c7f1f24e929df (patch)
tree86310679a19fc7b6dbbdf31fc34fdf4afb7e308a /dev-haskell/yesod-json
parentdev-haskell/pwstore-fast: initial layout (diff)
downloadgentoo-2-fa0bda20b3a4078b952b9ddf648c7f1f24e929df.tar.gz
gentoo-2-fa0bda20b3a4078b952b9ddf648c7f1f24e929df.tar.bz2
gentoo-2-fa0bda20b3a4078b952b9ddf648c7f1f24e929df.zip
dev-haskell/yesod-json: initial layout
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/yesod-json')
-rw-r--r--dev-haskell/yesod-json/ChangeLog10
-rw-r--r--dev-haskell/yesod-json/metadata.xml11
-rw-r--r--dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild39
-rw-r--r--dev-haskell/yesod-json/yesod-json-1.2.0.ebuild24
4 files changed, 84 insertions, 0 deletions
diff --git a/dev-haskell/yesod-json/ChangeLog b/dev-haskell/yesod-json/ChangeLog
new file mode 100644
index 000000000000..75bb20ed11d3
--- /dev/null
+++ b/dev-haskell/yesod-json/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-haskell/yesod-json
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-json/ChangeLog,v 1.1 2013/08/26 12:32:35 qnikst Exp $
+
+*yesod-json-1.2.0 (26 Aug 2013)
+*yesod-json-1.1.2.2 (26 Aug 2013)
+
+ 26 Aug 2013; Alexander Vershilov <qnikst@gentoo.org> +metadata.xml,
+ +yesod-json-1.1.2.2.ebuild, +yesod-json-1.2.0.ebuild:
+ dev-haskell/yesod-json: initial layout
diff --git a/dev-haskell/yesod-json/metadata.xml b/dev-haskell/yesod-json/metadata.xml
new file mode 100644
index 000000000000..1dff43876f7a
--- /dev/null
+++ b/dev-haskell/yesod-json/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>haskell</herd>
+ <maintainer>
+ <email>haskell@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Generate content for Yesod using the aeson package.
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild b/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild
new file mode 100644
index 000000000000..8e7232bb197e
--- /dev/null
+++ b/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-json/yesod-json-1.1.2.2.ebuild,v 1.1 2013/08/26 12:32:35 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Generate content for Yesod using the aeson package."
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ >=dev-haskell/attoparsec-conduit-0.5:=[profile?]
+ dev-haskell/blaze-builder:=[profile?]
+ >=dev-haskell/conduit-0.5:=[profile?]
+ >=dev-haskell/safe-0.2:=[profile?]
+ >=dev-haskell/shakespeare-js-1.0:=[profile?]
+ >=dev-haskell/text-0.8:=[profile?]
+ >=dev-haskell/transformers-0.2.2:=[profile?]
+ >=dev-haskell/vector-0.9:=[profile?]
+ >=dev-haskell/wai-1.3:=[profile?]
+ >=dev-haskell/wai-extra-1.3:=[profile?]
+ >=dev-haskell/yesod-core-1.1:=[profile?]
+ >=dev-haskell/yesod-routes-1.1:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( dev-haskell/hspec
+ dev-haskell/wai-test
+ )"
diff --git a/dev-haskell/yesod-json/yesod-json-1.2.0.ebuild b/dev-haskell/yesod-json/yesod-json-1.2.0.ebuild
new file mode 100644
index 000000000000..2530ef858751
--- /dev/null
+++ b/dev-haskell/yesod-json/yesod-json-1.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yesod-json/yesod-json-1.2.0.ebuild,v 1.1 2013/08/26 12:32:35 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Generate content for Yesod using the aeson package. (deprecated)"
+HOMEPAGE="http://www.yesodweb.com/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/yesod-core-1.2:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"