summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexander Vershilov <qnikst@gentoo.org>2014-03-04 16:06:34 +0000
committerAlexander Vershilov <qnikst@gentoo.org>2014-03-04 16:06:34 +0000
commit82d7912e448bc19ca70d9b814a2c2e547846c2b3 (patch)
tree2abaaba3d0e8c7cec58a788de1f08224c4018738 /dev-haskell/yaml
parentnew version (diff)
downloadgentoo-2-82d7912e448bc19ca70d9b814a2c2e547846c2b3.tar.gz
gentoo-2-82d7912e448bc19ca70d9b814a2c2e547846c2b3.tar.bz2
gentoo-2-82d7912e448bc19ca70d9b814a2c2e547846c2b3.zip
new version
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xEAD50D64D8D3571A!)
Diffstat (limited to 'dev-haskell/yaml')
-rw-r--r--dev-haskell/yaml/ChangeLog9
-rw-r--r--dev-haskell/yaml/yaml-0.8.7.2.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/dev-haskell/yaml/ChangeLog b/dev-haskell/yaml/ChangeLog
index 7fdd0e72ba72..8726ff13a870 100644
--- a/dev-haskell/yaml/ChangeLog
+++ b/dev-haskell/yaml/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/yaml
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yaml/ChangeLog,v 1.4 2013/12/10 13:37:47 gienah Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yaml/ChangeLog,v 1.5 2014/03/04 16:06:34 qnikst Exp $
+
+*yaml-0.8.7.2 (04 Mar 2014)
+
+ 04 Mar 2014; Alexander Vershilov <qnikst@gentoo.org> +yaml-0.8.7.2.ebuild:
+ new version
*yaml-0.8.5.2 (10 Dec 2013)
diff --git a/dev-haskell/yaml/yaml-0.8.7.2.ebuild b/dev-haskell/yaml/yaml-0.8.7.2.ebuild
new file mode 100644
index 000000000000..71b8bea2205b
--- /dev/null
+++ b/dev-haskell/yaml/yaml-0.8.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/yaml/yaml-0.8.7.2.ebuild,v 1.1 2014/03/04 16:06:34 qnikst Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.6.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Support for parsing and rendering YAML documents."
+HOMEPAGE="http://github.com/snoyberg/yaml/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="no-exe system-libyaml"
+
+RDEPEND=">=dev-haskell/aeson-0.5:=[profile?]
+ dev-haskell/attoparsec:=[profile?]
+ >=dev-haskell/conduit-1.0.11:=[profile?] <dev-haskell/conduit-1.1:=[profile?]
+ >=dev-haskell/resourcet-0.3:=[profile?] <dev-haskell/resourcet-0.5:=[profile?]
+ dev-haskell/scientific:=[profile?]
+ dev-haskell/text:=[profile?]
+ >=dev-haskell/transformers-0.1:=[profile?] <dev-haskell/transformers-0.4:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/vector:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ system-libyaml? ( dev-libs/libyaml )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hspec-1.3
+ dev-haskell/hunit )
+ system-libyaml? ( virtual/pkgconfig )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag no-exe no-exe) \
+ $(cabal_flag system-libyaml system-libyaml)
+}