summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2007-01-06 18:11:19 +0000
committerAndres Loeh <kosmikus@gentoo.org>2007-01-06 18:11:19 +0000
commit147eff173633cc4b742a3edde4c0c7f35add1192 (patch)
tree979a5cd41d8b5465882428db50564b02835de97f /dev-haskell/wxhaskell
parentVersion bump (diff)
downloadgentoo-2-147eff173633cc4b742a3edde4c0c7f35add1192.tar.gz
gentoo-2-147eff173633cc4b742a3edde4c0c7f35add1192.tar.bz2
gentoo-2-147eff173633cc4b742a3edde4c0c7f35add1192.zip
Fixed elog / einfo usage.
(Portage version: 2.1.1)
Diffstat (limited to 'dev-haskell/wxhaskell')
-rw-r--r--dev-haskell/wxhaskell/ChangeLog8
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.8-r1.ebuild14
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild14
-rw-r--r--dev-haskell/wxhaskell/wxhaskell-0.9.ebuild14
4 files changed, 27 insertions, 23 deletions
diff --git a/dev-haskell/wxhaskell/ChangeLog b/dev-haskell/wxhaskell/ChangeLog
index 9453e9532ef8..efe6ab28795f 100644
--- a/dev-haskell/wxhaskell/ChangeLog
+++ b/dev-haskell/wxhaskell/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-haskell/wxhaskell
-# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.21 2006/05/19 05:13:17 squinky86 Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/ChangeLog,v 1.22 2007/01/06 18:11:19 kosmikus Exp $
+
+ 06 Jan 2007; Andres Loeh <kosmikus@gentoo.org> wxhaskell-0.8-r1.ebuild,
+ wxhaskell-0.9.ebuild, wxhaskell-0.9.4.ebuild:
+ Fixed elog / einfo usage.
19 May 2006; Jon Hood <squinky86@gentoo.org> wxhaskell-0.9.4.ebuild:
Use the correct libdirs when installing for 64-bit. This way, it compiles
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.8-r1.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.8-r1.ebuild
index 2d4d818af6d0..89687c73f808 100644
--- a/dev-haskell/wxhaskell/wxhaskell-0.8-r1.ebuild
+++ b/dev-haskell/wxhaskell/wxhaskell-0.8-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.8-r1.ebuild,v 1.8 2006/02/19 18:50:26 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.8-r1.ebuild,v 1.9 2007/01/06 18:11:19 kosmikus Exp $
inherit flag-o-matic wxwidgets ghc-package
@@ -24,14 +24,14 @@ DEPEND="${RDEPEND}
pkg_setup() {
if ! built_with_use x11-libs/wxGTK X; then
- einfo "wxhaskell needs wxGTK that has been built with X11 support."
- einfo "Please re-emerge wxGTK with USE=\"X -odbc -unicode\""
+ eerror "wxhaskell needs wxGTK that has been built with X11 support."
+ eerror "Please re-emerge wxGTK with USE=\"X -odbc -unicode\""
die "wxhaskell requires wxGTK to be built with USE=\"X -odbc -unicode\""
fi
if built_with_use x11-libs/wxGTK odbc; then
- einfo "Sadly wxhaskell does not work with wxGTK that has been built"
- einfo "with USE=\"odbc\"."
- einfo "Please re-emerge wxGTK with USE=\"-odbc\""
+ eerror "Sadly wxhaskell does not work with wxGTK that has been built"
+ eerror "with USE=\"odbc\"."
+ eerror "Please re-emerge wxGTK with USE=\"-odbc\""
die "wxhaskell requires wxGTK to be built with USE=\"-odbc\""
fi
}
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild
index 14b5d976ff06..dace6e610a85 100644
--- a/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild
+++ b/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild,v 1.6 2006/05/19 05:13:17 squinky86 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.9.4.ebuild,v 1.7 2007/01/06 18:11:19 kosmikus Exp $
inherit flag-o-matic wxwidgets ghc-package multilib
@@ -22,14 +22,14 @@ DEPEND="${RDEPEND}
pkg_setup() {
if ! built_with_use x11-libs/wxGTK X; then
- einfo "wxhaskell needs wxGTK that has been built with X11 support."
- einfo "Please re-emerge wxGTK with USE=\"X -odbc -unicode\""
+ eerror "wxhaskell needs wxGTK that has been built with X11 support."
+ eerror "Please re-emerge wxGTK with USE=\"X -odbc -unicode\""
die "wxhaskell requires wxGTK to be built with USE=\"X -odbc -unicode\""
fi
if built_with_use x11-libs/wxGTK odbc; then
- einfo "Sadly wxhaskell does not work with wxGTK that has been built"
- einfo "with USE=\"odbc\"."
- einfo "Please re-emerge wxGTK with USE=\"-odbc\""
+ eerror "Sadly wxhaskell does not work with wxGTK that has been built"
+ eerror "with USE=\"odbc\"."
+ eerror "Please re-emerge wxGTK with USE=\"-odbc\""
die "wxhaskell requires wxGTK to be built with USE=\"-odbc\""
fi
}
diff --git a/dev-haskell/wxhaskell/wxhaskell-0.9.ebuild b/dev-haskell/wxhaskell/wxhaskell-0.9.ebuild
index 8e69bfde1aa0..21bc2ef9a7c7 100644
--- a/dev-haskell/wxhaskell/wxhaskell-0.9.ebuild
+++ b/dev-haskell/wxhaskell/wxhaskell-0.9.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.9.ebuild,v 1.5 2006/02/19 18:50:26 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/wxhaskell/wxhaskell-0.9.ebuild,v 1.6 2007/01/06 18:11:19 kosmikus Exp $
inherit flag-o-matic wxwidgets ghc-package
@@ -24,14 +24,14 @@ DEPEND="${RDEPEND}
pkg_setup() {
if ! built_with_use x11-libs/wxGTK X; then
- einfo "wxhaskell needs wxGTK that has been built with X11 support."
- einfo "Please re-emerge wxGTK with USE=\"X -odbc -unicode\""
+ eerror "wxhaskell needs wxGTK that has been built with X11 support."
+ eerror "Please re-emerge wxGTK with USE=\"X -odbc -unicode\""
die "wxhaskell requires wxGTK to be built with USE=\"X -odbc -unicode\""
fi
if built_with_use x11-libs/wxGTK odbc; then
- einfo "Sadly wxhaskell does not work with wxGTK that has been built"
- einfo "with USE=\"odbc\"."
- einfo "Please re-emerge wxGTK with USE=\"-odbc\""
+ eerror "Sadly wxhaskell does not work with wxGTK that has been built"
+ eerror "with USE=\"odbc\"."
+ eerror "Please re-emerge wxGTK with USE=\"-odbc\""
die "wxhaskell requires wxGTK to be built with USE=\"-odbc\""
fi
}