summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-09-13 06:36:15 +0000
committerMark Wright <gienah@gentoo.org>2013-09-13 06:36:15 +0000
commitcc724c77b761b8984ae656ab8fb2c4117d09c46d (patch)
tree28788a948a7a8c2615cd55115789f2185deeea8e /dev-haskell/tls
parentAdd tagstream-conduit (diff)
downloadgentoo-2-cc724c77b761b8984ae656ab8fb2c4117d09c46d.tar.gz
gentoo-2-cc724c77b761b8984ae656ab8fb2c4117d09c46d.tar.bz2
gentoo-2-cc724c77b761b8984ae656ab8fb2c4117d09c46d.zip
Bump tls to 1.1.5
(Portage version: 2.2.3/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/tls')
-rw-r--r--dev-haskell/tls/ChangeLog7
-rw-r--r--dev-haskell/tls/tls-1.1.5.ebuild42
2 files changed, 48 insertions, 1 deletions
diff --git a/dev-haskell/tls/ChangeLog b/dev-haskell/tls/ChangeLog
index 2686e94f29c4..74e691928fe4 100644
--- a/dev-haskell/tls/ChangeLog
+++ b/dev-haskell/tls/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/tls
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/ChangeLog,v 1.1 2013/08/26 08:20:07 qnikst Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/ChangeLog,v 1.2 2013/09/13 06:36:15 gienah Exp $
+
+*tls-1.1.5 (13 Sep 2013)
+
+ 13 Sep 2013; Mark Wright <gienah@gentoo.org> +tls-1.1.5.ebuild:
+ Bump tls to 1.1.5
*tls-1.1.2 (26 Aug 2013)
diff --git a/dev-haskell/tls/tls-1.1.5.ebuild b/dev-haskell/tls/tls-1.1.5.ebuild
new file mode 100644
index 000000000000..e0d5a3c4d68d
--- /dev/null
+++ b/dev-haskell/tls/tls-1.1.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/tls-1.1.5.ebuild,v 1.1 2013/09/13 06:36:15 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.3.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
+HOMEPAGE="http://github.com/vincenthz/hs-tls"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compat"
+RESTRICT="test"
+
+RDEPEND=">=dev-haskell/cereal-0.3:=[profile?]
+ >=dev-haskell/certificate-1.3.0:=[profile?] <dev-haskell/certificate-1.4.0:=[profile?]
+ >=dev-haskell/crypto-pubkey-0.2:=[profile?]
+ >=dev-haskell/crypto-random-0.0.7:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/cryptohash-0.6:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/cprng-aes-0.5
+ >=dev-haskell/quickcheck-2
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag compat compat)
+}