summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2014-05-10 11:45:51 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2014-05-10 11:45:51 +0000
commit7a9994d63a86749b596cb8260a696971223b3ebc (patch)
treef712de3efeb41de0d2d8a38dcd2428c1039d424c /dev-haskell/tls
parentAllow Cabal-1.20. (diff)
downloadgentoo-2-7a9994d63a86749b596cb8260a696971223b3ebc.tar.gz
gentoo-2-7a9994d63a86749b596cb8260a696971223b3ebc.tar.bz2
gentoo-2-7a9994d63a86749b596cb8260a696971223b3ebc.zip
Version bump.
(Portage version: 2.2.10_p15/cvs/Linux x86_64, signed Manifest commit with key 611FF3AA)
Diffstat (limited to 'dev-haskell/tls')
-rw-r--r--dev-haskell/tls/ChangeLog7
-rw-r--r--dev-haskell/tls/tls-1.2.7.ebuild54
2 files changed, 60 insertions, 1 deletions
diff --git a/dev-haskell/tls/ChangeLog b/dev-haskell/tls/ChangeLog
index 0460b91bc66c..e8f0a28cad8e 100644
--- a/dev-haskell/tls/ChangeLog
+++ b/dev-haskell/tls/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/tls
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/ChangeLog,v 1.5 2014/03/09 13:02:11 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/ChangeLog,v 1.6 2014/05/10 11:45:51 slyfox Exp $
+
+*tls-1.2.7 (10 May 2014)
+
+ 10 May 2014; Sergei Trofimovich <slyfox@gentoo.org> +tls-1.2.7.ebuild:
+ Version bump.
*tls-1.2.2 (09 Mar 2014)
diff --git a/dev-haskell/tls/tls-1.2.7.ebuild b/dev-haskell/tls/tls-1.2.7.ebuild
new file mode 100644
index 000000000000..cfd30f2ebde7
--- /dev/null
+++ b/dev-haskell/tls/tls-1.2.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/tls/tls-1.2.7.ebuild,v 1.1 2014/05/10 11:45:51 slyfox Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="TLS/SSL protocol native implementation (Server and Client)"
+HOMEPAGE="http://github.com/vincenthz/hs-tls"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compat"
+
+RDEPEND="dev-haskell/asn1-encoding:=[profile?]
+ >=dev-haskell/asn1-types-0.2.0:=[profile?]
+ dev-haskell/byteable:=[profile?]
+ >=dev-haskell/cereal-0.4:=[profile?]
+ >=dev-haskell/cipher-aes-0.2:=[profile?] <dev-haskell/cipher-aes-0.3:=[profile?]
+ dev-haskell/cipher-rc4:=[profile?]
+ dev-haskell/crypto-numbers:=[profile?]
+ >=dev-haskell/crypto-pubkey-0.2.4:=[profile?]
+ >=dev-haskell/crypto-pubkey-types-0.4:=[profile?]
+ >=dev-haskell/crypto-random-0.0:=[profile?] <dev-haskell/crypto-random-0.1:=[profile?]
+ >=dev-haskell/cryptohash-0.6:=[profile?]
+ dev-haskell/data-default-class:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/network:=[profile?]
+ >=dev-haskell/x509-1.4.3:=[profile?] <dev-haskell/x509-1.5.0:=[profile?]
+ >=dev-haskell/x509-store-1.4.4:=[profile?]
+ >=dev-haskell/x509-validation-1.5.0:=[profile?] <dev-haskell/x509-validation-1.6.0:=[profile?]
+ >=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/cprng-aes-0.5
+ dev-haskell/crypto-random
+ >=dev-haskell/quickcheck-2
+ dev-haskell/test-framework
+ dev-haskell/test-framework-quickcheck2
+ dev-haskell/x509
+ dev-haskell/x509-validation )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag compat compat)
+}