summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-12-14 06:32:28 +0000
committerMark Wright <gienah@gentoo.org>2014-12-14 06:32:28 +0000
commit6114c9060c226a0906143988eb6c835aed08e805 (patch)
treeeaf913cb7f4073a0e3815f546fb29c747e6c458c /dev-haskell/text
parentmask dev-haskell/text test as test dependencies need keywording (diff)
downloadgentoo-2-6114c9060c226a0906143988eb6c835aed08e805.tar.gz
gentoo-2-6114c9060c226a0906143988eb6c835aed08e805.tar.bz2
gentoo-2-6114c9060c226a0906143988eb6c835aed08e805.zip
Bump text to 1.2.0.3
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/text')
-rw-r--r--dev-haskell/text/ChangeLog7
-rw-r--r--dev-haskell/text/text-1.2.0.3.ebuild36
2 files changed, 42 insertions, 1 deletions
diff --git a/dev-haskell/text/ChangeLog b/dev-haskell/text/ChangeLog
index 4905deacc450..62417a861d04 100644
--- a/dev-haskell/text/ChangeLog
+++ b/dev-haskell/text/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/text
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.44 2014/07/25 09:16:36 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/ChangeLog,v 1.45 2014/12/14 06:32:28 gienah Exp $
+
+*text-1.2.0.3 (14 Dec 2014)
+
+ 14 Dec 2014; Mark Wright <gienah@gentoo.org> +text-1.2.0.3.ebuild:
+ Bump text to 1.2.0.3
25 Jul 2014; Sergei Trofimovich <slyfox@gentoo.org> text-0.11.3.1.ebuild,
text-1.1.0.0.ebuild, text-1.1.0.1.ebuild, text-1.1.1.3.ebuild:
diff --git a/dev-haskell/text/text-1.2.0.3.ebuild b/dev-haskell/text/text-1.2.0.3.ebuild
new file mode 100644
index 000000000000..d04542f201a2
--- /dev/null
+++ b/dev-haskell/text/text-1.2.0.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-1.2.0.3.ebuild,v 1.1 2014/12/14 06:32:28 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.4.4.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type"
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="developer"
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/hunit-1.2
+ >=dev-haskell/quickcheck-2.7
+ dev-haskell/random
+ >=dev-haskell/test-framework-0.4
+ >=dev-haskell/test-framework-hunit-0.2
+ >=dev-haskell/test-framework-quickcheck2-0.2 )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag developer developer)
+}