summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-03-06 05:48:02 +0000
committerMark Wright <gienah@gentoo.org>2012-03-06 05:48:02 +0000
commitdc8a96d543826c637b4d11f534f7f7e28b5afb5f (patch)
tree3795babdb3dac55cc11cb6f435a98549c8606074 /dev-haskell/text/text-0.11.1.13-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-dc8a96d543826c637b4d11f534f7f7e28b5afb5f.tar.gz
gentoo-2-dc8a96d543826c637b4d11f534f7f7e28b5afb5f.tar.bz2
gentoo-2-dc8a96d543826c637b4d11f534f7f7e28b5afb5f.zip
Bump text to 0.11.1.13-r1 (as in gentoo-haskell overlay), sync keywords with its reverse dependency darcs-2.5.2.
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/text/text-0.11.1.13-r1.ebuild')
-rw-r--r--dev-haskell/text/text-0.11.1.13-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-haskell/text/text-0.11.1.13-r1.ebuild b/dev-haskell/text/text-0.11.1.13-r1.ebuild
new file mode 100644
index 000000000000..0316304d1353
--- /dev/null
+++ b/dev-haskell/text/text-0.11.1.13-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/text/text-0.11.1.13-r1.ebuild,v 1.1 2012/03/06 05:48:02 gienah Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="4"
+
+CABAL_FEATURES="lib profile haddock hscolour hoogle"
+inherit haskell-cabal
+
+DESCRIPTION="An efficient packed Unicode text type."
+HOMEPAGE="https://github.com/bos/text"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND=">=dev-haskell/deepseq-1.1.0.0[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8
+ test? ( >=dev-haskell/quickcheck-2.4.0.1[profile?]
+ <dev-haskell/test-framework-0.6[profile?]
+ <dev-haskell/test-framework-hunit-0.3[profile?]
+ <dev-haskell/test-framework-quickcheck2-0.3[profile?]
+ )"
+
+src_prepare() {
+ sed -e 's@test-framework >= 0.4 && < 0.5@test-framework >= 0.4 \&\& < 0.6@' \
+ -i "${S}/${PN}.cabal" || die "Could not loosen depdencies"
+}
+
+src_configure() {
+ # the tests need a utf-8 locale
+ cabal_src_configure $(use test && use_enable test tests) #395351
+}