summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 11:11:40 +0000
committerLennart Kolmodin <kolmodin@gentoo.org>2009-04-19 11:11:40 +0000
commitc4c6609b03cf75e59891459ccffb76fc536628f0 (patch)
tree075537d436a056aa57c85ba1af10c125fa5723d6 /dev-haskell/http
parentVersion bump dev-haskell/quickcheck (diff)
downloadgentoo-2-c4c6609b03cf75e59891459ccffb76fc536628f0.tar.gz
gentoo-2-c4c6609b03cf75e59891459ccffb76fc536628f0.tar.bz2
gentoo-2-c4c6609b03cf75e59891459ccffb76fc536628f0.zip
Version bump dev-haskell/http
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/ChangeLog9
-rw-r--r--dev-haskell/http/http-4000.0.5.ebuild27
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-haskell/http/ChangeLog b/dev-haskell/http/ChangeLog
index f676d820b570..c53d42ac6430 100644
--- a/dev-haskell/http/ChangeLog
+++ b/dev-haskell/http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.9 2008/10/02 20:21:35 jer Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.10 2009/04/19 11:11:40 kolmodin Exp $
+
+*http-4000.0.5 (19 Apr 2009)
+
+ 19 Apr 2009; Lennart Kolmodin <kolmodin@gentoo.org> +http-4000.0.5.ebuild:
+ Version bump.
02 Oct 2008; Jeroen Roovers <jer@gentoo.org> http-3001.0.0.ebuild:
Marked ~hppa for dev-util/darcs-2.1.*.
diff --git a/dev-haskell/http/http-4000.0.5.ebuild b/dev-haskell/http/http-4000.0.5.ebuild
new file mode 100644
index 000000000000..80d50a10a82b
--- /dev/null
+++ b/dev-haskell/http/http-4000.0.5.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.0.5.ebuild,v 1.1 2009/04/19 11:11:40 kolmodin Exp $
+
+CABAL_FEATURES="lib profile haddock"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="http://projects.haskell.org/http/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-6.6.1
+ dev-haskell/mtl
+ dev-haskell/network
+ dev-haskell/parsec"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+S="${WORKDIR}/${MY_P}"