summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2013-04-02 11:19:40 +0000
committerMark Wright <gienah@gentoo.org>2013-04-02 11:19:40 +0000
commitb2ac99bdb2258171ec9215aed2d020078ac70b1b (patch)
treea73364c9bb0cd2aa45e8d6cabc8c235ba2c11ec9 /dev-haskell/http
parentStable for hppa, wrt bug #457484 (diff)
downloadgentoo-2-b2ac99bdb2258171ec9215aed2d020078ac70b1b.tar.gz
gentoo-2-b2ac99bdb2258171ec9215aed2d020078ac70b1b.tar.bz2
gentoo-2-b2ac99bdb2258171ec9215aed2d020078ac70b1b.zip
Bump http to 4000.2.8
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/http')
-rw-r--r--dev-haskell/http/ChangeLog7
-rw-r--r--dev-haskell/http/http-4000.2.8.ebuild61
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-haskell/http/ChangeLog b/dev-haskell/http/ChangeLog
index ad1286ed9f44..b5b1800cf27a 100644
--- a/dev-haskell/http/ChangeLog
+++ b/dev-haskell/http/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/http
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.36 2013/03/31 10:04:15 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/ChangeLog,v 1.37 2013/04/02 11:19:40 gienah Exp $
+
+*http-4000.2.8 (02 Apr 2013)
+
+ 02 Apr 2013; Mark Wright <gienah@gentoo.org> +http-4000.2.8.ebuild:
+ Bump http to 4000.2.8
31 Mar 2013; Agostino Sarubbo <ago@gentoo.org> http-4000.2.6.ebuild:
Stable for sparc, wrt bug #456496
diff --git a/dev-haskell/http/http-4000.2.8.ebuild b/dev-haskell/http/http-4000.2.8.ebuild
new file mode 100644
index 000000000000..c14b6359b11c
--- /dev/null
+++ b/dev-haskell/http/http-4000.2.8.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/http/http-4000.2.8.ebuild,v 1.1 2013/04/02 11:19:40 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+MY_PN="HTTP"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A library for client-side HTTP"
+HOMEPAGE="https://github.com/haskell/HTTP"
+SRC_URI="mirror://hackage/packages/archive/${MY_PN}/${PV}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~ppc-macos ~x86-macos"
+# hackport-args: --always-disabled='mtl1 network23 old-base warn-as-error'
+IUSE=""
+
+RDEPEND="<dev-haskell/network-2.5:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ >=dev-haskell/mtl-2.0:=[profile?]
+ <dev-haskell/mtl-2.2:=[profile?]"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"
+RESTRICT=test # missing modules: Could not find module `Httpd'
+# test? ( =dev-haskell/case-insensitive-0.4*
+# >=dev-haskell/conduit-0.4
+# <dev-haskell/conduit-0.6
+# =dev-haskell/deepseq-1.3*
+# >=dev-haskell/http-types-0.6
+# <dev-haskell/http-types-0.8
+# dev-haskell/httpd-shed
+# dev-haskell/hunit
+# =dev-haskell/puremd5-2.1*
+# >=dev-haskell/split-0.1
+# <dev-haskell/split-0.3
+# dev-haskell/test-framework
+# dev-haskell/test-framework-hunit
+# >=dev-haskell/wai-1.2
+# <dev-haskell/wai-1.4
+# >=dev-haskell/warp-1.2
+# <dev-haskell/warp-1.4
+# )
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-network23 \
+ --flag=-warn-as-error \
+ --flag=-mtl1 \
+ --flag=-old-base \
+ --disable-tests
+}