summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndres Loeh <kosmikus@gentoo.org>2005-02-23 09:45:59 +0000
committerAndres Loeh <kosmikus@gentoo.org>2005-02-23 09:45:59 +0000
commitebbaec10fab81eb07f95e53672a335da888b7737 (patch)
tree78e5107cf8b50c7f1ad6f06d0a1d0650efb8ddc3 /dev-haskell/hs-plugins
parentClosed bug #72383 (diff)
downloadgentoo-2-ebbaec10fab81eb07f95e53672a335da888b7737.tar.gz
gentoo-2-ebbaec10fab81eb07f95e53672a335da888b7737.tar.bz2
gentoo-2-ebbaec10fab81eb07f95e53672a335da888b7737.zip
New version.
Diffstat (limited to 'dev-haskell/hs-plugins')
-rw-r--r--dev-haskell/hs-plugins/ChangeLog7
-rw-r--r--dev-haskell/hs-plugins/files/digest-hs-plugins-0.9.82
-rw-r--r--dev-haskell/hs-plugins/hs-plugins-0.9.8.ebuild47
3 files changed, 55 insertions, 1 deletions
diff --git a/dev-haskell/hs-plugins/ChangeLog b/dev-haskell/hs-plugins/ChangeLog
index c3f0ac783ef7..839034dc5a9f 100644
--- a/dev-haskell/hs-plugins/ChangeLog
+++ b/dev-haskell/hs-plugins/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/hs-plugins
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/ChangeLog,v 1.4 2005/01/01 18:05:20 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/ChangeLog,v 1.5 2005/02/23 09:45:59 kosmikus Exp $
+
+*hs-plugins-0.9.8 (23 Feb 2005)
+
+ 23 Feb 2005; Andres Loeh <kosmikus@gentoo.org> +hs-plugins-0.9.8.ebuild:
+ New version.
17 Dec 2004; Andres Loeh <kosmikus@gentoo.org> hs-plugins-0.9.6.ebuild:
Fixed IUSE.
diff --git a/dev-haskell/hs-plugins/files/digest-hs-plugins-0.9.8 b/dev-haskell/hs-plugins/files/digest-hs-plugins-0.9.8
new file mode 100644
index 000000000000..28bb205cb6d3
--- /dev/null
+++ b/dev-haskell/hs-plugins/files/digest-hs-plugins-0.9.8
@@ -0,0 +1,2 @@
+MD5 2a809ef92f3ec5970b99aeb22078fb3e hs-plugins-0.9.8.tar.gz 250712
+MD5 2ba9b743f45c294bd32bd9e5ad44352b hs-plugins.html.tar.gz 24643
diff --git a/dev-haskell/hs-plugins/hs-plugins-0.9.8.ebuild b/dev-haskell/hs-plugins/hs-plugins-0.9.8.ebuild
new file mode 100644
index 000000000000..8c1b7c88f98b
--- /dev/null
+++ b/dev-haskell/hs-plugins/hs-plugins-0.9.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hs-plugins/hs-plugins-0.9.8.ebuild,v 1.1 2005/02/23 09:45:59 kosmikus Exp $
+
+inherit base ghc-package
+
+IUSE="doc"
+
+DESCRIPTION="Dynamically Loaded Haskell Plugins"
+HOMEPAGE="http://www.cse.unsw.edu.au/~dons/hs-plugins/"
+SRC_URI="ftp://ftp.cse.unsw.edu.au/pub/users/dons/${PN}/${P}.tar.gz
+doc? ( http://www.cse.unsw.edu.au/~dons/${PN}/${PN}.html.tar.gz )"
+
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+LICENSE="as-is"
+
+DEPEND=">=virtual/ghc-6.2"
+
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ # for package management
+ sed -i 's:ghc-pkg -u:\${GHC_PKGF} -u:' ${S}/Makefile
+}
+
+src_compile() {
+ econf
+ # for package management
+ echo 'GHC_PKGF = ${GHC_PKG} -f '"${S}/$(ghc-localpkgconf)" >> config.mk
+ emake -j1
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ ghc-setup-pkg
+ emake PREFIX="${D}/usr" register # then we don't need --force in ghc-pkg
+ ghc-install-pkg
+
+ dodoc AUTHORS README TODO VERSION
+
+ if use doc; then
+ dohtml ${WORKDIR}/${PN}/*
+ fi
+}
+