summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuis Francisco Araujo <araujo@gentoo.org>2005-03-08 23:03:12 +0000
committerLuis Francisco Araujo <araujo@gentoo.org>2005-03-08 23:03:12 +0000
commit7f3b4b8aaf6504609da1593426df6d7952c6a4d0 (patch)
tree767eeb1a40d27a603b4af1e795822d1788de6f44 /dev-haskell/hmake
parentfix deps (Manifest recommit) (diff)
downloadgentoo-2-7f3b4b8aaf6504609da1593426df6d7952c6a4d0.tar.gz
gentoo-2-7f3b4b8aaf6504609da1593426df6d7952c6a4d0.tar.bz2
gentoo-2-7f3b4b8aaf6504609da1593426df6d7952c6a4d0.zip
Added new hmake version
(Portage version: 2.0.51.19)
Diffstat (limited to 'dev-haskell/hmake')
-rw-r--r--dev-haskell/hmake/ChangeLog8
-rw-r--r--dev-haskell/hmake/Manifest6
-rw-r--r--dev-haskell/hmake/files/digest-hmake-3.091
-rw-r--r--dev-haskell/hmake/hmake-3.09.ebuild54
-rw-r--r--dev-haskell/hmake/metadata.xml3
5 files changed, 69 insertions, 3 deletions
diff --git a/dev-haskell/hmake/ChangeLog b/dev-haskell/hmake/ChangeLog
index db2e26fa338e..c9d0aeab7340 100644
--- a/dev-haskell/hmake/ChangeLog
+++ b/dev-haskell/hmake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-haskell/hmake
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.11 2005/01/21 10:34:58 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/ChangeLog,v 1.12 2005/03/08 23:03:12 araujo Exp $
+
+*hmake-3.09 (08 Mar 2005)
+
+ 08 Mar 2005; Luis F. Araujo <araujo@gentoo.org> metadata.xml,
+ +hmake-3.09.ebuild:
+ New hmake release
21 Jan 2005; Andres Loeh <kosmikus@gentoo.org> -hmake-3.07.ebuild,
hmake-3.08.ebuild:
diff --git a/dev-haskell/hmake/Manifest b/dev-haskell/hmake/Manifest
index 46db1cc8c8c6..2b799826b672 100644
--- a/dev-haskell/hmake/Manifest
+++ b/dev-haskell/hmake/Manifest
@@ -1,4 +1,6 @@
-MD5 dd301d3b0c4370817c888f5ef010a402 hmake-3.08.ebuild 1387
MD5 e479cb0a08516a1ad41d969286195755 ChangeLog 1609
-MD5 a769ecfcd1cdd2d40986627df7dfb249 metadata.xml 224
+MD5 dd301d3b0c4370817c888f5ef010a402 hmake-3.08.ebuild 1387
+MD5 e0ce59fd27b9382896cdb87d5fa48f89 metadata.xml 286
+MD5 12e88c298ccb7051cdfb3f26805b8786 hmake-3.09.ebuild 1366
MD5 77342bba93c32304e51d32b4894dddf2 files/digest-hmake-3.08 61
+MD5 50a20e8dc3ef16030908acbe85b97f1b files/digest-hmake-3.09 62
diff --git a/dev-haskell/hmake/files/digest-hmake-3.09 b/dev-haskell/hmake/files/digest-hmake-3.09
new file mode 100644
index 000000000000..f9644db20d45
--- /dev/null
+++ b/dev-haskell/hmake/files/digest-hmake-3.09
@@ -0,0 +1 @@
+MD5 72ac1fbca710dd8be5926600b119b4f4 hmake-3.09.tar.gz 100103
diff --git a/dev-haskell/hmake/hmake-3.09.ebuild b/dev-haskell/hmake/hmake-3.09.ebuild
new file mode 100644
index 000000000000..08ab4600b277
--- /dev/null
+++ b/dev-haskell/hmake/hmake-3.09.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hmake/hmake-3.09.ebuild,v 1.1 2005/03/08 23:03:12 araujo Exp $
+
+inherit base fixheadtails
+
+DESCRIPTION="a make tool for Haskell programs"
+HOMEPAGE="http://www.haskell.org/hmake/"
+SRC_URI="http://www.haskell.org/hmake/${P}.tar.gz"
+
+LICENSE="nhc98"
+KEYWORDS="~x86"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/ghc
+ sys-libs/readline"
+RDEPEND="sys-libs/readline
+ virtual/libc
+ dev-libs/gmp"
+
+# if using readline, hmake depends also on ncurses; but
+# readline already has this dependency
+
+src_compile() {
+ local buildwith
+ local arch
+
+ buildwith="--buildwith=ghc"
+
+ # fix all head/tail declarations
+ sed -i 's/tail -1/tail -n 1/' src/hmake/MkConfig.hs
+ # the line above prevents current fixheadtails.eclass from doing nonsense;
+ # double space before -n is significant
+ ht_fix_all
+
+ # fix string gaps
+ sed -i -e 's/\\ $/" ++/' -e 's/^\\/ "/' src/interpreter/HInteractive.hs
+
+ # package uses non-standard configure, therefore econf does
+ # not work ...
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man/man1 \
+ ${buildwith} || die "./configure failed"
+
+ # emake tested; does not work
+ emake -j1 || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die "make install failed"
+ dohtml docs/hmake/*
+}
diff --git a/dev-haskell/hmake/metadata.xml b/dev-haskell/hmake/metadata.xml
index a53a18c06081..347541c13d52 100644
--- a/dev-haskell/hmake/metadata.xml
+++ b/dev-haskell/hmake/metadata.xml
@@ -5,4 +5,7 @@
<maintainer>
<email>kosmikus@gentoo.org</email>
</maintainer>
+<maintainer>
+ <email>araujo@gentoo.org</email>
+</maintainer>
</pkgmetadata>