summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2012-06-02 03:56:46 +0000
committerMark Wright <gienah@gentoo.org>2012-06-02 03:56:46 +0000
commit82a841a65ab74bdde9ae39ec678044aa8cd04313 (patch)
tree7079e4ae312d5cae905faf3a6132771e8155fced /dev-haskell/highlighting-kate
parentFix build with ghc 7.5 dev snapshot (diff)
downloadgentoo-2-82a841a65ab74bdde9ae39ec678044aa8cd04313.tar.gz
gentoo-2-82a841a65ab74bdde9ae39ec678044aa8cd04313.tar.bz2
gentoo-2-82a841a65ab74bdde9ae39ec678044aa8cd04313.zip
Bump highlighting-kate to 0.5.1
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/highlighting-kate')
-rw-r--r--dev-haskell/highlighting-kate/ChangeLog7
-rw-r--r--dev-haskell/highlighting-kate/highlighting-kate-0.5.1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-haskell/highlighting-kate/ChangeLog b/dev-haskell/highlighting-kate/ChangeLog
index c128eb844db4..d9d469d02b3c 100644
--- a/dev-haskell/highlighting-kate/ChangeLog
+++ b/dev-haskell/highlighting-kate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/highlighting-kate
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.3 2012/03/10 17:46:31 slyfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/ChangeLog,v 1.4 2012/06/02 03:56:46 gienah Exp $
+
+*highlighting-kate-0.5.1 (02 Jun 2012)
+
+ 02 Jun 2012; Mark Wright <gienah@gentoo.org> +highlighting-kate-0.5.1.ebuild:
+ Bump highlighting-kate to 0.5.1
*highlighting-kate-0.5.0.5 (10 Mar 2012)
diff --git a/dev-haskell/highlighting-kate/highlighting-kate-0.5.1.ebuild b/dev-haskell/highlighting-kate/highlighting-kate-0.5.1.ebuild
new file mode 100644
index 000000000000..eebe539b8778
--- /dev/null
+++ b/dev-haskell/highlighting-kate/highlighting-kate-0.5.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/highlighting-kate/highlighting-kate-0.5.1.ebuild,v 1.1 2012/06/02 03:56:46 gienah Exp $
+
+EAPI=4
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Syntax highlighting"
+HOMEPAGE="http://github.com/jgm/highlighting-kate"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="executable pcre-light"
+
+RDEPEND=">=dev-haskell/blaze-html-0.4.2[profile?]
+ <dev-haskell/blaze-html-0.6[profile?]
+ dev-haskell/mtl[profile?]
+ dev-haskell/parsec[profile?]
+ pcre-light? ( dev-haskell/pcre-light[profile?] )
+ !pcre-light? ( dev-haskell/regex-pcre-builtin[profile?] )
+ >=dev-lang/ghc-6.8.2"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.2"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag executable) \
+ $(cabal_flag pcre-light)
+}