summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-03-20 08:26:21 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-03-20 08:26:21 +0000
commit8ce322a3e6fc06e25d8d7170100582495141745e (patch)
treeaf2a2f48a485f7d4b4ed55fe07f27398d4b2f695 /dev-haskell/cabal-install/cabal-install-0.10.2-r2.ebuild
parentStable for amd64, wrt bug #408913 (diff)
downloadgentoo-2-8ce322a3e6fc06e25d8d7170100582495141745e.tar.gz
gentoo-2-8ce322a3e6fc06e25d8d7170100582495141745e.tar.bz2
gentoo-2-8ce322a3e6fc06e25d8d7170100582495141745e.zip
Migrated to bash-completion-r1 eclass. Fixed build failure against ghc-7.2. Removed old.
(Portage version: 2.2.0_alpha90_p19/cvs/Linux x86_64)
Diffstat (limited to 'dev-haskell/cabal-install/cabal-install-0.10.2-r2.ebuild')
-rw-r--r--dev-haskell/cabal-install/cabal-install-0.10.2-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-haskell/cabal-install/cabal-install-0.10.2-r2.ebuild b/dev-haskell/cabal-install/cabal-install-0.10.2-r2.ebuild
new file mode 100644
index 000000000000..8b0cdb85cde3
--- /dev/null
+++ b/dev-haskell/cabal-install/cabal-install-0.10.2-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/cabal-install/cabal-install-0.10.2-r2.ebuild,v 1.1 2012/03/20 08:26:21 slyfox Exp $
+
+# ebuild generated by hackport 0.2.13
+
+EAPI="3"
+
+CABAL_FEATURES="bin"
+inherit haskell-cabal bash-completion-r1 eutils
+
+DESCRIPTION="The command-line interface for Cabal and Hackage."
+HOMEPAGE="http://www.haskell.org/cabal/"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc64 ~sparc ~x86"
+IUSE="+noprefs"
+
+RDEPEND=">=dev-haskell/cabal-1.10.1
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/http-4000.0.2 <dev-haskell/http-4000.3
+ dev-haskell/network
+ >=dev-haskell/time-1.1
+ =dev-haskell/zlib-0.5*"
+
+src_prepare() {
+ if use noprefs; then
+ epatch "${FILESDIR}/${PN}"-0.8-nopref.patch
+ fi
+ epatch "${FILESDIR}/${PN}"-0.10-ghc-7.2.patch
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ newbashcomp "${S}/bash-completion/cabal" ${PN}
+}