summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2014-07-02 15:12:12 +0000
committerMark Wright <gienah@gentoo.org>2014-07-02 15:12:12 +0000
commit6d146e81c7352f89729fbe5f5fcb330c152a116e (patch)
treedbb6776c52a011f7120eb5b34fffa2176f8b2381 /dev-haskell/bio
parentAdd stmonadtrans (diff)
downloadgentoo-2-6d146e81c7352f89729fbe5f5fcb330c152a116e.tar.gz
gentoo-2-6d146e81c7352f89729fbe5f5fcb330c152a116e.tar.bz2
gentoo-2-6d146e81c7352f89729fbe5f5fcb330c152a116e.zip
Specify slot 2 for quickcheck 2 in bio
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 618E971F)
Diffstat (limited to 'dev-haskell/bio')
-rw-r--r--dev-haskell/bio/ChangeLog9
-rw-r--r--dev-haskell/bio/bio-0.5.3-r1.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-haskell/bio/ChangeLog b/dev-haskell/bio/ChangeLog
index 8a5d6f5e5ec9..bbb52b442141 100644
--- a/dev-haskell/bio/ChangeLog
+++ b/dev-haskell/bio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-haskell/bio
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bio/ChangeLog,v 1.1 2013/09/12 20:19:20 slyfox Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bio/ChangeLog,v 1.2 2014/07/02 15:12:12 gienah Exp $
+
+*bio-0.5.3-r1 (02 Jul 2014)
+
+ 02 Jul 2014; Mark Wright <gienah@gentoo.org> +bio-0.5.3-r1.ebuild:
+ Specify slot 2 for quickcheck 2 in bio
*bio-0.5.3 (12 Sep 2013)
diff --git a/dev-haskell/bio/bio-0.5.3-r1.ebuild b/dev-haskell/bio/bio-0.5.3-r1.ebuild
new file mode 100644
index 000000000000..d361e426a6b2
--- /dev/null
+++ b/dev-haskell/bio/bio-0.5.3-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/bio/bio-0.5.3-r1.ebuild,v 1.1 2014/07/02 15:12:12 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.2.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="A bioinformatics library"
+HOMEPAGE="http://biohaskell.org/Libraries/Bio"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+examples test"
+
+RDEPEND=">=dev-haskell/binary-0.4:=[profile?] <dev-haskell/binary-0.8:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/parallel:=[profile?]
+ dev-haskell/parsec:=[profile?]
+ >=dev-haskell/quickcheck-2:2=[profile?]
+ dev-haskell/random:=[profile?]
+ >=dev-haskell/tagsoup-0.8:=[profile?]
+ >=dev-lang/ghc-6.10.4:="
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_prepare() {
+ cabal_chdeps \
+ 'binary >=0.4 && <0.5' 'binary >=0.4 && <0.8'
+}
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag examples examples) \
+ $(cabal_flag test test)
+}
+
+src_test() {
+ dist/build/qc/qc || die
+}
+
+src_install() {
+ haskell-cabal_src_install
+
+ use test && rm "${ED}"/usr/bin/qc
+ # many examples collide with dev-haskell/flower
+ if use examples ; then
+ pushd "${ED}"/usr/bin
+ local example
+ for example in *
+ do
+ mv "${example}" "${PN}-example-${example}"
+ done
+ popd
+ fi
+}