summaryrefslogtreecommitdiff
path: root/dev-go
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2015-08-05 16:43:33 +0000
committerWilliam Hubbs <williamh@gentoo.org>2015-08-05 16:43:33 +0000
commit7579595be9790f6704c2ad6ea54dfaf8cf088c79 (patch)
tree17c79eb8fd3fc9b89f5aa82e9174bb52923f44db /dev-go
parentmedia-gfx/openmesh: bump 4.1 (diff)
downloadgentoo-2-7579595be9790f6704c2ad6ea54dfaf8cf088c79.tar.gz
gentoo-2-7579595be9790f6704c2ad6ea54dfaf8cf088c79.tar.bz2
gentoo-2-7579595be9790f6704c2ad6ea54dfaf8cf088c79.zip
add support for golang-vcs-snapshot to live ebuild
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0x30C46538)
Diffstat (limited to 'dev-go')
-rw-r--r--dev-go/go-eapache-queue/ChangeLog5
-rw-r--r--dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild37
2 files changed, 6 insertions, 36 deletions
diff --git a/dev-go/go-eapache-queue/ChangeLog b/dev-go/go-eapache-queue/ChangeLog
index 6f6393237dde..d9dad0f971da 100644
--- a/dev-go/go-eapache-queue/ChangeLog
+++ b/dev-go/go-eapache-queue/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-go/go-eapache-queue
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-eapache-queue/ChangeLog,v 1.1 2015/07/30 21:09:09 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-eapache-queue/ChangeLog,v 1.2 2015/08/05 16:43:33 williamh Exp $
+
+ 05 Aug 2015; William Hubbs <williamh@gentoo.org> go-eapache-queue-9999.ebuild:
+ add support for golang-vcs-snapshot to live ebuild
*go-eapache-queue-1.0.2 (30 Jul 2015)
*go-eapache-queue-9999 (30 Jul 2015)
diff --git a/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild b/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
index f2b7757cfb1b..de2d2de14456 100644
--- a/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
+++ b/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild,v 1.1 2015/07/30 21:09:09 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-go/go-eapache-queue/go-eapache-queue-9999.ebuild,v 1.2 2015/08/05 16:43:33 williamh Exp $
EAPI=5
@@ -12,6 +12,7 @@ if [[ ${PV} = *9999* ]]; then
else
KEYWORDS="~amd64"
SRC_URI="https://${EGO_SRC}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ inherit golang-vcs-snapshot
fi
inherit golang-build
@@ -22,37 +23,3 @@ SLOT="0/${PV}"
IUSE=""
DEPEND=""
RDEPEND=""
-
-if [[ ${PV} != *9999* ]]; then
-src_unpack() {
- local f
-
- for f in ${A}
- do
- case "${f}" in
- *.tar|*.tar.gz|*.tar.bz2|*.tar.xz)
- local destdir=${WORKDIR}/${P}/src/${EGO_SRC}
-
- debug-print "${FUNCNAME}: unpacking ${f} to ${destdir}"
-
- # XXX: check whether the directory structure inside is
- # fine? i.e. if the tarball has actually a parent dir.
- mkdir -p "${destdir}" || die
- tar -C "${destdir}" -x --strip-components 1 \
- -f "${DISTDIR}/${f}" || die
- ;;
- *)
- debug-print "${FUNCNAME}: falling back to unpack for ${f}"
-
- # fall back to the default method
- unpack "${f}"
- ;;
- esac
- done
-}
-fi
-
-src_install() {
- rm -rf src/${EGO_SRC}/.git* || die
- golang-build_src_install
-}