summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-07-24 07:52:03 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-07-24 07:52:03 +0000
commitfd0c9d4e81546462d80f45a0cb8e4cd4f86254f0 (patch)
tree24e749c3eb2a950090d231d5947b10ba1600dbd9 /dev-games
parentExim uses libiconv for header expansion, make this dependency explicit and do... (diff)
downloadgentoo-2-fd0c9d4e81546462d80f45a0cb8e4cd4f86254f0.tar.gz
gentoo-2-fd0c9d4e81546462d80f45a0cb8e4cd4f86254f0.tar.bz2
gentoo-2-fd0c9d4e81546462d80f45a0cb8e4cd4f86254f0.zip
Fix build with glibc-2.10 Bug #278103
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/cel/ChangeLog8
-rw-r--r--dev-games/cel/cel-1.2.1.ebuild14
-rw-r--r--dev-games/cel/files/cel-1.2.1-glibc210.patch11
3 files changed, 28 insertions, 5 deletions
diff --git a/dev-games/cel/ChangeLog b/dev-games/cel/ChangeLog
index a3525806a458..4e150b4f5ae0 100644
--- a/dev-games/cel/ChangeLog
+++ b/dev-games/cel/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/cel
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/ChangeLog,v 1.25 2008/09/04 18:01:23 nyhm Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/ChangeLog,v 1.26 2009/07/24 07:52:03 tupone Exp $
+
+ 24 Jul 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/cel-1.2.1-glibc210.patch, cel-1.2.1.ebuild:
+ Fix build with glibc-2.10 Bug #278103 by flameeyes@gentoo.org
*cel-1.2.1 (04 Sep 2008)
diff --git a/dev-games/cel/cel-1.2.1.ebuild b/dev-games/cel/cel-1.2.1.ebuild
index a2d703dee47e..dfe7325a3724 100644
--- a/dev-games/cel/cel-1.2.1.ebuild
+++ b/dev-games/cel/cel-1.2.1.ebuild
@@ -1,6 +1,7 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/cel-1.2.1.ebuild,v 1.1 2008/09/04 18:01:23 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/cel/cel-1.2.1.ebuild,v 1.2 2009/07/24 07:52:03 tupone Exp $
+EAPI=2
inherit eutils
@@ -21,12 +22,19 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
-src_compile() {
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-glibc210.patch
+}
+
+src_configure() {
econf \
--disable-separate-debug-info \
--disable-cstest \
$(use_with python) \
|| die
+}
+
+src_compile() {
jam -q || die "jam failed"
}
diff --git a/dev-games/cel/files/cel-1.2.1-glibc210.patch b/dev-games/cel/files/cel-1.2.1-glibc210.patch
new file mode 100644
index 000000000000..3624c3315af8
--- /dev/null
+++ b/dev-games/cel/files/cel-1.2.1-glibc210.patch
@@ -0,0 +1,11 @@
+--- plugins/behaviourlayer/python/blpython.cpp.old 2009-07-24 09:46:29.000000000 +0200
++++ plugins/behaviourlayer/python/blpython.cpp 2009-07-24 09:46:55.000000000 +0200
+@@ -166,7 +166,7 @@
+ PyObject *py_entity, *py_object;
+
+ csString realname;
+- char* slash = strrchr (name, '/');
++ const char* slash = strrchr (name, '/');
+ if (slash)
+ {
+ csString path;