summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2010-03-25 17:31:13 +0000
committerTristan Heaven <nyhm@gentoo.org>2010-03-25 17:31:13 +0000
commit365e89f14a590828a098cdec576fcc9b8e9acc91 (patch)
tree9adfdd27f186ffe0bbacf66f3a9d8949cc77e3b0 /dev-games
parentdbus: New upstream release, fixes a crasher with syslogging. Also move (diff)
downloadgentoo-2-365e89f14a590828a098cdec576fcc9b8e9acc91.tar.gz
gentoo-2-365e89f14a590828a098cdec576fcc9b8e9acc91.tar.bz2
gentoo-2-365e89f14a590828a098cdec576fcc9b8e9acc91.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-games')
-rw-r--r--dev-games/physfs/ChangeLog9
-rw-r--r--dev-games/physfs/physfs-2.0.1.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/dev-games/physfs/ChangeLog b/dev-games/physfs/ChangeLog
index 3f989236ab32..ca26d2475e48 100644
--- a/dev-games/physfs/ChangeLog
+++ b/dev-games/physfs/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-games/physfs
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/ChangeLog,v 1.30 2009/11/08 07:47:47 josejx Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/ChangeLog,v 1.31 2010/03/25 17:31:13 nyhm Exp $
+
+*physfs-2.0.1 (25 Mar 2010)
+
+ 25 Mar 2010; Tristan Heaven <nyhm@gentoo.org> +physfs-2.0.1.ebuild:
+ Version bump
08 Nov 2009; Joseph Jezak <josejx@gentoo.org> physfs-2.0.0.ebuild:
Marked ppc stable for bug #290054.
diff --git a/dev-games/physfs/physfs-2.0.1.ebuild b/dev-games/physfs/physfs-2.0.1.ebuild
new file mode 100644
index 000000000000..d1279fc16889
--- /dev/null
+++ b/dev-games/physfs/physfs-2.0.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/physfs/physfs-2.0.1.ebuild,v 1.1 2010/03/25 17:31:13 nyhm Exp $
+
+EAPI=2
+inherit cmake-utils
+
+DESCRIPTION="Abstraction layer for filesystem and archive access"
+HOMEPAGE="http://icculus.org/physfs/"
+SRC_URI="http://icculus.org/physfs/downloads/${P}.tar.gz"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc grp hog mvl qpak static-libs wad +zip"
+
+RDEPEND=""
+DEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ sed -i \
+ -e 's:-Werror::' \
+ -e '/DESTINATION/s:lib:lib${LIB_SUFFIX}:' \
+ CMakeLists.txt \
+ || die "sed failed"
+ # make sure these libs aren't used
+ rm -rf lzma zlib*
+}
+
+src_configure() {
+ local mycmakeargs="
+ -DPHYSFS_ARCHIVE_7Z=OFF
+ -DPHYSFS_BUILD_SHARED=ON
+ -DPHYSFS_BUILD_TEST=OFF
+ -DPHYSFS_BUILD_WX_TEST=OFF
+ -DPHYSFS_INTERNAL_ZLIB=OFF
+ $(cmake-utils_use static-libs PHYSFS_BUILD_STATIC)
+ $(cmake-utils_use grp PHYSFS_ARCHIVE_GRP)
+ $(cmake-utils_use hog PHYSFS_ARCHIVE_HOG)
+ $(cmake-utils_use mvl PHYSFS_ARCHIVE_MVL)
+ $(cmake-utils_use wad PHYSFS_ARCHIVE_WAD)
+ $(cmake-utils_use qpak PHYSFS_ARCHIVE_QPAK)
+ $(cmake-utils_use zip PHYSFS_ARCHIVE_ZIP)"
+
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use doc ; then
+ doxygen || die "doxygen failed"
+ fi
+}
+
+src_install() {
+ local DOCS="CHANGELOG.txt CREDITS.txt TODO.txt"
+ local HTML_DOCS=$(use doc && echo docs/html/*)
+
+ cmake-utils_src_install
+}