summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-10-31 20:37:20 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-10-31 20:37:20 +0000
commite584d2f6fb346edc99fddf84293e3e0a2afe8732 (patch)
tree30f0c7f913de02406278f9699c7925ffcf7d2743 /dev-games/mygui/files
parentwhitespace (diff)
downloadgentoo-2-e584d2f6fb346edc99fddf84293e3e0a2afe8732.tar.gz
gentoo-2-e584d2f6fb346edc99fddf84293e3e0a2afe8732.tar.bz2
gentoo-2-e584d2f6fb346edc99fddf84293e3e0a2afe8732.zip
initial import wrt #261895
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'dev-games/mygui/files')
-rw-r--r--dev-games/mygui/files/mygui-3.2.0-FHS.patch63
-rw-r--r--dev-games/mygui/files/mygui-3.2.0-build.patch72
-rw-r--r--dev-games/mygui/files/mygui-3.2.0-underlinking.patch20
3 files changed, 155 insertions, 0 deletions
diff --git a/dev-games/mygui/files/mygui-3.2.0-FHS.patch b/dev-games/mygui/files/mygui-3.2.0-FHS.patch
new file mode 100644
index 000000000000..7c0c88a2caa7
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.0-FHS.patch
@@ -0,0 +1,63 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Sat Oct 27 22:39:31 UTC 2012
+Subject: FHS
+
+paths hardcoded until upstream fixed the logic
+
+--- Common/Base/Ogre/BaseManager.cpp
++++ Common/Base/Ogre/BaseManager.cpp
+@@ -47,14 +47,14 @@
+ mWindow(nullptr),
+ mExit(false),
+ mPluginCfgName("plugins.cfg"),
+- mResourceXMLName("resources.xml"),
++ mResourceXMLName("/etc/MYGUI/resources.xml"),
+ mResourceFileName("MyGUI_Core.xml"),
+ mNode(nullptr)
+ {
+ #if MYGUI_PLATFORM == MYGUI_PLATFORM_APPLE
+ mResourcePath = macBundlePath() + "/Contents/Resources/";
+ #else
+- mResourcePath = "";
++ mResourcePath = "/etc/MYGUI/";
+ #endif
+ }
+
+@@ -65,12 +65,16 @@
+ bool BaseManager::create()
+ {
+ Ogre::String pluginsPath;
++ char *homedir;
++ homedir = getenv("HOME");
++ std::string homePath;
++ homePath = homedir;
+
+ #ifndef OGRE_STATIC_LIB
+ pluginsPath = mResourcePath + mPluginCfgName;
+ #endif
+
+- mRoot = new Ogre::Root(pluginsPath, mResourcePath + "ogre.cfg", mResourcePath + "Ogre.log");
++ mRoot = new Ogre::Root(pluginsPath, homePath + "/mygui-ogre.cfg", homePath + "/mygui-Ogre.log");
+
+ setupResources();
+
+--- CMake/InstallResources.cmake
++++ CMake/InstallResources.cmake
+@@ -24,7 +24,7 @@
+ else ()
+ install(FILES
+ ${MYGUI_BINARY_DIR}/bin/${FILENAME}
+- DESTINATION "bin"
++ DESTINATION "/etc/MYGUI"
+ )
+ endif ()
+ endfunction(install_file)
+@@ -51,7 +51,7 @@
+ if (WIN32)
+ set(MYGUI_MEDIA_DIR "../../Media")
+ elseif (UNIX)
+- set(MYGUI_MEDIA_DIR "../share/MYGUI/Media")
++ set(MYGUI_MEDIA_DIR "${CMAKE_INSTALL_PREFIX}/share/MYGUI/Media")
+ else ()
+ set(MYGUI_MEDIA_DIR "../../Media")
+ endif ()
diff --git a/dev-games/mygui/files/mygui-3.2.0-build.patch b/dev-games/mygui/files/mygui-3.2.0-build.patch
new file mode 100644
index 000000000000..f1f0f1cc94e3
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.0-build.patch
@@ -0,0 +1,72 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jun 15 21:58:45 UTC 2012
+
+use proper destinations and allow Gentoo build type
+rename demo targets to avoid confusion
+
+--- CMake/Utils/MyGUIConfigTargets.cmake
++++ CMake/Utils/MyGUIConfigTargets.cmake
+@@ -1,6 +1,8 @@
+ # Configure settings and install targets
+ # FIXME: Copypasted from Ogre and need lots of changes
+
++include(GNUInstallDirs)
++
+ if (WIN32)
+ set(MYGUI_RELEASE_PATH "/Release")
+ set(MYGUI_RELWDBG_PATH "/RelWithDebInfo")
+@@ -56,6 +58,12 @@
+ # install targets according to current build type
+ function(mygui_install_target TARGETNAME SUFFIX)
+ install(TARGETS ${TARGETNAME}
++ RUNTIME DESTINATION "${CMAKE_INSTALL_BINDIR}" CONFIGURATIONS Gentoo ""
++ LIBRARY DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
++ ARCHIVE DESTINATION "${CMAKE_INSTALL_LIBDIR}" CONFIGURATIONS Gentoo ""
++ FRAMEWORK DESTINATION "${MYGUI_FRAMEWORK_PATH}" CONFIGURATIONS Gentoo ""
++ )
++ install(TARGETS ${TARGETNAME}
+ RUNTIME DESTINATION "bin${MYGUI_RELEASE_PATH}" CONFIGURATIONS Release None ""
+ LIBRARY DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
+ ARCHIVE DESTINATION "lib${MYGUI_LIB_RELEASE_PATH}${SUFFIX}" CONFIGURATIONS Release None ""
+@@ -170,7 +178,13 @@
+ endif ()
+ add_executable(${PROJECTNAME} ${MYGUI_EXEC_TYPE} ${HEADER_FILES} ${SOURCE_FILES})
+ endif ()
+- set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
++
++ # rename demo target
++ if (${SOLUTIONFOLDER} STREQUAL "Demos")
++ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER} OUTPUT_NAME MYGUI-${PROJECTNAME})
++ else()
++ set_target_properties(${PROJECTNAME} PROPERTIES FOLDER ${SOLUTIONFOLDER})
++ endif()
+
+ add_dependencies(${PROJECTNAME} MyGUIEngine Common)
+
+@@ -326,4 +340,4 @@
+ INSTALL_RPATH ${CMAKE_INSTALL_PREFIX}/lib)
+ set_property(TARGET ${PROJECTNAME} PROPERTY INSTALL_RPATH_USE_LINK_PATH TRUE)
+ endif ()
+-endfunction(mygui_config_sample)
+\ No newline at end of file
++endfunction(mygui_config_sample)
+--- CMake/ConfigureBuild.cmake
++++ CMake/ConfigureBuild.cmake
+@@ -4,6 +4,8 @@
+ # also prepare package files for pkg-config and CMake.
+ #######################################################################
+
++include(GNUInstallDirs)
++
+ # should we build static libs?
+ if (MYGUI_STATIC)
+ set(MYGUI_LIB_TYPE STATIC)
+@@ -47,7 +49,7 @@
+ else ()
+ configure_file(${MYGUI_TEMPLATES_DIR}/MYGUI.pc.in ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc @ONLY)
+ endif ()
+- install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION lib/pkgconfig)
++ install(FILES ${MYGUI_BINARY_DIR}/pkgconfig/MYGUI${MYGUI_LIB_SUFFIX}.pc DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
+
+ # configure additional packages
+
diff --git a/dev-games/mygui/files/mygui-3.2.0-underlinking.patch b/dev-games/mygui/files/mygui-3.2.0-underlinking.patch
new file mode 100644
index 000000000000..2d1026856f03
--- /dev/null
+++ b/dev-games/mygui/files/mygui-3.2.0-underlinking.patch
@@ -0,0 +1,20 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Fri Jun 15 10:42:42 UTC 2012
+Subject: build system
+
+fix underlinking
+
+--- MyGUIEngine/CMakeLists.txt
++++ MyGUIEngine/CMakeLists.txt
+@@ -48,7 +48,10 @@
+ if (MYGUI_USE_FREETYPE)
+ target_link_libraries(${PROJECTNAME}
+ ${FREETYPE_LIBRARIES}
+- )
++ dl)
++else()
++ target_link_libraries(${PROJECTNAME}
++ dl)
+ endif()
+
+ # platform specific dependencies