summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-01 21:04:10 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-01 21:04:10 +0000
commitd915e36c27fde5b6a37ca4710edb79376c7a561b (patch)
treea934d03fde9e49daaa268ae766f52ea7e07098f0 /dev-games/irrlicht/files
parentReadd ~ia64 keyword wrt #180580 (diff)
downloadgentoo-2-d915e36c27fde5b6a37ca4710edb79376c7a561b.tar.gz
gentoo-2-d915e36c27fde5b6a37ca4710edb79376c7a561b.tar.bz2
gentoo-2-d915e36c27fde5b6a37ca4710edb79376c7a561b.zip
Version bump, bug #172776
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-games/irrlicht/files')
-rw-r--r--dev-games/irrlicht/files/digest-irrlicht-1.33
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.3-config.patch26
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.3-demoMake.patch20
-rw-r--r--dev-games/irrlicht/files/irrlicht-1.3-opengl.patch20
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-games/irrlicht/files/digest-irrlicht-1.3 b/dev-games/irrlicht/files/digest-irrlicht-1.3
new file mode 100644
index 000000000000..bd9184679084
--- /dev/null
+++ b/dev-games/irrlicht/files/digest-irrlicht-1.3
@@ -0,0 +1,3 @@
+MD5 87d25c36a2d93a34ab64b5fa783fb557 irrlicht-1.3.zip 16473254
+RMD160 947d9107d6dff012037ace9e12db78debfa08de4 irrlicht-1.3.zip 16473254
+SHA256 5370777c47c4311de21a8c71b2a302711364299b71f43d1e13d35ea2bc66cefe irrlicht-1.3.zip 16473254
diff --git a/dev-games/irrlicht/files/irrlicht-1.3-config.patch b/dev-games/irrlicht/files/irrlicht-1.3-config.patch
new file mode 100644
index 000000000000..e3aecc791e00
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.3-config.patch
@@ -0,0 +1,26 @@
+--- include/IrrCompileConfig.h
++++ include/IrrCompileConfig.h
+@@ -99,7 +99,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_ZLIB_ to let irrlicht use the zlib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the zlib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_ZLIB_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_ZLIB_
+
+
+ //! Define _IRR_COMPILE_WITH_JPEGLIB_ to enable compiling the engine using libjpeg.
+@@ -110,7 +109,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_JPEG_LIB_ to let irrlicht use the jpeglib which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the jpeg lib installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBJPEG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_JPEG_LIB_
+
+
+ //! Define _IRR_COMPILE_WITH_LIBPNG_ to enable compiling the engine using libpng.
+@@ -121,7 +119,6 @@
+ //! Define _IRR_USE_NON_SYSTEM_LIBPNG_ to let irrlicht use the libpng which comes with irrlicht.
+ /** If this is commented out, Irrlicht will try to compile using the libpng installed in the system.
+ This is only used when _IRR_COMPILE_WITH_LIBPNG_ is defined. */
+-#define _IRR_USE_NON_SYSTEM_LIB_PNG_
+
+
+ //! Define _IRR_D3D_NO_SHADER_DEBUGGING to disable shader debugging in D3D9
diff --git a/dev-games/irrlicht/files/irrlicht-1.3-demoMake.patch b/dev-games/irrlicht/files/irrlicht-1.3-demoMake.patch
new file mode 100644
index 000000000000..055a9b496a7e
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.3-demoMake.patch
@@ -0,0 +1,20 @@
+--- examples/Demo/Makefile
++++ examples/Demo/Makefile
+@@ -2,7 +2,7 @@
+ Target = Demo
+ Sources = CDemo.cpp CMainMenu.cpp main.cpp
+
+-CPPFLAGS = -I../../include -I/usr/X11R6/include
++CPPFLAGS = -I/usr/include/irrlicht
+ CXXFLAGS = -O3 -ffast-math
+
+ ifeq ($(HOSTTYPE), x86_64)
+@@ -13,7 +13,7 @@
+
+ # target specific settings
+ all_linux: SYSTEM=Linux
+-all_linux: LDFLAGS = -L/usr/X11R6/lib$(LIBSELECT) -L../../lib/$(SYSTEM) -lIrrlicht -lGL -lGLU -lXxf86vm -lXext -lX11
++all_linux: LDFLAGS = -lIrrlicht -lGL -lGLU -lXxf86vm -lXext -lX11 -lpng -ljpeg
+
+ all_win32 clean_win32: SYSTEM=Win32-gcc
+ all_win32: LDFLAGS = -L../../lib/$(SYSTEM) -lIrrlicht -lopengl32 -lglu32 -lm
diff --git a/dev-games/irrlicht/files/irrlicht-1.3-opengl.patch b/dev-games/irrlicht/files/irrlicht-1.3-opengl.patch
new file mode 100644
index 000000000000..f527f22cacd5
--- /dev/null
+++ b/dev-games/irrlicht/files/irrlicht-1.3-opengl.patch
@@ -0,0 +1,20 @@
+Fix compiling error:
+COpenGLDriver.cpp: In member function `void irr::video::COpenGLDriver::loadExtensions()':
+COpenGLDriver.cpp:357: error: `glXGetProcAddress' undeclared (first use this function)
+COpenGLDriver.cpp:357: error: (Each undeclared identifier is reported only once for each function it appears in.)
+make: *** [COpenGLDriver.o] Error 1
+
+Patch by Chris Statzer.
+
+http://bugs.gentoo.org/87015
+
+--- COpenGLDriver.cpp
++++ COpenGLDriver.cpp
+@@ -2,6 +2,7 @@
+
+ #include "IrrCompileConfig.h"
+ #ifdef _IRR_COMPILE_WITH_OPENGL_
++#define glXGetProcAddress glXGetProcAddressARB
+
+ #include "COpenGLTexture.h"
+ #include "COpenGLMaterialRenderer.h"