summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-08-04 21:24:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-08-04 21:24:39 +0000
commitfb0b78ee04c9f229663ad6749042e30c7e5380a1 (patch)
tree97d7fb703a5bd46694bbab6f07e355c8289b74f4 /dev-games/clanlib
parentVersion bump (diff)
downloadgentoo-2-fb0b78ee04c9f229663ad6749042e30c7e5380a1.tar.gz
gentoo-2-fb0b78ee04c9f229663ad6749042e30c7e5380a1.tar.bz2
gentoo-2-fb0b78ee04c9f229663ad6749042e30c7e5380a1.zip
EAPI=2; add gcc44 patch submitted by Fredric Johansson via bug #275791
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'dev-games/clanlib')
-rw-r--r--dev-games/clanlib/ChangeLog8
-rw-r--r--dev-games/clanlib/clanlib-0.8.1.ebuild18
-rw-r--r--dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch33
3 files changed, 47 insertions, 12 deletions
diff --git a/dev-games/clanlib/ChangeLog b/dev-games/clanlib/ChangeLog
index 28329eb178c7..15c0291bb30a 100644
--- a/dev-games/clanlib/ChangeLog
+++ b/dev-games/clanlib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-games/clanlib
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.44 2008/08/26 20:53:25 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/ChangeLog,v 1.45 2009/08/04 21:24:39 mr_bones_ Exp $
+
+ 04 Aug 2009; Michael Sterrett <mr_bones_@gentoo.org> clanlib-0.8.1.ebuild,
+ +files/clanlib-0.8.1-gcc44.patch:
+ EAPI=2; add gcc44 patch submitted by Fredric Johansson via bug #275791
26 Aug 2008; Tristan Heaven <nyhm@gentoo.org> clanlib-0.8.1.ebuild:
Add missing media-libs/alsa-lib dependency, bug #227509
diff --git a/dev-games/clanlib/clanlib-0.8.1.ebuild b/dev-games/clanlib/clanlib-0.8.1.ebuild
index 1aa60b1a66b0..989d2f45c104 100644
--- a/dev-games/clanlib/clanlib-0.8.1.ebuild
+++ b/dev-games/clanlib/clanlib-0.8.1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.1.ebuild,v 1.4 2008/08/26 20:53:25 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-games/clanlib/clanlib-0.8.1.ebuild,v 1.5 2009/08/04 21:24:39 mr_bones_ Exp $
+EAPI=2
inherit flag-o-matic eutils
DESCRIPTION="multi-platform game development library"
@@ -34,15 +35,14 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/ClanLib-${PV}
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
epatch \
"${FILESDIR}"/${P}-ndebug.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
}
-src_compile() {
+src_configure() {
#clanSound only controls mikmod/vorbis so there's
# no need to pass --{en,dis}able-clanSound ...
#clanDisplay only controls X, SDL, OpenGL plugins
@@ -58,9 +58,7 @@ src_compile() {
$(use_enable sdl clanSDL) \
$(use_enable vorbis clanVorbis) \
$(use_enable mikmod clanMikMod) \
- $(use_enable ipv6 getaddr) \
- || die
- emake || die "emake failed"
+ $(use_enable ipv6 getaddr)
}
src_install() {
diff --git a/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch b/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
new file mode 100644
index 000000000000..ddf5a170b027
--- /dev/null
+++ b/dev-games/clanlib/files/clanlib-0.8.1-gcc44.patch
@@ -0,0 +1,33 @@
+diff -Naur ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp
+--- ClanLib-0.8.1-old/Sources/GL/canvas_opengl.cpp 2009-08-01 18:15:44.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/canvas_opengl.cpp 2009-08-01 18:08:55.000000000 +0200
+@@ -48,6 +48,7 @@
+ #include "graphic_context_opengl.h"
+ #include "surface_target_opengl.h"
+ #include <cstring>
++#include <cstdio>
+
+ /////////////////////////////////////////////////////////////////////////////
+ // CL_Canvas_OpenGL construction:
+diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp
+--- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:17:25.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/GLX/input_device_linuxevent.cpp 2009-08-01 18:11:23.000000000 +0200
+@@ -35,6 +35,7 @@
+ #include <iostream>
+ #include <errno.h>
+ #include <cstring>
++#include <cstdio>
+
+ #include "API/Core/System/error.h"
+ #include "API/Core/System/clanstring.h"
+diff -Naur ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp
+--- ClanLib-0.8.1-old/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:17:41.000000000 +0200
++++ ClanLib-0.8.1/Sources/GL/GLX/input_device_xinput.cpp 2009-08-01 18:12:56.000000000 +0200
+@@ -29,6 +29,7 @@
+
+ #include <iostream>
+ #include <cstring>
++#include <cstdio>
+ #include "API/Core/System/log.h"
+ #include "API/Display/input_device.h"
+ #include "API/Display/input_event.h"