summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-03-14 23:00:56 +0000
committerTim Harder <radhermit@gentoo.org>2011-03-14 23:00:56 +0000
commit7cd1352c1b178013745085411030bb3f7c1f3d11 (patch)
treec078e480a0b8f46dc6db77f9d366d8713c2db7d0 /dev-embedded
parentRemove spurious old-style virtuals. (diff)
downloadgentoo-2-7cd1352c1b178013745085411030bb3f7c1f3d11.tar.gz
gentoo-2-7cd1352c1b178013745085411030bb3f7c1f3d11.tar.bz2
gentoo-2-7cd1352c1b178013745085411030bb3f7c1f3d11.zip
Version bump (bug #355669 by Jacob Galbreath) and remove old. Update to EAPI 4 and remove unnecessary compile setup and die usage.
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded')
-rw-r--r--dev-embedded/u-boot-tools/ChangeLog9
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2009.03.ebuild35
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2009.11.1.ebuild56
-rw-r--r--dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild38
4 files changed, 46 insertions, 92 deletions
diff --git a/dev-embedded/u-boot-tools/ChangeLog b/dev-embedded/u-boot-tools/ChangeLog
index 7de24e5d2258..bdaada6bfd1b 100644
--- a/dev-embedded/u-boot-tools/ChangeLog
+++ b/dev-embedded/u-boot-tools/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-embedded/u-boot-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/ChangeLog,v 1.16 2011/03/07 11:33:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/ChangeLog,v 1.17 2011/03/14 23:00:56 radhermit Exp $
+
+*u-boot-tools-2010.12 (14 Mar 2011)
+
+ 14 Mar 2011; Tim Harder <radhermit@gentoo.org> -u-boot-tools-2009.03.ebuild,
+ -u-boot-tools-2009.11.1.ebuild, +u-boot-tools-2010.12.ebuild:
+ Version bump (bug #355669 by Jacob Galbreath) and remove old. Update to EAPI
+ 4 and remove unnecessary compile setup and die usage.
07 Mar 2011; Raúl Porcel <armin76@gentoo.org> u-boot-tools-2010.06.ebuild:
x86stable wrt #355671
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2009.03.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2009.03.ebuild
deleted file mode 100644
index e7dfd1c2bdeb..000000000000
--- a/dev-embedded/u-boot-tools/u-boot-tools-2009.03.ebuild
+++ /dev/null
@@ -1,35 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/u-boot-tools-2009.03.ebuild,v 1.2 2009/05/07 17:28:06 armin76 Exp $
-
-MY_P="u-boot-${PV}"
-
-DESCRIPTION="utilities for working with Das U-Boot"
-HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
-SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 arm x86"
-IUSE=""
-
-DEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-src_compile() {
- touch include/config.{h,mk}
- emake HOSTSTRIP=echo BIN_FILES="bmp_logo gen_eth_addr img2srec mkimage" tools || die
- emake HOSTSTRIP=echo -C tools/easylogo || die
- emake env || die
-}
-
-src_install() {
- cd tools
- dobin bmp_logo gen_eth_addr img2srec mkimage || die
- dobin easylogo/easylogo || die
- dobin env/fw_printenv || die
- dosym fw_printenv /usr/bin/fw_setenv || die
- insinto /etc
- doins env/fw_env.config || die
-}
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2009.11.1.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2009.11.1.ebuild
deleted file mode 100644
index 48ac69578c2b..000000000000
--- a/dev-embedded/u-boot-tools/u-boot-tools-2009.11.1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/u-boot-tools-2009.11.1.ebuild,v 1.1 2010/06/05 13:58:54 armin76 Exp $
-
-inherit flag-o-matic
-
-MY_P="u-boot-${PV/_/-}"
-
-DESCRIPTION="utilities for working with Das U-Boot"
-HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
-SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE=""
-
-DEPEND=""
-
-S=${WORKDIR}/${MY_P}
-
-domake() {
- emake \
- HOSTSTRIP=echo \
- HOSTCC="$(tc-getCC)" CC="$(tc-getCC)" \
- HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}" \
- "$@"
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- touch include/config.{h,mk} include/autoconf.mk{.dep,}
- sed -i \
- -e 's:HOST_CFLAGS:HOSTCFLAGS:g' \
- Makefile *.mk tools/Makefile
- sed -i \
- -e '/CFLAGS/s:-O::' \
- tools/Makefile
-}
-
-src_compile() {
- domake SUBDIRS=tools BIN_FILES-y="bmp_logo gen_eth_addr img2srec mkimage" tools || die
- domake -C tools/easylogo || die
- domake env || die
-}
-
-src_install() {
- cd tools
- dobin bmp_logo gen_eth_addr img2srec mkimage || die
- dobin easylogo/easylogo || die
- dobin env/fw_printenv || die
- dosym fw_printenv /usr/bin/fw_setenv || die
- insinto /etc
- doins env/fw_env.config || die
-}
diff --git a/dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild b/dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild
new file mode 100644
index 000000000000..8b8ef83d2eb2
--- /dev/null
+++ b/dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/u-boot-tools/u-boot-tools-2010.12.ebuild,v 1.1 2011/03/14 23:00:56 radhermit Exp $
+
+EAPI=4
+
+inherit toolchain-funcs
+
+MY_P="u-boot-${PV/_/-}"
+DESCRIPTION="utilities for working with Das U-Boot"
+HOMEPAGE="http://www.denx.de/wiki/U-Boot/WebHome"
+SRC_URI="ftp://ftp.denx.de/pub/u-boot/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake \
+ HOSTSTRIP=echo \
+ HOSTCC="$(tc-getCC)" \
+ HOSTCFLAGS="${CFLAGS} ${CPPFLAGS}"' $(HOSTCPPFLAGS)' \
+ HOSTLDFLAGS="${LDFLAGS}" \
+ tools-all
+}
+
+src_install() {
+ cd tools
+ dobin bmp_logo gen_eth_addr img2srec mkimage
+ dobin easylogo/easylogo
+ dobin env/fw_printenv
+ dosym fw_printenv /usr/bin/fw_setenv
+ insinto /etc
+ doins env/fw_env.config
+}