summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDominik Kapusta <ayoy@gentoo.org>2009-10-15 20:41:21 +0000
committerDominik Kapusta <ayoy@gentoo.org>2009-10-15 20:41:21 +0000
commit9887cfb437e994e5673ad255209fcc4bb22f34b4 (patch)
tree237ec76318e35af0e56f0560c756768d31a82bb0 /dev-embedded/scratchbox
parentMasking experimental ebuild for scratchbox2 (diff)
downloadgentoo-2-9887cfb437e994e5673ad255209fcc4bb22f34b4.tar.gz
gentoo-2-9887cfb437e994e5673ad255209fcc4bb22f34b4.tar.bz2
gentoo-2-9887cfb437e994e5673ad255209fcc4bb22f34b4.zip
Adding scratchbox-2.0 for testing
(Portage version: 2.2_rc46/cvs/Linux x86_64)
Diffstat (limited to 'dev-embedded/scratchbox')
-rw-r--r--dev-embedded/scratchbox/ChangeLog9
-rw-r--r--dev-embedded/scratchbox/files/scratchbox-2.0-gentoo.patch57
-rw-r--r--dev-embedded/scratchbox/files/scratchbox-2.0-glibc-2.10.patch39
-rw-r--r--dev-embedded/scratchbox/scratchbox-2.0.ebuild39
4 files changed, 143 insertions, 1 deletions
diff --git a/dev-embedded/scratchbox/ChangeLog b/dev-embedded/scratchbox/ChangeLog
index 009ccd7d35af..b20f183553a8 100644
--- a/dev-embedded/scratchbox/ChangeLog
+++ b/dev-embedded/scratchbox/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-embedded/scratchbox
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/ChangeLog,v 1.5 2009/09/16 00:07:20 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/ChangeLog,v 1.6 2009/10/15 20:41:21 ayoy Exp $
+
+*scratchbox-2.0 (15 Oct 2009)
+
+ 15 Oct 2009; Dominik Kapusta <ayoy@gentoo.org> +scratchbox-2.0.ebuild,
+ +files/scratchbox-2.0-gentoo.patch,
+ +files/scratchbox-2.0-glibc-2.10.patch:
+ Adding scratchbox-2.0 for testing
*scratchbox-1.0.16 (16 Sep 2009)
diff --git a/dev-embedded/scratchbox/files/scratchbox-2.0-gentoo.patch b/dev-embedded/scratchbox/files/scratchbox-2.0-gentoo.patch
new file mode 100644
index 000000000000..e762c7dd5778
--- /dev/null
+++ b/dev-embedded/scratchbox/files/scratchbox-2.0-gentoo.patch
@@ -0,0 +1,57 @@
+diff --git a/Makefile b/Makefile
+index 23a13b3..c5b26cc 100644
+--- a/Makefile
++++ b/Makefile
+@@ -59,7 +59,6 @@ subdirs = luaif preload utils
+
+ -include config.mak
+
+-CFLAGS += -O2 -g -Wall -W
+ CFLAGS += -I$(OBJDIR)/include -I$(SRCDIR)/include
+ CFLAGS += -I$(SRCDIR)/luaif/lua-5.1.4/src
+ CFLAGS += -D_GNU_SOURCE=1 -D_LARGEFILE_SOURCE=1 -D_LARGEFILE64_SOURCE=1
+@@ -145,6 +144,9 @@ install-noarch: regular
+ else install -d -m 755 $(prefix)/share/man/man1 ; \
+ fi
+ $(Q)echo "$(PACKAGE_VERSION)" > $(prefix)/share/scratchbox2/version
++ $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-show $(prefix)/bin/sb2-show
++ $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-monitor $(prefix)/bin/sb2-monitor
++ $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-interp-wrapper $(prefix)/bin/sb2-interp-wrapper
+ $(Q)install -c -m 755 $(SRCDIR)/utils/sb2 $(prefix)/bin/sb2
+ $(Q)install -c -m 755 $(SRCDIR)/utils/sb2-init $(prefix)/bin/sb2-init
+ $(Q)install -c -m 755 $(SRCDIR)/utils/sb2-config $(prefix)/bin/sb2-config
+@@ -210,10 +212,10 @@ install-noarch: regular
+ ifeq ($(MACH),x86_64)
+ install: install-multilib
+ else
+-install: do-install
++install: install-singlelib
+ endif
+
+-do-install: install-noarch
++install-singlelib: install-noarch
+ $(P)INSTALL
+ @if [ -d $(prefix)/lib ] ; \
+ then echo "$(prefix)/lib present" ; \
+@@ -221,9 +223,6 @@ do-install: install-noarch
+ fi
+ $(Q)install -d -m 755 $(prefix)/lib/libsb2
+ $(Q)install -c -m 755 $(OBJDIR)/preload/libsb2.$(SHLIBEXT) $(prefix)/lib/libsb2/libsb2.so.$(PACKAGE_VERSION)
+- $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-show $(prefix)/bin/sb2-show
+- $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-monitor $(prefix)/bin/sb2-monitor
+- $(Q)install -c -m 755 $(OBJDIR)/utils/sb2-interp-wrapper $(prefix)/bin/sb2-interp-wrapper
+ ifeq ($(OS),Linux)
+ $(Q)/sbin/ldconfig -n $(prefix)/lib/libsb2
+ endif
+@@ -232,9 +231,9 @@ multilib_prefix=$(prefix)
+
+ install-multilib: multilib
+ @$(MAKE) -C obj-32 --include-dir=.. -f ../Makefile SRCDIR=.. do-install-multilib bitness=32
+- @$(MAKE) -C obj-64 --include-dir=.. -f ../Makefile SRCDIR=.. do-install
++ @$(MAKE) -C obj-64 --include-dir=.. -f ../Makefile SRCDIR=.. do-install-multilib bitness=64
+
+-do-install-multilib:
++do-install-multilib: install-noarch
+ $(P)INSTALL
+ @if [ -d $(multilib_prefix)/lib$(bitness) ] ; \
+ then echo "$(prefix)/lib$(bitness) present" ; \
diff --git a/dev-embedded/scratchbox/files/scratchbox-2.0-glibc-2.10.patch b/dev-embedded/scratchbox/files/scratchbox-2.0-glibc-2.10.patch
new file mode 100644
index 000000000000..c5ec6aea4341
--- /dev/null
+++ b/dev-embedded/scratchbox/files/scratchbox-2.0-glibc-2.10.patch
@@ -0,0 +1,39 @@
+diff --git a/preload/interface.master b/preload/interface.master
+index 55a9481..4ba22b2 100644
+--- a/preload/interface.master
++++ b/preload/interface.master
+@@ -406,20 +406,34 @@ WRAP: int rmdir(const char *pathname) : \
+
+ #ifdef HAVE_SCANDIR
+ #ifdef HAVE_LINUX_SCANDIR
++#if _POSIX_C_SOURCE == 200809L
++WRAP: int scandir(const char *dir, struct dirent ***namelist, \
++ SCANDIR_TYPE_ARG3, \
++ int(*compar)(const struct dirent **, const struct dirent **)) : \
++ map(dir) hardcode_param(3,filter)
++#else
+ WRAP: int scandir(const char *dir, struct dirent ***namelist, \
+ SCANDIR_TYPE_ARG3, int(*compar)(const void *, const void *)) : \
+ map(dir) hardcode_param(3,filter)
+ #endif
++#endif
+ #ifdef HAVE_OSX_SCANDIR
+ WRAP: int scandir(const char *dirname, struct dirent ***namelist, int (*select)(struct dirent *), int (*compar)(const void *, const void *)): map(dirname)
+ #endif
+ #endif
+ #ifdef HAVE_SCANDIR64
++#if _POSIX_C_SOURCE == 200809L
++WRAP: int scandir64(const char *dir, struct dirent64 ***namelist, \
++ int(*filter)(const struct dirent64 *), \
++ int(*compar)(const struct dirent64 **, const struct dirent64 **)) : \
++ map(dir)
++#else
+ WRAP: int scandir64(const char *dir, struct dirent64 ***namelist, \
+ int(*filter)(const struct dirent64 *), \
+ int(*compar)(const void *, const void *)) : \
+ map(dir)
+ #endif
++#endif
+ #ifdef HAVE_SETXATTR
+ #ifdef HAVE_LINUX_XATTRS
+ WRAP: int setxattr(const char *path, const char *name, const void *value, \
diff --git a/dev-embedded/scratchbox/scratchbox-2.0.ebuild b/dev-embedded/scratchbox/scratchbox-2.0.ebuild
new file mode 100644
index 000000000000..1333f10be3aa
--- /dev/null
+++ b/dev-embedded/scratchbox/scratchbox-2.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/scratchbox/scratchbox-2.0.ebuild,v 1.1 2009/10/15 20:41:21 ayoy Exp $
+
+EAPI="2"
+
+inherit autotools eutils
+
+MY_PN="${PN/cratch}2"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="A cross-compilation toolkit designed to make embedded Linux application development easier."
+HOMEPAGE="http://www.freedesktop.org/wiki/Software/sbox2"
+SRC_URI="http://cgit.freedesktop.org/${MY_PN}/snapshot/${MY_P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-glibc-2.10.patch"
+ epatch "${FILESDIR}/${P}-gentoo.patch"
+ eautoreconf
+}
+
+src_compile() {
+ emake prefix="${D}/usr" || die "emake failed"
+}
+
+src_install() {
+ emake INSTALL_ROOT="${D}" install || die "emake install failed"
+ dodoc AUTHORS README || die "dodoc failed"
+}