summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Dupeyron <calchan@gentoo.org>2008-06-03 08:35:02 +0000
committerDenis Dupeyron <calchan@gentoo.org>2008-06-03 08:35:02 +0000
commitd70b28cff15f183dca44bef2ec0071aa63777df7 (patch)
treeacb203cc9216767a723273fd76264633e8b444f9 /dev-embedded/gputils/gputils-0.13.6-r1.ebuild
parentkeyword ~sparc-fbsd (diff)
downloadgentoo-2-d70b28cff15f183dca44bef2ec0071aa63777df7.tar.gz
gentoo-2-d70b28cff15f183dca44bef2ec0071aa63777df7.tar.bz2
gentoo-2-d70b28cff15f183dca44bef2ec0071aa63777df7.zip
Fixed bad files when using CODE_PACK, thanks to David Barnett (bug #224719).
(Portage version: 2.1.5.3)
Diffstat (limited to 'dev-embedded/gputils/gputils-0.13.6-r1.ebuild')
-rw-r--r--dev-embedded/gputils/gputils-0.13.6-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-embedded/gputils/gputils-0.13.6-r1.ebuild b/dev-embedded/gputils/gputils-0.13.6-r1.ebuild
new file mode 100644
index 000000000000..064942d9089e
--- /dev/null
+++ b/dev-embedded/gputils/gputils-0.13.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-embedded/gputils/gputils-0.13.6-r1.ebuild,v 1.1 2008/06/03 08:35:02 calchan Exp $
+
+inherit eutils
+
+DESCRIPTION="Collection of tools including assembler, linker and librarian for PIC microcontrollers."
+HOMEPAGE="http://gputils.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-code_pack.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Installation failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO doc/gputils.ps
+ insinto /usr/share/doc/${PF}/
+ doins doc/gputils.pdf
+}