summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2011-03-12 12:51:55 +0000
committerChristoph Mende <angelos@gentoo.org>2011-03-12 12:51:55 +0000
commita6fbe4ea40ec4913da06366069c4806afaf5b2ba (patch)
treef710f9dc6a8d1eac9886cfeed04ceeb51d5d5a12 /dev-dotnet
parentVersion bump. (diff)
downloadgentoo-2-a6fbe4ea40ec4913da06366069c4806afaf5b2ba.tar.gz
gentoo-2-a6fbe4ea40ec4913da06366069c4806afaf5b2ba.tar.bz2
gentoo-2-a6fbe4ea40ec4913da06366069c4806afaf5b2ba.zip
Prevent gio-sharp.dll.mdb from being installed
(Portage version: 2.2.0_alpha26/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/gio-sharp/ChangeLog8
-rw-r--r--dev-dotnet/gio-sharp/files/gio-sharp-0.2-debug-libs.patch24
-rw-r--r--dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild45
3 files changed, 76 insertions, 1 deletions
diff --git a/dev-dotnet/gio-sharp/ChangeLog b/dev-dotnet/gio-sharp/ChangeLog
index 6664eefc2594..868dfc7f2f25 100644
--- a/dev-dotnet/gio-sharp/ChangeLog
+++ b/dev-dotnet/gio-sharp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/gio-sharp
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gio-sharp/ChangeLog,v 1.1 2011/02/27 19:11:26 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gio-sharp/ChangeLog,v 1.2 2011/03/12 12:51:55 angelos Exp $
+
+*gio-sharp-0.2-r1 (12 Mar 2011)
+
+ 12 Mar 2011; <angelos@gentoo.org> +gio-sharp-0.2-r1.ebuild,
+ +files/gio-sharp-0.2-debug-libs.patch:
+ Prevent gio-sharp.dll.mdb from being installed
*gio-sharp-0.2 (27 Feb 2011)
diff --git a/dev-dotnet/gio-sharp/files/gio-sharp-0.2-debug-libs.patch b/dev-dotnet/gio-sharp/files/gio-sharp-0.2-debug-libs.patch
new file mode 100644
index 000000000000..8601e148a0c6
--- /dev/null
+++ b/dev-dotnet/gio-sharp/files/gio-sharp-0.2-debug-libs.patch
@@ -0,0 +1,24 @@
+commit 99cdb9c4bad171b6f987a3969112dbcd986bd0bd
+Author: Iain Lane <laney@ubuntu.com>
+Date: Sat Sep 4 22:34:39 2010 +0100
+
+ Remove the .mdb file from Libraries in the .pc file
+
+ Debugging libraries need not be built. We should not assume they are
+ present.
+
+ Signed-off-by: Bertrand Lorentz <bertrand.lorentz@gmail.com>
+
+diff --git a/gio/gio-sharp-2.0.pc.in b/gio/gio-sharp-2.0.pc.in
+index 35b1696..e1099eb 100644
+--- a/gio/gio-sharp-2.0.pc.in
++++ b/gio/gio-sharp-2.0.pc.in
+@@ -3,7 +3,7 @@ exec_prefix=${prefix}
+ libdir=${exec_prefix}/lib
+ assemblies_dir=${libdir}/gio-sharp
+ gapidir=${prefix}/share/gapi-2.0
+-Libraries=${assemblies_dir}/gio-sharp.dll ${assemblies_dir}/gio-sharp.dll.mdb
++Libraries=${assemblies_dir}/gio-sharp.dll
+
+ Name: GIO#
+ Description: GIO# - GIO .NET Binding
diff --git a/dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild b/dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild
new file mode 100644
index 000000000000..03e8e195d4db
--- /dev/null
+++ b/dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gio-sharp/gio-sharp-0.2-r1.ebuild,v 1.1 2011/03/12 12:51:55 angelos Exp $
+
+EAPI=2
+inherit autotools eutils mono
+
+DESCRIPTION="GIO API C# binding"
+HOMEPAGE="http://github.com/mono/gio-sharp"
+SRC_URI="http://github.com/mono/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-dotnet/glib-sharp-2.12
+ >=dev-dotnet/gtk-sharp-gapi-2.12
+ >=dev-libs/glib-2.22:2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${PN}-* "${S}"
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-debug-libs.patch
+ sed -i -e '/autoreconf/d' autogen-generic.sh || die
+ NOCONFIGURE=1 ./autogen-2.22.sh || die
+
+ eautoreconf
+}
+
+src_compile() {
+ emake -j1 || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+
+ mono_multilib_comply
+}