summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-11-07 16:05:48 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-11-07 16:05:48 +0000
commit71ad2b09bf7bb6548e191f9c1d4536b75a8799cb (patch)
tree1a96798bc3ad4331b065783180c345371edcd5bb /dev-dotnet
parentAdding x11-themes/qtcurve to kde3 mask (diff)
downloadgentoo-2-71ad2b09bf7bb6548e191f9c1d4536b75a8799cb.tar.gz
gentoo-2-71ad2b09bf7bb6548e191f9c1d4536b75a8799cb.tar.bz2
gentoo-2-71ad2b09bf7bb6548e191f9c1d4536b75a8799cb.zip
Fix bug #285760 (remove built_with_use usage, by bumping dbus dep), fix bug #292252 (fetch libgalago-0.5.0 within the ebuild and move it in the right place).
(Portage version: 2.2_rc49/cvs/Linux x86_64)
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/galago-sharp/ChangeLog10
-rw-r--r--dev-dotnet/galago-sharp/galago-sharp-0.5.0-r1.ebuild49
2 files changed, 58 insertions, 1 deletions
diff --git a/dev-dotnet/galago-sharp/ChangeLog b/dev-dotnet/galago-sharp/ChangeLog
index 27dbcf9283eb..f510c1b08e9a 100644
--- a/dev-dotnet/galago-sharp/ChangeLog
+++ b/dev-dotnet/galago-sharp/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-dotnet/galago-sharp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/galago-sharp/ChangeLog,v 1.17 2009/03/20 03:37:47 jmbsvicetto Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/galago-sharp/ChangeLog,v 1.18 2009/11/07 16:05:48 flameeyes Exp $
+
+*galago-sharp-0.5.0-r1 (07 Nov 2009)
+
+ 07 Nov 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ +galago-sharp-0.5.0-r1.ebuild:
+ Fix bug #285760 (remove built_with_use usage, by bumping dbus dep), fix
+ bug #292252 (fetch libgalago-0.5.0 within the ebuild and move it in the
+ right place).
20 Mar 2009; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
metadata.xml, galago-sharp-0.5.0.ebuild:
diff --git a/dev-dotnet/galago-sharp/galago-sharp-0.5.0-r1.ebuild b/dev-dotnet/galago-sharp/galago-sharp-0.5.0-r1.ebuild
new file mode 100644
index 000000000000..537793481459
--- /dev/null
+++ b/dev-dotnet/galago-sharp/galago-sharp-0.5.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/galago-sharp/galago-sharp-0.5.0-r1.ebuild,v 1.1 2009/11/07 16:05:48 flameeyes Exp $
+
+inherit eutils mono autotools
+
+DESCRIPTION="Mono bindings to Galago"
+HOMEPAGE="http://galago-project.org"
+SRC_URI="http://galago-project.org/files/releases/source/${PN}/${P}.tar.gz
+ http://galago-project.org/files/releases/source/libgalago/libgalago-${PV}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/mono-1.0
+ >=sys-apps/dbus-0.90
+ =dev-dotnet/gtk-sharp-2*
+ >=dev-libs/libgalago-0.5.0"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Hard enable/disable tests
+ epatch "${FILESDIR}/${PN}-0.5.0-tests.patch"
+
+ # Nasty hack to prevent building of the tests
+ sed -i -e 's/ tests//' "${S}/Makefile.am"
+
+ sed -i -e 's:\$(GET_METHOD)::' "${S}"/sources/Makefile.am || die
+
+ mv "${WORKDIR}"/libgalago-${PV} "${S}"/sources/libgalago
+
+ eautoreconf
+}
+
+src_compile() {
+ econf --disable-tests || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS ChangeLog NEWS README
+}