summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Johanson <latexer@gentoo.org>2005-05-06 16:26:30 +0000
committerPeter Johanson <latexer@gentoo.org>2005-05-06 16:26:30 +0000
commit2cd92c7024ec8bea7ecbdf9eead7783593475d0d (patch)
treeccb8b31a5c21f196f17d2674b35181aa8f743b0a /dev-dotnet/gtk-sharp
parentStable on alpha + ia64, bug 90539. Cleaned out old ebuild + patches. (diff)
downloadgentoo-2-2cd92c7024ec8bea7ecbdf9eead7783593475d0d.tar.gz
gentoo-2-2cd92c7024ec8bea7ecbdf9eead7783593475d0d.tar.bz2
gentoo-2-2cd92c7024ec8bea7ecbdf9eead7783593475d0d.zip
Add a revision bump that provides the option to install the monodoc documentation.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'dev-dotnet/gtk-sharp')
-rw-r--r--dev-dotnet/gtk-sharp/ChangeLog9
-rw-r--r--dev-dotnet/gtk-sharp/Manifest2
-rw-r--r--dev-dotnet/gtk-sharp/files/digest-gtk-sharp-1.9.3-r12
-rw-r--r--dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild84
4 files changed, 96 insertions, 1 deletions
diff --git a/dev-dotnet/gtk-sharp/ChangeLog b/dev-dotnet/gtk-sharp/ChangeLog
index 561c251dcfe2..f42bc8b0dac4 100644
--- a/dev-dotnet/gtk-sharp/ChangeLog
+++ b/dev-dotnet/gtk-sharp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-dotnet/gtk-sharp
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/ChangeLog,v 1.25 2005/05/05 02:15:26 latexer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/ChangeLog,v 1.26 2005/05/06 16:26:30 latexer Exp $
+
+*gtk-sharp-1.9.3-r1 (06 May 2005)
+
+ 06 May 2005; Peter Johanson <latexer@gentoo.org>
+ +gtk-sharp-1.9.3-r1.ebuild:
+ Add a revision bump that provides the option to install the monodoc
+ documentation.
*gtk-sharp-1.9.3 (05 May 2005)
diff --git a/dev-dotnet/gtk-sharp/Manifest b/dev-dotnet/gtk-sharp/Manifest
index 8dafbd9a2fec..298f8bee512e 100644
--- a/dev-dotnet/gtk-sharp/Manifest
+++ b/dev-dotnet/gtk-sharp/Manifest
@@ -5,8 +5,10 @@ MD5 c8dfb7de74c457dbc73e8fdc433586ee gtk-sharp-1.0.8.ebuild 1385
MD5 d491c00e9dbad08a6eaa104fde72baae ChangeLog 8917
MD5 e06909c47712ae995f4879eefb22e38b metadata.xml 160
MD5 c1d0f71cc8ab4f08784bdedc8bf1b896 gtk-sharp-1.9.3.ebuild 1383
+MD5 b926aaf09f0a5ae74119acd46d336b58 gtk-sharp-1.9.3-r1.ebuild 2013
MD5 b63c29f6761c048a9d7943713c15c78c files/digest-gtk-sharp-1.0.4-r1 147
MD5 ff5a2a47c3e1d785fc179c922857e409 files/digest-gtk-sharp-1.0.6 147
MD5 3af46f2e9fbd6a7f642bc1ef502d50ca files/digest-gtk-sharp-1.0.8 147
MD5 d1dddb54802e684259aedfd27a11af15 files/digest-gtk-sharp-1.9.2 147
MD5 284fbaa2e02c9f1dca27440457411e0b files/digest-gtk-sharp-1.9.3 147
+MD5 284fbaa2e02c9f1dca27440457411e0b files/digest-gtk-sharp-1.9.3-r1 147
diff --git a/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-1.9.3-r1 b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-1.9.3-r1
new file mode 100644
index 000000000000..d3aaed887246
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/files/digest-gtk-sharp-1.9.3-r1
@@ -0,0 +1,2 @@
+MD5 c7654c4947a554d7fd588f035c7ef92a gtk-sharp-1.9.3.tar.gz 2186372
+MD5 2f54720cea7a0f0f517c95ea9df0b8d1 gtk-sharp-1.9.3-configurable.diff.gz 1480
diff --git a/dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild b/dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild
new file mode 100644
index 000000000000..3e4779e60e07
--- /dev/null
+++ b/dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gtk-sharp/gtk-sharp-1.9.3-r1.ebuild,v 1.1 2005/05/06 16:26:30 latexer Exp $
+
+inherit eutils mono
+
+DESCRIPTION="Gtk# is a C# language binding for the GTK2 toolkit and GNOME libraries"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ mirror://gentoo/${P}-configurable.diff.gz"
+HOMEPAGE="http://gtk-sharp.sourceforge.net/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+IUSE="doc"
+
+RDEPEND=">=sys-apps/sed-4.0
+ >=dev-lang/mono-1.1.2
+ >=x11-libs/gtk+-2.4
+ >=gnome-base/orbit-2.8.3"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+KEYWORDS="~x86 ~ppc ~ppc"
+
+src_unpack() {
+ unpack ${A}
+
+ # disable building of samples (#16015)
+ cd ${S}
+ epatch ${WORKDIR}/${P}-configurable.diff
+ export WANT_AUTOMAKE="1.8"
+ aclocal || die
+ automake || die
+ autoconf || die
+ libtoolize --copy --force
+
+ sed -i -e "s:sample::" Makefile.in
+}
+
+src_compile() {
+
+ local myconf=""
+ # These are the same as from gtk-sharp-component.eclass
+ for package in art gda glade gnome gnomedb gnomevfs gtkhtml rsvg vte
+ do
+ myconf="${myconf} --disable-${package}"
+ done
+
+ econf ${myconf} || die "./configure failed"
+ LANG=C emake -j1 || die
+
+ if use doc && has_version dev-util/monodoc
+ then
+ cd ${S}/doc
+ emake assemble || die "Failed to generate docs"
+ fi
+}
+
+src_install () {
+ make GACUTIL_FLAGS="/root ${D}/usr/lib /gacdir /usr/lib /package ${PN}-2.0" \
+ DESTDIR=${D} install || die
+
+ dodoc README* ChangeLog
+
+ if use doc && has_version dev-util/monodoc
+ then
+ cd ${S}/doc
+ insinto $(monodoc --get-sourcesdir)
+ doins gtk-sharp-docs.{tree,zip}
+ fi
+}
+
+pkg_postinst() {
+ if use doc && ! has_version dev-util/monodoc
+ then
+ ewarn
+ ewarn "Although 'doc' is in the USE flag list, gtk-sharp will"
+ ewarn "not install its monodoc documentation unless you have monodoc"
+ ewarn "installed. If you want the documentation to be available in"
+ ewarn "monodoc, please emerge monodoc then re-emerge gtk-sharp."
+ ewarn
+ fi
+}