summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2007-04-28 22:04:20 +0000
committerTorsten Veller <tove@gentoo.org>2007-04-28 22:04:20 +0000
commitb52c1a29be6949d3df5844273dd14581200b74a0 (patch)
tree0bcab57d13085e38a42725df85a569c5c3649a4b /dev-db
parentIntroduced device-mapper local USE flag. (diff)
downloadgentoo-2-b52c1a29be6949d3df5844273dd14581200b74a0.tar.gz
gentoo-2-b52c1a29be6949d3df5844273dd14581200b74a0.tar.bz2
gentoo-2-b52c1a29be6949d3df5844273dd14581200b74a0.zip
Fix *initd, *confd and *envd calls (#173884, #174266)
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/postgresql/ChangeLog6
-rw-r--r--dev-db/postgresql/postgresql-7.3.15-r1.ebuild11
-rw-r--r--dev-db/postgresql/postgresql-7.4.13.ebuild14
-rw-r--r--dev-db/postgresql/postgresql-8.0.8.ebuild14
4 files changed, 21 insertions, 24 deletions
diff --git a/dev-db/postgresql/ChangeLog b/dev-db/postgresql/ChangeLog
index 6dd36f5222b2..c2af7782749c 100644
--- a/dev-db/postgresql/ChangeLog
+++ b/dev-db/postgresql/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/postgresql
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.330 2007/03/04 11:14:50 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/ChangeLog,v 1.331 2007/04/28 22:04:20 tove Exp $
+
+ 28 Apr 2007; Torsten Veller <tove@gentoo.org> postgresql-7.3.15-r1.ebuild,
+ postgresql-7.4.13.ebuild, postgresql-8.0.8.ebuild:
+ Fix *initd, *confd and *envd calls (#173884, #174266)
04 Mar 2007; Simon Stelling <blubb@gentoo.org> postgresql-7.4.16.ebuild,
postgresql-8.0.12.ebuild:
diff --git a/dev-db/postgresql/postgresql-7.3.15-r1.ebuild b/dev-db/postgresql/postgresql-7.3.15-r1.ebuild
index 25c0e5cf2aea..3cb3c86367e2 100644
--- a/dev-db/postgresql/postgresql-7.3.15-r1.ebuild
+++ b/dev-db/postgresql/postgresql-7.3.15-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.15-r1.ebuild,v 1.12 2006/11/09 18:35:25 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.3.15-r1.ebuild,v 1.13 2007/04/28 22:04:20 tove Exp $
inherit eutils gnuconfig flag-o-matic java-pkg multilib
@@ -172,11 +172,8 @@ src_install() {
fi
cd ${S}
- exeinto /etc/init.d/
- newexe "${FILESDIR}/postgresql.init-${PV%.*}" postgresql || die
-
- insinto /etc/conf.d/
- newins "${FILESDIR}/postgresql.conf-${PV%.*}" postgresql || die
+ newinitd "${FILESDIR}/postgresql.init-${PV%.*}" postgresql || die
+ newconfd "${FILESDIR}/postgresql.conf-${PV%.*}" postgresql || die
keepdir /var/lib/postgresql
}
diff --git a/dev-db/postgresql/postgresql-7.4.13.ebuild b/dev-db/postgresql/postgresql-7.4.13.ebuild
index 2d670da7e254..4ceb6cab589d 100644
--- a/dev-db/postgresql/postgresql-7.4.13.ebuild
+++ b/dev-db/postgresql/postgresql-7.4.13.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.13.ebuild,v 1.13 2006/11/09 18:35:25 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-7.4.13.ebuild,v 1.14 2007/04/28 22:04:20 tove Exp $
inherit eutils gnuconfig flag-o-matic java-pkg multilib toolchain-funcs
@@ -201,14 +201,12 @@ src_install() {
fi
cd ${S}
- exeinto /etc/init.d/
- newexe "${FILESDIR}/postgresql.init-${PV%.*}" postgresql || die
- newexe "${FILESDIR}/pg_autovacuum.init-${PV%.*}" pg_autovacuum || die
+ newinitd "${FILESDIR}/postgresql.init-${PV%.*}" postgresql || die
+ newinitd "${FILESDIR}/pg_autovacuum.init-${PV%.*}" pg_autovacuum || die
dosed "s:___DOCDIR___:/usr/share/doc/${PF}:" /etc/init.d/pg_autovacuum
- insinto /etc/conf.d/
- newins "${FILESDIR}/postgresql.conf-${PV%.*}" postgresql || die
- newins "${FILESDIR}/pg_autovacuum.conf-${PV%.*}" pg_autovacuum || die
+ newconfd "${FILESDIR}/postgresql.conf-${PV%.*}" postgresql || die
+ newconfd "${FILESDIR}/pg_autovacuum.conf-${PV%.*}" pg_autovacuum || die
}
pkg_postinst() {
diff --git a/dev-db/postgresql/postgresql-8.0.8.ebuild b/dev-db/postgresql/postgresql-8.0.8.ebuild
index 6c58ae6029f8..f3bd51c43792 100644
--- a/dev-db/postgresql/postgresql-8.0.8.ebuild
+++ b/dev-db/postgresql/postgresql-8.0.8.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.8.ebuild,v 1.13 2006/11/09 18:35:25 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql/postgresql-8.0.8.ebuild,v 1.14 2007/04/28 22:04:20 tove Exp $
inherit eutils gnuconfig flag-o-matic multilib toolchain-funcs
@@ -156,14 +156,12 @@ src_install() {
fi
cd ${S}
- exeinto /etc/init.d/
- newexe "${FILESDIR}/postgresql.init-${PV%.*}" postgresql || die
- newexe "${FILESDIR}/pg_autovacuum.init-${PV%.*}" pg_autovacuum || die
+ newinitd "${FILESDIR}/postgresql.init-${PV%.*}" postgresql || die
+ newinitd "${FILESDIR}/pg_autovacuum.init-${PV%.*}" pg_autovacuum || die
dosed "s:___DOCDIR___:/usr/share/doc/${PF}:" /etc/init.d/pg_autovacuum
- insinto /etc/conf.d/
- newins "${FILESDIR}/postgresql.conf-${PV%.*}" postgresql || die
- newins "${FILESDIR}/pg_autovacuum.conf-${PV%.*}" pg_autovacuum || die
+ newconfd "${FILESDIR}/postgresql.conf-${PV%.*}" postgresql || die
+ newconfd "${FILESDIR}/pg_autovacuum.conf-${PV%.*}" pg_autovacuum || die
rm ${D}/usr/include/postgres_ext.h
}