summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-08 11:30:35 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-08 11:30:35 +0000
commitb51e14c340d38420e436a50060d8483b141362ac (patch)
treeee42745d8c8bdc9b6d0909e6ec166853907c16a0 /dev-db
parentDelete older ebuilds. (diff)
downloadgentoo-2-b51e14c340d38420e436a50060d8483b141362ac.tar.gz
gentoo-2-b51e14c340d38420e436a50060d8483b141362ac.tar.bz2
gentoo-2-b51e14c340d38420e436a50060d8483b141362ac.zip
Version bump.
(Portage version: 14964-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog8
-rw-r--r--dev-db/sqlite/sqlite-3.6.21.ebuild116
2 files changed, 123 insertions, 1 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index 12fadae1e8aa..9f6424949864 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/sqlite
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.296 2009/11/29 14:08:02 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.297 2009/12/08 11:30:35 arfrever Exp $
+
+*sqlite-3.6.21 (08 Dec 2009)
+
+ 08 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +sqlite-3.6.21.ebuild:
+ Version bump.
29 Nov 2009; Raúl Porcel <armin76@gentoo.org> sqlite-3.6.19.ebuild:
alpha/ia64/s390/sh/sparc stable wrt #291913
diff --git a/dev-db/sqlite/sqlite-3.6.21.ebuild b/dev-db/sqlite/sqlite-3.6.21.ebuild
new file mode 100644
index 000000000000..f20304fc0ad6
--- /dev/null
+++ b/dev-db/sqlite/sqlite-3.6.21.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.6.21.ebuild,v 1.1 2009/12/08 11:30:35 arfrever Exp $
+
+EAPI="2"
+
+inherit eutils flag-o-matic multilib versionator
+
+DESCRIPTION="an SQL Database Engine in a C Library"
+HOMEPAGE="http://www.sqlite.org/"
+DOC_BASE="$(get_version_component_range 1-3)"
+DOC_PV="$(replace_all_version_separators _ ${DOC_BASE})"
+SRC_URI="http://www.sqlite.org/${P}.tar.gz
+ doc? ( http://www.sqlite.org/${PN}_docs_${DOC_PV}.zip )
+ !tcl? ( mirror://gentoo/sqlite3.h-${PV}.bz2 )"
+
+LICENSE="as-is"
+SLOT="3"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="debug doc fts3 icu +readline soundex tcl +threadsafe"
+RESTRICT="!tcl? ( test )"
+
+RDEPEND="icu? ( dev-libs/icu )
+ readline? ( sys-libs/readline )
+ tcl? ( dev-lang/tcl )"
+DEPEND="${RDEPEND}
+ doc? ( app-arch/unzip )"
+
+pkg_setup() {
+ if ! use tcl; then
+ ewarn "Installation of SQLite with \"tcl\" USE flag enabled provides more (TCL-unrelated) functionality."
+
+ if use icu; then
+ ewarn "Support for ICU is enabled only when \"tcl\" USE flag is enabled."
+ fi
+
+ ebeep 1
+ fi
+}
+
+src_prepare() {
+ if use icu; then
+ rm -f test/like.test
+ fi
+
+ # Needed to compile without tcl installed but fails to compile when it is installed, bug #293405
+ use fts3 && ! has_version dev-lang/tcl && epatch "${FILESDIR}/sqlite-3.6.20-fts3.patch"
+
+ epunt_cxx
+}
+
+src_configure() {
+ # Support column metadata, bug #266651
+ append-cppflags -DSQLITE_ENABLE_COLUMN_METADATA
+
+ # Support R-trees, bug #257646
+ # Avoid "./.libs/libsqlite3.so: undefined reference to `sqlite3RtreeInit'" during non-amalgamation building.
+ if use tcl; then
+ append-cppflags -DSQLITE_ENABLE_RTREE
+ fi
+
+ if use icu && use tcl; then
+ append-cppflags -DSQLITE_ENABLE_ICU
+ sed -e "s/TLIBS = @LIBS@/& -licui18n -licuuc/" -i Makefile.in || die "sed failed"
+ fi
+
+ # Support soundex, bug #143794
+ use soundex && append-cppflags -DSQLITE_SOUNDEX
+
+ # http://bugs.gentoo.org/show_bug.cgi?id=207701
+ use fts3 && append-cppflags -DSQLITE_ENABLE_FTS3=1
+
+ econf \
+ $(use_enable debug) \
+ $(use_enable readline) \
+ $(use_enable threadsafe) \
+ $(use_enable threadsafe cross-thread-connections) \
+ $(use_enable tcl)
+}
+
+src_compile() {
+ use tcl || cp "${WORKDIR}/sqlite3.h-${PV}" sqlite3.h
+ emake TCLLIBDIR="/usr/$(get_libdir)/${P}" || die "emake failed"
+}
+
+src_test() {
+ if [[ "${EUID}" -ne "0" ]]; then
+ local test="test"
+ use debug && test="fulltest"
+ emake ${test} || die "Some test(s) failed"
+ else
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
+ fi
+
+ if ! use tcl; then
+ ewarn "You must enable the tcl USE flag if you want to run the testsuite."
+ eerror "Testsuite will not be run."
+ fi
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ TCLLIBDIR="/usr/$(get_libdir)/${P}" \
+ install \
+ || die "emake install failed"
+
+ doman sqlite3.1 || die "doman sqlite3.1 failed"
+
+ if use doc; then
+ # Naming scheme changes randomly between - and _ in releases
+ # http://www.sqlite.org/cvstrac/tktview?tn=3523
+ dohtml -r "${WORKDIR}"/${PN}-${DOC_PV}-docs/* || die "dohtml failed"
+ fi
+}