summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-05-23 01:14:54 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-05-23 01:14:54 +0000
commit83128c0de8b72c5020d10d278f40dffe9f26e15f (patch)
treeffe347c452fa5951a8ac0cdff7c4b52fc324f2f7 /dev-db
parentVersion bump. (diff)
downloadgentoo-2-83128c0de8b72c5020d10d278f40dffe9f26e15f.tar.gz
gentoo-2-83128c0de8b72c5020d10d278f40dffe9f26e15f.tar.bz2
gentoo-2-83128c0de8b72c5020d10d278f40dffe9f26e15f.zip
Fixing FEATURES=test to be properly RESTRICTed as per ferringb's fixes
(Portage version: 2.1.2.7)
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/sqlite/ChangeLog6
-rw-r--r--dev-db/sqlite/sqlite-2.8.16-r4.ebuild18
-rw-r--r--dev-db/sqlite/sqlite-3.3.12.ebuild18
-rw-r--r--dev-db/sqlite/sqlite-3.3.17.ebuild18
-rw-r--r--dev-db/sqlite/sqlite-3.3.5-r1.ebuild18
5 files changed, 29 insertions, 49 deletions
diff --git a/dev-db/sqlite/ChangeLog b/dev-db/sqlite/ChangeLog
index c5acaa2ebe59..0874fe1c01b8 100644
--- a/dev-db/sqlite/ChangeLog
+++ b/dev-db/sqlite/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-db/sqlite
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.144 2007/05/08 20:25:59 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/ChangeLog,v 1.145 2007/05/23 01:14:54 cardoe Exp $
+
+ 23 May 2007; Doug Goldstein <cardoe@gentoo.org> sqlite-2.8.16-r4.ebuild,
+ sqlite-3.3.5-r1.ebuild, sqlite-3.3.12.ebuild, sqlite-3.3.17.ebuild:
+ Fixing FEATURES=test to be properly RESTRICTed as per ferringb's fixes
08 May 2007; Roy Marples <uberlord@gentoo.org> sqlite-2.8.16-r4.ebuild:
Added ~sparc-fbsd keyword.
diff --git a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
index 44834833fad5..a000f0a60b65 100644
--- a/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
+++ b/dev-db/sqlite/sqlite-2.8.16-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.17 2007/05/08 20:25:59 uberlord Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-2.8.16-r4.ebuild,v 1.18 2007/05/23 01:14:54 cardoe Exp $
inherit eutils alternatives toolchain-funcs
@@ -21,19 +21,13 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+RESTRICT="tcl? ( test )"
+
src_unpack() {
# test
- if has test ${FEATURES} ; then
- if ! has userpriv ${FEATURES} ; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl ; then
- eerror "The tcl USE flag must be enabled to run tests."
- ewarn "Please note that turning on tcl installs runtime"
- ewarn "support too."
- eerror "Testsuite will not be run."
- fi
+ if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
fi
unpack ${A}
diff --git a/dev-db/sqlite/sqlite-3.3.12.ebuild b/dev-db/sqlite/sqlite-3.3.12.ebuild
index f58cb49780ed..587e69554dd4 100644
--- a/dev-db/sqlite/sqlite-3.3.12.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.10 2007/05/06 19:54:44 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.12.ebuild,v 1.11 2007/05/23 01:14:54 cardoe Exp $
inherit eutils alternatives libtool
@@ -21,19 +21,13 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+RESTRICT="tcl? ( test )"
+
src_unpack() {
# test
- if has test ${FEATURES} ; then
- if ! has userpriv ${FEATURES} ; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl ; then
- eerror "The tcl USE flag must be enabled to run tests."
- ewarn "Please note that turning on tcl installs runtime"
- ewarn "support too."
- eerror "Testsuite will not be run."
- fi
+ if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
fi
unpack ${A}
diff --git a/dev-db/sqlite/sqlite-3.3.17.ebuild b/dev-db/sqlite/sqlite-3.3.17.ebuild
index c9a2dc055e0b..ceb47dc1e7ac 100644
--- a/dev-db/sqlite/sqlite-3.3.17.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.17.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.17.ebuild,v 1.1 2007/05/03 19:57:57 betelgeuse Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.17.ebuild,v 1.2 2007/05/23 01:14:54 cardoe Exp $
inherit flag-o-matic eutils alternatives libtool
@@ -21,19 +21,13 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+RESTRICT="tcl? ( test )"
+
src_unpack() {
# test
- if has test ${FEATURES} ; then
- if ! has userpriv ${FEATURES} ; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl ; then
- eerror "The tcl USE flag must be enabled to run tests."
- ewarn "Please note that turning on tcl installs runtime"
- ewarn "support too."
- eerror "Testsuite will not be run."
- fi
+ if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
fi
unpack ${A}
diff --git a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
index ec10a4873843..21d2cb42c015 100644
--- a/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
+++ b/dev-db/sqlite/sqlite-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.17 2007/03/10 18:18:52 chtekk Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/sqlite/sqlite-3.3.5-r1.ebuild,v 1.18 2007/05/23 01:14:54 cardoe Exp $
inherit eutils alternatives
@@ -21,19 +21,13 @@ RDEPEND="tcl? ( dev-lang/tcl )"
SOURCE="/usr/bin/lemon"
ALTERNATIVES="${SOURCE}-3 ${SOURCE}-0"
+RESTRICT="tcl? ( test )"
+
src_unpack() {
# test
- if has test ${FEATURES} ; then
- if ! has userpriv ${FEATURES} ; then
- ewarn "The userpriv feature must be enabled to run tests."
- eerror "Testsuite will not be run."
- fi
- if ! use tcl ; then
- eerror "The tcl USE flag must be enabled to run tests."
- ewarn "Please note that turning on tcl installs runtime"
- ewarn "support too."
- eerror "Testsuite will not be run."
- fi
+ if has test ${FEATURES} && ! has userpriv ${FEATURES}; then
+ ewarn "The userpriv feature must be enabled to run tests."
+ eerror "Testsuite will not be run."
fi
unpack ${A}