summaryrefslogtreecommitdiff
path: root/dev-db
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-08-05 16:08:02 +0000
committerMike Frysinger <vapier@gentoo.org>2003-08-05 16:08:02 +0000
commit0638500649f080e18a033c5df580a8332b7c9255 (patch)
treeb38a6ba48df426e464dc2eaa9a735fbc476c6553 /dev-db
parentneed eutils for epatch (diff)
downloadgentoo-2-0638500649f080e18a033c5df580a8332b7c9255.tar.gz
gentoo-2-0638500649f080e18a033c5df580a8332b7c9255.tar.bz2
gentoo-2-0638500649f080e18a033c5df580a8332b7c9255.zip
need eutils for epatch
Diffstat (limited to 'dev-db')
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.6.ebuild30
-rw-r--r--dev-db/unixODBC/unixODBC-2.0.8.ebuild24
-rw-r--r--dev-db/unixODBC/unixODBC-2.2.2.ebuild32
3 files changed, 43 insertions, 43 deletions
diff --git a/dev-db/unixODBC/unixODBC-2.0.6.ebuild b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
index c3242334a391..1e777a9f55c0 100644
--- a/dev-db/unixODBC/unixODBC-2.0.6.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.6.ebuild
@@ -1,18 +1,18 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.17 2003/07/18 21:29:29 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.6.ebuild,v 1.18 2003/08/05 16:05:00 vapier Exp $
inherit gnuconfig
-IUSE="qt"
-
-S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
-HOMEPAGE="http://www.unixodbc.org"
+
LICENSE="GPL-2"
-KEYWORDS="x86 ppc hppa sparc alpha ~amd64"
SLOT="0"
+KEYWORDS="x86 ppc hppa sparc alpha ~amd64"
+IUSE="qt"
+
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
@@ -26,8 +26,8 @@ src_unpack() {
cp configure.in configure.orig
sed -e "s:AC_CHECK_LIB *( *c *,:AC_CHECK_FUNC(:" configure.orig >configure.in
cd gODBCConfig
- libtoolize
- aclocal
+ libtoolize
+ aclocal
cd ..
libtoolize
aclocal
@@ -47,21 +47,21 @@ src_compile() {
fi
export QTDIR=/usr/qt/2
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
${myconf} || die
make || die
}
-src_install () {
- mkdir -p ${D}/etc/unixODBC
+src_install() {
+ dodir /etc/unixODBC
make DESTDIR=${D} sysconfdir=${D}/etc/unixODBC install || die
rm -r ${D}/var
dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
prepalldocs
}
diff --git a/dev-db/unixODBC/unixODBC-2.0.8.ebuild b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
index fa3f7473654e..1b6e3e56b458 100644
--- a/dev-db/unixODBC/unixODBC-2.0.8.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.0.8.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.15 2003/06/19 17:28:12 wwoods Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.0.8.ebuild,v 1.16 2003/08/05 16:05:00 vapier Exp $
-IUSE="qt"
-
-S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
-HOMEPAGE="http://www.unixodbc.org"
+
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86 ~ppc ~hppa ~alpha"
+IUSE="qt"
+
DEPEND="virtual/glibc
>=sys-libs/readline-4.1
>=sys-libs/ncurses-5.2
qt? ( =x11-libs/qt-2.3* )"
-SLOT="0"
src_unpack() {
unpack ${A}
@@ -34,19 +34,19 @@ src_compile() {
fi
export QTDIR=/usr/qt/2
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
${myconf} || die
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
prepalldocs
}
diff --git a/dev-db/unixODBC/unixODBC-2.2.2.ebuild b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
index 1036ed01f04e..8af2d49a7782 100644
--- a/dev-db/unixODBC/unixODBC-2.2.2.ebuild
+++ b/dev-db/unixODBC/unixODBC-2.2.2.ebuild
@@ -1,20 +1,20 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.11 2003/07/31 19:36:23 rphillips Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/unixODBC/unixODBC-2.2.2.ebuild,v 1.12 2003/08/05 16:05:00 vapier Exp $
-IUSE="qt"
-
-S=${WORKDIR}/${P}
DESCRIPTION="ODBC Interface for Linux"
+HOMEPAGE="http://www.unixodbc.org/"
SRC_URI="http://www.unixodbc.org/${P}.tar.gz"
-HOMEPAGE="http://www.unixodbc.org"
-DEPEND="virtual/glibc
- >=sys-libs/readline-4.1
- >=sys-libs/ncurses-5.2
- qt? ( >=x11-libs/qt-3.0* )"
+
LICENSE="GPL-2"
-KEYWORDS="~x86 ~ppc ~hppa ~alpha amd64"
SLOT="0"
+KEYWORDS="~x86 ~ppc ~hppa ~alpha amd64"
+IUSE="qt"
+
+DEPEND="virtual/glibc
+ >=sys-libs/readline-4.1
+ >=sys-libs/ncurses-5.2
+ qt? ( >=x11-libs/qt-3.0* )"
src_unpack() {
unpack ${A}
@@ -36,19 +36,19 @@ src_compile() {
myconf="--enable-gui=no"
fi
- ./configure --host=${CHOST} \
- --prefix=/usr \
- --sysconfdir=/etc/unixODBC \
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc/unixODBC \
${myconf} || die
make || die
}
-src_install () {
+src_install() {
make DESTDIR=${D} install || die
dodoc AUTHORS COPYING ChangeLog NEWS README*
- cp -a doc ${D}/usr/share/doc/${PF}/html
- find ${D}/usr/share/doc/${PF}/html -name "Makefile*" -exec rm {} \;
+ find doc/ -name "Makefile*" -exec rm '{}' \;
+ dohtml doc/*
prepalldocs
}