summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2008-06-16 18:21:36 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2008-06-16 18:21:36 +0000
commit6697d967b0424c6a2cfcec8de987a84d823f66ea (patch)
tree963177fa408256541b2346201374befba0f6e63d /dev-db/tora
parentBug #222341, do not install the cvs-format emacs lisp file, as it clobbers th... (diff)
downloadgentoo-2-6697d967b0424c6a2cfcec8de987a84d823f66ea.tar.gz
gentoo-2-6697d967b0424c6a2cfcec8de987a84d823f66ea.tar.bz2
gentoo-2-6697d967b0424c6a2cfcec8de987a84d823f66ea.zip
Version bump, include fix to build w/ gcc-4.3 (#227497)
(Portage version: 2.1.5.5)
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/ChangeLog8
-rw-r--r--dev-db/tora/files/tora-gcc43.patch11
-rw-r--r--dev-db/tora/tora-1.3.23.ebuild86
3 files changed, 104 insertions, 1 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index 1bbc1ac9c0a2..e0a9644df0cd 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/tora
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.64 2008/03/21 10:04:27 dertobi123 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.65 2008/06/16 18:21:35 dertobi123 Exp $
+
+*tora-1.3.23 (16 Jun 2008)
+
+ 16 Jun 2008; Tobias Scherbaum <dertobi123@gentoo.org>
+ +files/tora-gcc43.patch, +tora-1.3.23.ebuild:
+ Version bump, include fix to build w/ gcc-4.3 (#227497)
*tora-1.3.22 (21 Mar 2008)
diff --git a/dev-db/tora/files/tora-gcc43.patch b/dev-db/tora/files/tora-gcc43.patch
new file mode 100644
index 000000000000..b39b94dcdbfb
--- /dev/null
+++ b/dev-db/tora/files/tora-gcc43.patch
@@ -0,0 +1,11 @@
+--- ext/loki/loki-0.1.6/src/SmallObj.cpp.orig 2008-06-16 20:10:07.676442069 +0200
++++ ext/loki/loki-0.1.6/src/SmallObj.cpp 2008-06-16 20:10:21.139446807 +0200
+@@ -22,6 +22,8 @@
+ #include <vector>
+ #include <bitset>
+
++#include <limits.h>
++
+ //#define DO_EXTRA_LOKI_TESTS
+ //#define USE_NEW_TO_ALLOCATE
+
diff --git a/dev-db/tora/tora-1.3.23.ebuild b/dev-db/tora/tora-1.3.23.ebuild
new file mode 100644
index 000000000000..1df39b9d5362
--- /dev/null
+++ b/dev-db/tora/tora-1.3.23.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.23.ebuild,v 1.1 2008/06/16 18:21:35 dertobi123 Exp $
+
+inherit eutils kde-functions
+
+IUSE="kde oracle debug oci8-instant-client xinerama"
+DESCRIPTION="TOra - Toolkit For Oracle"
+HOMEPAGE="http://tora.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-1-3-end-of-life.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+
+RDEPEND="${DEPEND}
+ xinerama? ( x11-libs/libXinerama )"
+
+DEPEND="=x11-libs/qt-3*
+ dev-lang/perl
+ <x11-libs/qscintilla-2.1
+ kde? ( >=kde-base/kdelibs-3.1
+ kde-base/arts )
+ xinerama? ( x11-proto/xineramaproto )
+ oci8-instant-client? ( dev-db/oracle-instantclient-basic )"
+
+S="${WORKDIR}/${PN}-1-3-end-of-life"
+
+pkg_setup() {
+ if use oracle && [ -z "$ORACLE_HOME" ] ; then
+ eerror "ORACLE_HOME variable is not set."
+ eerror
+ eerror "You must install Oracle >= 8i client for Linux in"
+ eerror "order to compile TOra with Oracle support."
+ eerror
+ eerror "Otherwise specify -oracle in your USE variable."
+ eerror
+ eerror "You can download the Oracle software from"
+ eerror "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-gcc43.patch"
+}
+
+src_compile() {
+ set-qtdir 3
+ set-kdedir 3
+
+ # Need to fake out Qt or we'll get sandbox problems
+ REALHOME="$HOME"
+ mkdir -p "$T"/fakehome/.kde
+ mkdir -p "$T"/fakehome/.qt
+ export HOME="$T/fakehome"
+ addwrite "${QTDIR}/etc/settings"
+
+ local myconf
+ myconf="${myconf} $(use_with kde)"
+ myconf="${myconf} $(use_with oracle)"
+ myconf="${myconf} $(use_with xinerama)"
+
+ if use oci8-instant-client; then
+ myconf="$myconf --with-instant-client"
+ fi
+
+ myconf="$myconf --with-qt-dir=/usr/qt/3"
+
+ #./configure $myconf || die "configure failed"
+ econf $myconf || die "configure failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}"
+ dodoc BUGS INSTALL NEWS README TODO
+
+ insinto /usr/share/applications
+ doins "${FILESDIR}"/${PN}.desktop
+ insinto /usr/share/pixmaps
+ doins "${FILESDIR}"/${PN}.png
+}