summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2003-08-19 17:58:43 +0000
committerDon Seiler <rizzo@gentoo.org>2003-08-19 17:58:43 +0000
commit0a2db82f7e7e86aa715a46e21a66f59894c08881 (patch)
tree6133b9167565bfaa95c3f7bcb5a227e75e31c631 /dev-db/tora
parentPatch to fix tora index tab crashing bug. TOra sf.net bug #784124 (diff)
downloadgentoo-2-0a2db82f7e7e86aa715a46e21a66f59894c08881.tar.gz
gentoo-2-0a2db82f7e7e86aa715a46e21a66f59894c08881.tar.bz2
gentoo-2-0a2db82f7e7e86aa715a46e21a66f59894c08881.zip
Patch to fix tora index tab crashing bug. TOra sf.net bug #784124
Diffstat (limited to 'dev-db/tora')
-rw-r--r--dev-db/tora/ChangeLog8
-rw-r--r--dev-db/tora/Manifest4
-rw-r--r--dev-db/tora/files/digest-tora-1.3.11-r11
-rw-r--r--dev-db/tora/files/tora-index-segfault.patch23
-rw-r--r--dev-db/tora/tora-1.3.11-r1.ebuild53
5 files changed, 86 insertions, 3 deletions
diff --git a/dev-db/tora/ChangeLog b/dev-db/tora/ChangeLog
index 2f044c9dbc4e..a726666707f6 100644
--- a/dev-db/tora/ChangeLog
+++ b/dev-db/tora/ChangeLog
@@ -1,7 +1,13 @@
# ChangeLog for dev-db/tora
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.11 2003/08/11 07:11:48 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/ChangeLog,v 1.12 2003/08/19 17:58:36 rizzo Exp $
+
+*tora-1.3.11-r1 (19 Aug 2003)
+
+ 19 Aug 2003; Don Seiler <rizzo@gentoo.org>; tora-1.3.11-r1.ebuild,
+ files/tora-index-segfault.patch:
+ Patch to fix tora index tab crashing bug. TOra sf.net bug #784124
*tora-1.3.11 (11 Aug 2003)
diff --git a/dev-db/tora/Manifest b/dev-db/tora/Manifest
index 744d0b9de349..ef163982d0c9 100644
--- a/dev-db/tora/Manifest
+++ b/dev-db/tora/Manifest
@@ -1,9 +1,9 @@
MD5 8419022a25ffe64dc4d8f9a3df4a72bf tora-1.3.11.ebuild 1247
MD5 f03fff2b63ddd77a03f5e3b3c756af27 tora-1.3.8.ebuild 1574
MD5 774b6c7f3e913fafbd06035f2c5cbc27 tora-1.3.10.ebuild 1245
-MD5 a141ecc2450f729708600bdee2fb150c tora-1.3.11-r1.ebuild 1250
+MD5 3f33109e1f248ded2c13ac9f5d378ae8 tora-1.3.11-r1.ebuild 1345
MD5 6df9df1a4a6aaf82cd39239ee161738c tora-1.3.9.2.ebuild 1249
-MD5 2de87a1d80588c421bb47102c94ef161 ChangeLog 2112
+MD5 599af146c7108873138dd13952471d6e ChangeLog 2109
MD5 0cb18bcf00a1bd7ccb4010bba81619ed files/tora-index-segfault.patch 619
MD5 94ba94945d843ea598f9b63230f31e8d files/digest-tora-1.3.9.2 71
MD5 69a9a5c1060cf3a1fcc5d9730ce9b00a files/digest-tora-1.3.10 70
diff --git a/dev-db/tora/files/digest-tora-1.3.11-r1 b/dev-db/tora/files/digest-tora-1.3.11-r1
new file mode 100644
index 000000000000..d176267843c8
--- /dev/null
+++ b/dev-db/tora/files/digest-tora-1.3.11-r1
@@ -0,0 +1 @@
+MD5 e056c5c84db1da8bccd7688a0aef9317 tora-alpha-1.3.11.tar.gz 2405314
diff --git a/dev-db/tora/files/tora-index-segfault.patch b/dev-db/tora/files/tora-index-segfault.patch
new file mode 100644
index 000000000000..ffe663a870a2
--- /dev/null
+++ b/dev-db/tora/files/tora-index-segfault.patch
@@ -0,0 +1,23 @@
+Index: tooracleconnection.cpp
+===================================================================
+RCS file: /cvsroot/tora/tora/tooracleconnection.cpp,v
+retrieving revision 1.80
+diff -u -r1.80 tooracleconnection.cpp
+--- tooracleconnection.cpp 9 Aug 2003 13:36:17 -0000 1.80
++++ tooracleconnection.cpp 10 Aug 2003 14:30:56 -0000
+@@ -202,11 +202,13 @@
+ }
+ virtual ~oracleQuery()
+ {
++ if(Query!=0) {
+ #ifdef OTL_STREAM_POOLING_ON
+- if (!SaveInPool)
++ if (!SaveInPool)
+ Query->close(false);
+ #endif
+- delete Query;
++ delete Query;
++ }
+ }
+ virtual void execute(void);
+
diff --git a/dev-db/tora/tora-1.3.11-r1.ebuild b/dev-db/tora/tora-1.3.11-r1.ebuild
new file mode 100644
index 000000000000..a2653d867294
--- /dev/null
+++ b/dev-db/tora/tora-1.3.11-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/tora/tora-1.3.11-r1.ebuild,v 1.1 2003/08/19 17:58:36 rizzo Exp $
+
+DESCRIPTION="TOra - Toolkit For Oracle"
+HOMEPAGE="http://www.globecom.se/tora/"
+SRC_URI="mirror://sourceforge/${PN}/${PN}-alpha-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+
+DEPEND=">=x11-libs/qt-3.0.0
+ dev-lang/perl
+ kde? ( >=kde-base/kdebase-3.1 )"
+
+pkg_setup() {
+ if [ "`use oci8`" -a ! $ORACLE_HOME ] ; then
+ einfo "ORACLE_HOME variable is not set."
+ einfo ""
+ einfo "You must install Oracle >= 8i client for Linux in"
+ einfo "order to compile TOra with Oracle support."
+ einfo ""
+ einfo "Otherwise specify -oci8 in your USE variable."
+ einfo ""
+ einfo "You can download the Oracle software from"
+ einfo "http://otn.oracle.com/software/content.html"
+ die
+ fi
+}
+
+src_unpack() {
+ unpack ${PN}-alpha-${PV}.tar.gz
+ cd ${P}
+ epatch ${FILESDIR}/tora-index-segfault.patch
+}
+
+src_compile() {
+ local myconf
+
+ use kde \
+ && myconf="$myconf --with-kde" \
+ || myconf="$myconf --without-kde"
+ use oci8 || myconf="$myconf --without-oracle"
+
+ ./configure --prefix=/usr --with-mono $myconf || die "conf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir ${D}/usr/bin
+ einstall ROOT=${D}
+}